Replies: 7 (Who?), Viewed: 3971 times.
Lab Assistant
Original Poster
#1 Old 21st Oct 2016 at 8:12 AM
Default General questions about downloads.
I have The Sims 3, and I know some stuff crosses over from Sims 2 to Sims 3 because I have done it before. I recently reinstalled the base game along with all the expansions and packs and afterward, I logged into Origin to get my Sims 4 base game and it updated my Sims 3 game. Now, it loads the game launcher when I go to install custom sims for the game. Do I have to uninstall and reinstall the sims 3 game so it doesn't update? Not sure how to fix this, and just floating a question out there.
Advertisement
dodgy builder
#2 Old 21st Oct 2016 at 11:06 AM
Have you actually checked what version you have? Do you have 1.69?
Lab Assistant
Original Poster
#3 Old 21st Oct 2016 at 11:02 PM Last edited by Glitchie : 21st Oct 2016 at 11:16 PM.
If it helps - I am running windows 10, (Thought I put that in original post, but looked and didn't, sorry) and anytime I click my sims 3 launcher icon, it pulls up the Origin log in before the sims 3 launcher is activated. However, it DOES say that I am running sims 3 version 1.69.43.024017. If need be, I can reinstall the base game and packs again. When I was doing that earlier, it said that my generations game was out of date and needed to be updated when I was online. Not sure what that was about.
Née whiterider
retired moderator
#4 Old 21st Oct 2016 at 11:15 PM
You can probably just right-click the file, select Open With, and then pick the launcher for whichever game the content is for.

What I lack in decorum, I make up for with an absence of tact.
Lab Assistant
Original Poster
#5 Old 21st Oct 2016 at 11:19 PM
No, Nysha, just tried that and it did the same thing. I think I am going to do a reinstall of it all and try that. I think its because it updated with Origin. Will post again to let you know if I find a solution or not.
Lab Assistant
Original Poster
#6 Old 22nd Oct 2016 at 1:44 AM
Okay, this is confusing. I am installing the base game, that I have to update before I install the first expansion - I do that and I install the other expansions until I get to Generations, then I get a message that the base game I have is newer than the Generations I have and that I need to be connected to the internet to update it if I continue. I think this is where my installs got messed up and why it won't let me install mods - because when online, it updates with Origin. Not sure how to fix this.
Department of Post-Mortem Communications
#7 Old 22nd Oct 2016 at 8:39 AM
Hm, I think you would be better served if you posted this in the Sims 3 section under Help.
If you let Origin update your game you will inevitably be updated to 1.69. And 1.69 is permanently tied to Origin, meaning that you will have to to be logged into Origin first before the Launcher starts.
If you have a disk version of the base game you can avoid it by not letting Origin do the update and patch manually instead. See here: http://simswiki.info/wiki.php?title...lp:TS3_Patching
Lab Assistant
Original Poster
#8 Old 23rd Oct 2016 at 1:41 AM
Got it fixed, thanks!!
Back to top