Replies: 127 (Who?), Viewed: 150023 times.
Page 5 of 6
#101 Old 1st Mar 2009 at 4:15 AM
I wanted to give a big thanks to issanet for the fix. That was what finally worked for me after many installs/uninstalls/re-installs. I had read all the FAQs and suggestions on Wiki and could never get the program to even open once. It never even showed in the task manager. But then I did as issanet's posts said, and have now made a couple sets of floors and walls. I was really beginning to wonder if the program was even worth all the trouble. THANK YOU SO MUCH!
Test Subject
#102 Old 10th Mar 2009 at 12:28 AM
Default Thanks
I want to say thanks to Issanet for coming up with this fix. I have actually been using HC for quite regularly, the last time was on 2/27/09. Then all of sudden yesterday it wouldn't work. No changes had been on my PC so I was at a lost. Finally I came across this fix and it worked. I am very, very happy. Thank You
Test Subject
#103 Old 10th Mar 2009 at 5:39 PM
Originally Posted by cameronsnan
Brilliant! But don't forget we have issanet to thank for the overwrite exe file

Indeed! Thank you both for your help. I was about this far --><-- to chucking the whole idea of using that program at all. I followed the instructions in your sig, replaced the exe file that issanet supplied a viola! I couldn't be more happy! Thank you! Thank you!
Test Subject
#104 Old 21st Mar 2009 at 3:36 AM
Thanks to Issanet for his tips on getting HomeCrafter to work again! Thanks again!

SLASHER BBS(TM), INC. (c) John Riley telnet:// or Website
Riley - Personal Computer Doctor (c) John Riley telnet:// or Website
rileypcmd and is a registered trademark of Riley's - Personal Computer Doctor
Test Subject
#105 Old 22nd Mar 2009 at 4:14 AM
Thanks Issanet for the fix to this!!!!
Lab Assistant
#106 Old 1st Apr 2009 at 2:57 PM
Thanks , this replacement exe works spot on .
Lab Assistant
#107 Old 2nd Apr 2009 at 8:09 AM
Thank you very much for this fix. I was going crazy trying to figure out what the heck.....???
Test Subject
#108 Old 16th Apr 2009 at 1:05 PM
Thanks to Issanet.. It works fine!
Test Subject
#109 Old 18th Apr 2009 at 7:26 PM
Thank you so much Miska! I've been having this problem for a while, and tearing the internet appart in order to find it. T WORKED!! THANK YOU!!!
Test Subject
#110 Old 20th Apr 2009 at 4:57 PM
that camronsnan seaid that u can use SimPE to make wall paper home crafter is a lot easeyer
Top Secret Researcher
#111 Old 30th Apr 2009 at 6:40 AM
Originally Posted by miska
Everyone . . .

After the previous post I tried something that I recalled reading while looking for answers to the Homecrafter problem yesterday.

When executing the program from the Windows Start menu (via the shortcut) rather than just left-clicking on it and executing 'normally', right-click on the short cut and select RunAs. Doing this will bring up a box that asks which user you want to run the program as/under. Just check to make sure your Windows UserName is selected (it should be by default) and click the 'OK' button. When I did this Homecrafter loaded quickly/ appeared before my eyes. How strange, but it worked!

It seems that Homecrafter now will only run under the default Administrator account, and not just an account with Administrative Rights. I don't run in default Administrator mode (as I keep that account for pure troubleshooting) and just use the account that I set up initially when installing Windows which by default has Administrative Rights.

Hope this Helps!

~*~ Miska ~*~

A belated HUGE "THANK YOU!", Miska! I had been trying for months to make this... monster to work, re-downloaded HCPlus from EA site again and again, only to fail miserably in the end. I am sincerely grateful! <3 <3
Test Subject
4th May 2009 at 11:15 PM
This message has been deleted by Lizzle.
Lab Assistant
#112 Old 22nd May 2009 at 3:14 PM
We built a new computer for me and after installing all Sims 2 things, I went and downloaded HomeCrafter from the official site but, like everyone else here, it didn't want to run. I thought it'd be a good idea since there may have been improvements in the tool (haha). Thankfully, I still had an "old" downloaded version on my other drive. Uninstalled crap version, installed "old" version. Yay! It works.
Lab Assistant
#113 Old 30th May 2009 at 7:58 PM
Issanet you deserve a monument for this big help! thank you!

Forever young...
Lab Assistant
#114 Old 1st Jun 2009 at 8:56 PM
I had the same.
Re-install helped.
Test Subject
#115 Old 19th Jul 2009 at 12:14 AM
Hey! I had issues as well running Homecrafter Plus, mainly cause I am on Vista. Anyway, I followed the 'if all else fails' and it worked. BUT! I have reformatted the computer since then, and now I went to download the old exe file again, and guess what! The link is broken, any help? Please and thank you.
#116 Old 20th Jul 2009 at 9:01 PM
isagrey, do you mean that the file that Issanet posted is no longer available? I still have his archive, and can re-upload it, if needed.

This Space Intentionally Left Blank
Original Poster
#117 Old 31st Jul 2009 at 12:10 AM
I also have the file stored on my website, just click the link in my signature below
Test Subject
#118 Old 24th Nov 2009 at 9:20 PM
HomeCrafter wont Install!!!
I have downloade The Sims 2 Homecrafter Plus and I cant install it.
I get a window that says Run/Chancel I press Run and noting And I dont know what to do. PS sorry my English is pritty bad
Test Subject
#119 Old 9th Aug 2012 at 3:50 AM
I know this thread hasn't been answered to in a very long time but it's the one I need so Im hoping someone somewhere will see it and help me out.

I have the home crafter tool and the problem I'm having is that it crashes when I click the 'floors' tab. the wall and the ground are fine, but the floors....not so fine. it crashes. I have deleted/moved all the user files like 'suggested' after reading so much stuff and pulling hair out. Un-installed and re-installed (a couple of times) but it's still doing it. so either I can't use this program for making floors which sort of sucks (excuse my bad language) or the walls I created will have to be deleted as well cause they have no floors to match. So that means I can't create anything and have to rely on others content to use. Which there is a lot of it and some just isn't what Im looking for. Hence me making my own. Enough of my ramblings....anyone have any tips that might help me out here?

Oh btw I also did the suggestion in post 19 and still nothing.
Lab Assistant
#120 Old 17th Aug 2012 at 11:50 AM
A kazillion thanks to Issanet
You made it possible to use HC again
Thank you :D
Test Subject
#121 Old 10th May 2013 at 10:16 PM
I have did some troubleshooting for The Sims 2 Homecrafter Plus. I was encountering the same issues as many of you that posted here. I ruled it out: Setup and Startup
1. Make sure your anitvirus is disabled when you download and install the program. Being cautious for no corrupted files being downloaded. Install and quit. 2.Run the Sims 2 game to associate the files to the program. (Make sure all other programs are not running) Then quit the game. 3. Then start The Sims 2 Homecrafter Plus and select what type of content you want to create exit. Create your content save and then close that program. Now you Must start your Sims 2 game once more for the file association to take place. Now close the program and open your The Sims 2 Homecrafter Pus and click on create content button and there's your content to price and describe and name. Suggestions: If this issue continue once the content is loaded just repeat these steps.

Living Life To The Fullest
Forum Resident
#122 Old 3rd Oct 2014 at 9:48 PM Last edited by telefen : 4th Oct 2014 at 12:34 PM.
Originally Posted by Kims*Designs
I also have the file stored on my website, just click the link in my signature below
I have tried that and my norton took it away stating there is a threat. I don't know I tried the other stuff and double clicking on it does nothing but that green wheel rotates for a few seconts trying to load. I don't know what is going on now several different Home crafter exe were stopped and removed from my desk top stating there is a threat which we took away. Update nevermind I shut off the stupid antivirus and it installed correctly no problem. Thanks you Kims design and others who provided. Hey Kim you exe. was the only one that worked for me BTW.
#123 Old 25th Dec 2015 at 9:32 PM
Originally Posted by Jasana_BugBreeder
Access Violation has nothing to do with the admin rights. It may be, for example, that program tries to access memory (in RAM) which doesn't belong to it, or something like that - that's program internal error, it has nothing to do with security settings.

Honestly, my Homecrafter doesn't work for ages, but I use SimPE and don't care about HCP, since SimPE is better
sim pe is a virus and it makes your game run slower Dont USE IT
Be like the 22nd elephant with heated value in space- Bark!
retired moderator
#124 Old 26th Dec 2015 at 1:46 AM
Originally Posted by CMPunkGTS96
sim pe is a virus and it makes your game run slower Dont USE IT

Sounds like you downloaded something that was definitely NOT SimPE. I've been using SimPE for around 10 years with no problems.

I will choose a path that's clear- I will choose free will
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
Test Subject
#125 Old 29th Mar 2016 at 10:30 AM
Help! still cant load HC even after doing Issanet's method. Any help would be appreciated.
Page 5 of 6
Back to top