Replies: 4 (Who?), Viewed: 4053 times.
Original Poster
#1 Old 30th May 2019 at 2:21 PM
Default Spawning an accessory object
I made an edit to sim wardrobes checkbook to allow sims to stand up and write their checks -- I just bypassed all of the sit down stuff and subbed in the BV hotel desk check in animation -- and it looks great except I can't get a pen to spawn. (video of it in use )

Specifically I edited Interaction - Write Check - From Seated Line 0x20

From the looks of it the pen is created from an event tree but even with the tons of examples where the pen is used I can't figure it out. Nothing I've tried has worked and I'm ready to call this as good as it's going to get. But it seems like it would be dead simple for someone who knows what they're doing? I don't know but I thought I'd ask to see if anyone can help me with this before I share.
Download - please read all instructions before downloading any files!
File Type: zip (305.3 KB, 15 downloads) - View custom content
#2 Old 30th May 2019 at 9:22 PM
@Honeywell What surface does this work on? I made an edit that I wanted to test, and I put it on the counter, desk and dining table, but the Sims are just stomping because there's no chair available.
Original Poster
#3 Old 30th May 2019 at 9:44 PM
It needs to be placed on the floor with move objects on -- I co-opted the write from the floor option so the checkbook still works with desks. For looks, it's height adjustable and can be raised to counter height but, as you know, it won't work if it snaps into any slots.

Thank you for taking the time to look at this.
#4 Old 31st May 2019 at 3:11 AM
No problem. The issue isn't actually with the spawning. That part of the code isn't getting run because of the parameter checks. In Event Homework Start, if you point line 3 True and False to line 5, and line 5 true and false to Line 6, the pen spawning code will always be run. Which, of course isn't a fix, since I'm sure those parameter checks are there for a reason, but I just did it that way to check the spawning code. I also kept getting an error that the check wasn't created, even before I edited the package, but that could just be because of a mod conflict on my end or something.
Original Poster
#5 Old 31st May 2019 at 11:03 AM Last edited by Honeywell : 31st May 2019 at 11:19 AM.
There's a second part to the mod which contains the check which is your error but that was incredibly helpful. Thank you.

Forcing the pen animation is throwing iteration errors but it let me see that no pen is infinitely better than a poorly timed one. Before I posted I tried to animate the pen with the hotel check in code and couldn't... which was so frustrating knowing it's all right there if I just knew more. But it is what it is and it doesn't look to be as "dead simple" as I imagined so I'm glad I asked. Even without the pen I'm really happy with this so I'm ready to toss this in the good enough for my purposes bucket and move on.
Back to top