Replies: 6 (Who?), Viewed: 943 times.
Instructor
Original Poster
#1 Old 13th Mar 2020 at 7:44 PM Last edited by vegan_kaktus : 13th Mar 2020 at 9:59 PM.
Default Can't figure out why my CEP-extra won't work :-(
Short said: I wanted to add the mousepad as a second subset to the cheap computer from BG (aka moneywell computer), so I kind of followed this tutorial and looked at HL's fruitbowl CEP-extra to figure out how to make my own. It went pretty well, but when I tested it, the mousepad was invisible and the computer flashed blue. I have no idea why it won't work, I can't seem to see anything off at all in my files? Does someone know what I've done wrong? Idk if it matters but I extracted the gmnd from _EnableColorOptionsGMND, not from the objects package. Also, hopefully this is in the right forum. Any help is much appreciated :-)

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Advertisement
Dancing Flamingo
staff: administrator
#2 Old 13th Mar 2020 at 7:54 PM
In the GMND and SHPE your subset is named computercheap_mousepad, but in the GMDC your subset is named mousepad. On another note, the instance of 5000 will likely conflict with another CEP. The best practice for instance number of the MMAT is to hash the subset name (or default string name) because it's most likely unique. Also, the Family value in the MMAT should be a random hash and different from the original subset (maybe you knew this bit though).
Instructor
Original Poster
#3 Old 13th Mar 2020 at 7:57 PM Last edited by vegan_kaktus : 13th Mar 2020 at 9:57 PM.
Thank you so much for the quick reply! Ahhh I see I see, this I did not know. I'll try it out, thank you! :-))

Edit: ha-ha, I must have done something wrong now as well, because the computer is still flashing blue. The mousepad however, is visible but looks like this:

I don't know what I'm missing? I used the hash generator, edited the family (dstring) + instance number in the MMAT. Also edited the mousepad's subset name in the gmdc. It still won't work though :-(

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Dancing Flamingo
staff: administrator
#4 Old 13th Mar 2020 at 9:31 PM
One step forward, two steps back. That texture on the mousepad means it's not finding the texture linked. Something I didn't notice before was the instance number of the txmt. I'm guessing you cloned the computer one and renamed it. When you do that with a resource, you need to select the Fix TGI link on the right side in plugin view. This is not Fix Integrity. What Fix TGI does is hash the instances to the resource name. The same goes for your texture name, you'll want to hit the Fix TGI link below the resource name.

I did this Fix TGI on the latest one you posted and tried in my game, and all textures show. Maybe you have an older file somewhere? Or maybe this isn't a fresh catalog selection?
Screenshots
Instructor
Original Poster
#5 Old 13th Mar 2020 at 9:48 PM Last edited by vegan_kaktus : 13th Mar 2020 at 10:09 PM.
Quote:
Originally Posted by HugeLunatic
One step forward, two steps back.

Now if that doesn't describe me fiddling around with stuff in SimPE lol!

Oh yikes, I'm so embarrassed asdfghjkl. I never understood what Fix TGI was so I just simply.... forgot about it it seems? Anyways, a HUGE thank you!! (or should I say, a huge lunatic thank you? *badum tss*.. I'll see myself out.. haha). My bad puns aside, it indeed works now! :-D Thank you very much!!

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Instructor
Original Poster
#7 Old 15th Mar 2020 at 3:50 PM
I'm back with another problem, ha! I remapped the mousepad, added it to all of EA's computers and then followed your tutorial here (which was very detailed and nice - thank you!) and successfully slaved the mousepads back to the cheapcomputer's one. For some weird reason, recolors for the mousepad only shows up for the cheapcomputer and expensive computer? Not for the teen or techie one, although the subset does and they're slaved. Everything is the same in the files from what I can tell, so I'm not sure what I'm doing wrong?

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Back to top