Replies: 8 (Who?), Viewed: 647 times.
Instructor
Original Poster
#1 Old 21st Jun 2020 at 8:23 PM Last edited by vegan_kaktus : 22nd Jun 2020 at 3:50 PM.
Default Why won't my hair default change hair color?
I apologize for the bad title, I'm not sure how to explain it better. My problem is this:

I'm currently defaulting the maildelivery's hair but I can't figure out why the hairalphas (hairalpha5 & hairalpha3) won't change color when changing colors (woah, English). Example:


The hair is slaved to two of EA's hairs, amcaesar (scalp/hair group) & afhairpixie (hairalpha5+hairalpha3). The scalp (aka hair group) is the only one changing color as it should (like seen on the image above). I have no idea why hairalpha5 and hairalpha3 won't change. When I change the txmt references in the shpe the hairalpha5+3 changes, but once again for all colors. Any ideas? I can't figure out what I'm missing :-(

Edit: Attached my file below, if anyone would like to take a look at it. And oh, hairalpha5 & hairalpa3 is using the same txmt file, in case you're wondering. Also, I know the hair has some transparency issues on the right, I'm going to fix this later!

Edit #2: removed file.

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Advertisement
Mad Poster
#2 Old 21st Jun 2020 at 9:18 PM
There's a bit of a mismatch between the subset names in the mesh file and the PropertySet resources, but I'm not sure if that's got anything to do with the problems (hair_alpha3/5 and hairalpha3/5). Not sure if that's enough to cause this problem, though. CAS files are occasionally on the weird side with things they accept and things they absolutely do not accept whatsoever compared to objects.

Looks like they're slaved to the black hair in the SHPE (unless I'm overlooking something? I don't usually make default hairs even if I occasionally poke around in the files), so I'd say it seems kinda normal that they're showing up black. You may have to slave the rest of the colors to their respective colors, too. Eyebrows don't get affected by the hair color that shows, just the genetic (or colored) hair color of the sim. Not entirely sure with the scalp, but those have a tendency to do weird things anyway. If that's not what you want, you may have to add TXMTs slaved to the ingame textures (to avoid TXTRs).
Instructor
Original Poster
#3 Old 21st Jun 2020 at 11:15 PM Last edited by vegan_kaktus : 21st Jun 2020 at 11:49 PM.
Thank you for taking the time to help! Hairalpha5+3 are using the same txmt so even if there are any mismatchs in the PropertySet resources, it wouldn't make a difference :-/ (and since the scalp and hat shows up correctly for every color, it's not a problem with them either, which leaves both the alphas in the middle - and they are referencing the same txmt).

Perhaps I'm misunderstanding you now (or you misunderstood me, since my explanations are.. very bad ahah) but the thing is I want the hair to change colors like the scalp does, like it's supposed to do. For some reason, the shpe is the one "controlling" the hairalphas colors, when it should be the 3D ID reference files (I'm really terrible with words, I'm sorry if this doesn't make any sense at all!)

Quote:
Originally Posted by simmer22
[...]you may have to add TXMTs slaved to the ingame textures (to avoid TXTRs).

I'm afraid I don't understand you here, both the shpe and the 3D ID references are referencing EA's txmts, never the "pure" txtrs. So I'm not sure what you mean by this? Or did I perhaps misunderstand you?

I'm starting to think this might be a case of CAS not "accepting" things like you mentioned, since I can't seem to see any problem. The mail delivery's hair is always black, so I assume this could work but, it feels bitter sharing it like this :-(

Also, my bad about the eyebrows! I completely forgot they don't have anything to do with the hair. Sometimes my brain makes weird connections, like the time I thought getting bit by a mosquito equalled getting a cold ahah. I legit thought that for a second, out of nowhere!

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Mad Poster
#4 Old 21st Jun 2020 at 11:54 PM
Brain fart on the SHPE and 3DIR, because there is such a thing as 3DIRs, but my brain says "no, we don't open up those because they have to load for like five seconds, so put on ignore!"...

Are you sure you have the right Material Definition lines in the 3DIR linked to the right colors? You'll want to compare the middle two MD lines with the ones in each file with the ones in the Pixie hair. Could be a couple of those are switched around, color-wise.
Instructor
Original Poster
#5 Old 22nd Jun 2020 at 12:02 AM
Hahaha!

I am pretty sure yes :-( I'll extract them again and re-do them tomorrow though, just in case!

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Mad Poster
#6 Old 22nd Jun 2020 at 12:10 AM
I'm really tired (and my brain is obviously not fit for rocket science tonight) so I'm not entirely sure I've copied off this info properly, but these are the instance numbers I found in the MDs in the Pixie OFB hairs (It appears you'll want the middle ones). You may want to check just to be sure. They do appear to be right in the file.

0xFFD67E54
0xFF0C2FBC
0xFFDF1099
black


0xFF94A585
0xFF863DB4
0xFF71F50A
red

0xFFFB70A7
0xFF21214F
0xFFF21E6A
Brown

0xFF6B2353
0xFFB172BB
0xFF624D9E
Blond

There is however a hair called "afhairpixie_EP7_(color)" which potentially could be causing issues if it's one of those that got updated with a later pack, especially if the game for some reason doesn't have a clue which files to draw info from.
Instructor
Original Poster
#7 Old 22nd Jun 2020 at 1:22 PM Last edited by vegan_kaktus : 22nd Jun 2020 at 1:46 PM.
Thank you!

I extracted the txmts from freetime this time and re-did the GZPS and 3D ID references, and there's improvement!

Now it's only hairalpha5 which isn't changing color as it should


Edit: I fixed it! What I did: used the txmts for the pixie hair from freetime, merged the groups hairalpha5+3 (named it hairalpha3) in milkshape, got rid of the hairalpha5 in the shpe, GZPS and 3D ID references and now the hair changes color as it should!

It seems I got rid of some transparency issues when merging them as well

(Also, fyi, I'm using the female to male pixie hair conversion by Andie here. So it's not EA's female pixie hair, just thought I'd mention that.)

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Mad Poster
#8 Old 22nd Jun 2020 at 2:37 PM
(I understood that when I saw the mesh name, as those conversions and a few variations of them used to be some of my favorite hairs a loooong time ago - I had a few sims who rocked those hairs. We're talking 2007 or some such, so it's a reeeeally long time )

Happy you got it fixed
Instructor
Original Poster
#9 Old 22nd Jun 2020 at 3:49 PM
Ah right haha! :-D and thank you for the help, as always!

You can find more of my downloads over at my tumblr: https://vegan-kaktus.tumblr.com/downloads
Back to top