Replies: 7 (Who?), Viewed: 1027 times.
Lab Assistant
Original Poster
#1 Old 20th Jan 2020 at 8:25 PM
Empty CC thumbnails bug
Hi,
a few days ago Epi7 informed me that my deco object: TinyLollipopTree-LightGreen-MESH could corrupt thumbnails of CC items.
( game sometimes generated empty thumbnails for new decorative content). My mesh file contained second CRES resource - removing it fixed the problem.
I've recalled that I extracted thumbnailShape cres from ChinaVase and added it to my mesh file while doing a tutorial on custom thumbnail camera.
I didn't manage to modify my object's thumbnail though.. So I forgot all about it . I didn't get empty thumbnails problem. A few weeks later I shared this package on MTS.
According to Epi, some (if not all) affected items were cloned from China Vase.
(I've already updated my Potted Plants Collection. To anyone who's downloaded the Lollipop Tree and experienced this: I'm very sorry, please reupload and refresh your thumbnails).

So, yeah, the problem is solved, kind off.. But it's still bugging me
how is it possible that a file that did no harm in my game, can act as a default thumbnail camera replacement in other peoples games?
I've included the messed-up package in case somebody would like to have a look (I've changed the GUID).
Download - please read all instructions before downloading any files!
File Type: zip CorruptedLollipopTree-MESH.zip (40.0 KB, 7 downloads)
Advertisement
Inventor
#2 Old 21st Jan 2020 at 4:23 AM
The TinyTreeDecorativebyPineappleForest_thumbnailShape_cres is a problem. It has the wrong group value, it should be 0x1C050000 as that is how it's called and internally named and it has the wrong instance value, you need to 'fix TGI' on it. It is probably overriding a default file and messing with the thumbnail of a default item.
Lab Assistant
#3 Old 21st Jan 2020 at 4:08 PM
There's much easy way to fix objects thumbnails. It uses actual object size so you don't need fiddling with custom thumbnails. Try this tutorial, maybe it will fix the issue.
Mad Poster
#4 Old 21st Jan 2020 at 5:24 PM
It does look like the first CRES instance has the original ThumbnailExtension camera, so deleting this according to the thumbnail fix would work. Several deco items have this issue, and there's no point in going through a complicated tutorial when you can fix it in a much simpler way.

The current file has issues (like what Chris mentioned on the Group number of the second CRES you probably added), so it is possible something you did while trying to add the camera has caused the issue for other objects. You may want to find the old file (without any camera/thumbnail edits) and do the Thumbnail Extension fix on this one (and the rest of the items with possibly borked thumbnails).

I don't think I've found any deco items this fix didn't work on, at least not out of items I've cloned. Not all items have these problems - I've taken to use the sculpture of a wooden man (the kind you use for drawing poses in art class) for smaller deco items, because it doesn't have thumbnail issues and is less annoying to work with than a lot of the vases.
Lab Assistant
Original Poster
#5 Old 22nd Jan 2020 at 12:27 PM
Quote:
Originally Posted by Chris Hatch
It is probably overriding a default file and messing with the thumbnail of a default item.

Thanks Chris. I probably didn't perform "fix TGI" as the tutorial didn't mention it (?). I just did "integrity fix". I think there should be a warning in the header of that tutorial.
If I had known that package containing imported thumbnailShape has the potential to change other thumbnails, I wouldn't have touched that.

@Influence & @Simmer22
Thanks . Yes, I know the "easy way" to fix thumbnails. The thing is, my object had oversized shadow under it..
And as thumbnail camera renders all meshes present in the package, even if invisible - the item in the thumbnail was too small.
Importing much smaller shadow was the solution here. But naturally I had to try 'the hard way'..
Mad Poster
#6 Old 22nd Jan 2020 at 3:09 PM
Maybe reduce the shadow and/or remove it from the bounding box?
(One way to remove it from the bounding box is to first import just the shadow mesh, then just the rest of the mesh - which will remove the shadow from the bounding mesh. I think the camera only takes into account the bounding mesh, but I'm not entirely certain).
Lab Assistant
Original Poster
#7 Old 26th Jan 2020 at 10:38 AM
Quote:
Originally Posted by simmer22
I think the camera only takes into account the bounding mesh, but I'm not entirely certain).

I'm not sure about furniture, beds and such. But in case of decorative items, camera renders everything
Inventor
#8 Old 26th Jan 2020 at 1:53 PM
The shadow is not in the bounding box, the icon does normally include shadows. One of the tour vehicles has an unlinked shadow texture so it shows in sim's queue with flashy blue underneath. You would be better off to redo the shadow texture as it is a little big, off centre and it's round but its under a square pot so it should be square.
Back to top