Replies: 9 (Who?), Viewed: 178 times.
Top Secret Researcher
Original Poster
#1 Old 1st Jul 2020 at 9:19 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life, Island Paradise, Into the Future
Default Mods folder not working
Winblows 10 hosed it's own file system on my PC (this is why M$ Winblows is not an operating system: by definition, an operating system can never hose it's own file system), so I reinstalled from disc. After reinstalling Sims 3, I proceeded to setup my mods, following all the instructions for unpacking the FrameworkSetup compressed file. I'm not new to this, so I know everything is in the correct place. However, when launching the game, the introduction still plays (hence my thread title). I don't see any recent threads about this issue, so I'm looking for advice/guesses about what is going wrong. Thanks for any constructive information.

TS2 and TS3: Where adult sims potty train their toddlers.
TS4: Where adult sims make Angry Poops.

Which game is made for the juvenile minded?
Advertisement
Site Helper
#2 Old 1st Jul 2020 at 11:13 PM
Quote:
Originally Posted by zigersimmer
Winblows 10 hosed it's own file system on my PC (this is why M$ Winblows is not an operating system: by definition, an operating system can never hose it's own file system), so I reinstalled from disc. After reinstalling Sims 3, I proceeded to setup my mods, following all the instructions for unpacking the FrameworkSetup compressed file. I'm not new to this, so I know everything is in the correct place. However, when launching the game, the introduction still plays (hence my thread title). I don't see any recent threads about this issue, so I'm looking for advice/guesses about what is going wrong. Thanks for any constructive information.



Not sure exactly what your problem is or all the steps you have taken. I would try clearing the scriptcache file to see if this helps.
Top Secret Researcher
Original Poster
#3 Old 1st Jul 2020 at 11:30 PM
Quote:
Originally Posted by fascisthater
Not sure exactly what your problem is or all the steps you have taken. I would try clearing the scriptcache file to see if this helps.


Thanks for helping. I deleted all of the cache files (because they are frequently the cause of problems), but that did not help in this case. I'm banging my head against a wall here. Must get mods working. This game sucks without Twallan mods.

My C:\Users\Zigersimmer\Documents\Electronic Arts\The Sims 3\Mods folder has the Overrides and Packages folders (with nointro and nobuildsparkles in Packages), and the Resource.cfg file is:

Priority 501
DirectoryFiles Files/... autoupdate
Priority 1000
PackedFile Overrides/*.package
PackedFile Overrides/*/*.package
PackedFile Overrides/*/*/*.package
PackedFile Overrides/*/*/*/*.package
PackedFile Overrides/*/*/*/*/*.package
Priority 500
PackedFile Packages/*.package
PackedFile Packages/*/*.package
PackedFile Packages/*/*/*.package
PackedFile Packages/*/*/*/*.package
PackedFile Packages/*/*/*/*/*.package
Priority 499
PackedFile Test/*.package
PackedFile Test/*/*.package
PackedFile Test/*/*/*.package
PackedFile Test/*/*/*/*.package
PackedFile Test/*/*/*/*/*.package
Priority -50
PackedFile Probation/*.package
PackedFile Probation/*/*.package
PackedFile Probation/*/*/*.package
PackedFile Probation/*/*/*/*.package
PackedFile Probation/*/*/*/*/*.package
Priority 500
PackedFile DCCache/*.dbc

Everything looks correct, but still, no workey.

TS2 and TS3: Where adult sims potty train their toddlers.
TS4: Where adult sims make Angry Poops.

Which game is made for the juvenile minded?
Scholar
#4 Old 2nd Jul 2020 at 12:07 AM
Do you have OneDrive enabled? You might have another game folder there. This was advice from @igazor.
https://www.modthesims.info/showthr...871#post5609871
I updated later on what worked for me in that thread.
Top Secret Researcher
Original Poster
#5 Old 2nd Jul 2020 at 1:20 AM
Quote:
Originally Posted by 310175
Do you have OneDrive enabled? You might have another game folder there. This was advice from @igazor.
https://www.modthesims.info/showthr...871#post5609871
I updated later on what worked for me in that thread.


Thanks for the suggestion. I uninstalled OneDrive (I have no need for it), then deleted my Mods folder and the cache files, then unpacked FrameworkSetup.zip again. Still no bueno.

TS2 and TS3: Where adult sims potty train their toddlers.
TS4: Where adult sims make Angry Poops.

Which game is made for the juvenile minded?
Mad Poster
#6 Old 2nd Jul 2020 at 4:04 AM
Please check the Modification Date/Time of the DeviceConfig.log file in your TS3 user game folder (Right-Click > Properties on the file). It should exactly match the last time you started up the game. If you aren't sure when that was, close everything out and start the game; the Modification Date/Time on that file should update instantly. If it's not doing that, then you have another user game folder on your system someplace that the game is reading from/writing to rather than the intended one.

Also, let's make sure we are testing the right thing here on the Intro still playing. Are you really getting the entire Intro movie or is it just the very beginning part where someone screams "Maxis!" at us? It's been so long since I've seen this I forget exactly what it looks like now. The NoIntro mod included in the downloadable Framework doesn't suppress the Maxis! part as EA added that bit in later. There are other NoIntro mods that will do so, though.
Top Secret Researcher
Original Poster
#7 Old 2nd Jul 2020 at 4:21 AM
Quote:
Originally Posted by igazor
Please check the Modification Date/Time of the DeviceConfig.log file in your TS3 user game folder (Right-Click > Properties on the file). It should exactly match the last time you started up the game. If you aren't sure when that was, close everything out and start the game; the Modification Date/Time on that file should update instantly. If it's not doing that, then you have another user game folder on your system someplace that the game is reading from/writing to rather than the intended one.

Also, let's make sure we are testing the right thing here on the Intro still playing. Are you really getting the entire Intro movie or is it just the very beginning part where someone screams "Maxis!" at us? It's been so long since I've seen this I forget exactly what it looks like now. The NoIntro mod included in the downloadable Framework doesn't suppress the Maxis! part as EA added that bit in later. There are other NoIntro mods that will do so, though.


Thanks, igazor. The DeviceConfig.log updates to exactly the time I launch the game. I do get the full intro playing. I have only reinstalled the base game so far, so I don't get the Maxis scream, but I do get the EA logo with the plumbobs, followed by the low-rez cutscene that EA made with the pre-release version of Sunset Valley.

I've tried moving the Packages folder out of Mods and up one level to Sims 3, not expecting that to work. And, of course, it did not.

TS2 and TS3: Where adult sims potty train their toddlers.
TS4: Where adult sims make Angry Poops.

Which game is made for the juvenile minded?
Mad Poster
#8 Old 2nd Jul 2020 at 4:34 AM
Wait a minute...this is a disc install which is fine, but is your game unpatched by any chance? The Mods Framework as we know it today will only work on Patch 1.12 and higher, the one that was released alongside of Ambitions. Prior to that the Mods folder had to be setup within the Program Files and some extra steps taken with a dll file or two but many modern mods don't work properly that way.

If you are patched up by way of the Launcher, I would suggest running the SuperPatcher to 1.67 (even if that's where you already are) as the Launcher is notorious for not finishing the job and reporting that it's done anyway and see if that fixes things.
https://help.ea.com/en-us/help/the-...3-super-patcher

If on a suitable patch level, you also may want to start over with a brand new user game folder (pull the current one out to spawn a new one) rather than just pulling the Mods folder out and replacing it.
Top Secret Researcher
Original Poster
#9 Old 2nd Jul 2020 at 4:56 AM
Quote:
Originally Posted by igazor
Wait a minute...this is a disc install which is fine, but is your game unpatched by any chance? The Mods Framework as we know it today will only work on Patch 1.12 and higher, the one that was released alongside of Ambitions. Prior to that the Mods folder had to be setup within the Program Files and some extra steps taken with a dll file or two but many modern mods don't work properly that way.

If you are patched up by way of the Launcher, I would suggest running the SuperPatcher to 1.67 (even if that's where you already are) as the Launcher is notorious for not finishing the job and reporting that it's done anyway and see if that fixes things.
https://help.ea.com/en-us/help/the-...3-super-patcher

If on a suitable patch level, you also may want to start over with a brand new user game folder (pull the current one out to spawn a new one) rather than just pulling the Mods folder out and replacing it.


You are a genius! I ran the patcher immediately after installing, but it looks like it did not update everything it was supposed to. I just ran it again, and now the mods are working. Thank you sooooooooooooooo much!

TS2 and TS3: Where adult sims potty train their toddlers.
TS4: Where adult sims make Angry Poops.

Which game is made for the juvenile minded?
Mad Poster
#10 Old 2nd Jul 2020 at 5:01 AM
If I were really a genius, I would have recognized the issue seven posts ago but it wasn't until you mentioned base game only that the alarm went off. Anyway, glad that's all that was wrong and you're welcome.
Back to top