Replies: 82 (Who?), Viewed: 84699 times.
Page 3 of 4
Ms. Byte
Original Poster
#51 Old 15th Jul 2010 at 10:39 PM
Originally Posted by cwurts00
I downloaded the latest version, but no matter how many times I reload it, if I use the bi-directional option, it uses the "right" BGEO in both directions.

Can you post/send/pm me the package so I can take a look and see if it does the same thing in my game?
Lab Assistant
#52 Old 15th Jul 2010 at 10:53 PM Last edited by cwurts00 : 15th Jul 2010 at 11:16 PM.
Here is the rar with three of the sliders. They only show up in adult males.
Download - please read all instructions before downloading any files!
File Type: rar CAS sliders.rar (22.0 KB, 62 downloads) - View custom content
File Type: rar facemeshes.rar (155.6 KB, 52 downloads) - View custom content
Lab Assistant
#53 Old 8th Sep 2010 at 12:16 AM
Hey, it's me again. XD

Okay, so now I've used my own sliders for some months, and everything worked fine. Today I installed WA, and updated both games with the latest patch.
All my CC's and Custom Sliders, which I've downloaded from MTS, work as fine as they did before. Except for my own sliders. They show up in CAS, and I can even use them in CAS, to create my sims, BUT when I start playing with them, they look as if my sliders did no changes to them. ôo
I don't get it. All the other custom sliders work just fine. >.< Why mine not? Q___Q
Ms. Byte
Original Poster
#54 Old 8th Sep 2010 at 1:47 AM
I'm sorry, cwurts00, I didn't see your second post until now. It looks like you were using the original MorphMaker, which had a bug causing the left direction to use the right-direction morph. That was fixed in an update on 7/4, and why I didn't make the connection before I haven't a clue. Sorry again!

Melody2: Did you update whatever core mod you're using to increase the number of sliders the game can use? Although if your sliders work in CAS but not in the game that's not the answer. Are you maybe playing at low sim resolution and only did lod0 meshes??
Lab Assistant
#55 Old 8th Sep 2010 at 2:07 AM
I'm playing at high sim resolution. And I did lod0 and lod1, as written in the tutorial...
I already used the sliders before in my basegame. They worked fine there. I think it must have something to do with the WA EP... or maybe the latest patch, dunno.
Well, I just noticed, that you can see the changes on the picture of the sim at the bottom of the screen in the game... You know, that tiny thumbnail on the user interface..
But that's it. <.<
Ms. Byte
Original Poster
#56 Old 8th Sep 2010 at 12:17 PM
How very strange! Did you try deleting SimCompositerCache.package? I'm just guessing here... Can you upload one of your sliders for me to look at?
Lab Assistant
#57 Old 8th Sep 2010 at 2:28 PM
Indeed, it's VERY strange... ôo
Well, yeah. I just figured out, that this might help. So I deleted the Cache files in my Sims 3 folder, and then restarted the game. But that didn't change anything. Unfortunately...

Of course, here it is:
Download - please read all instructions before downloading any files!
File Type: rar sliders.rar (2.2 KB, 31 downloads) - View custom content
Ms. Byte
Original Poster
#58 Old 9th Sep 2010 at 2:20 AM
Did the same thing in my game.

Looking at the BGEO information, you have the same starting vertex ID, 38, for both lod0 and lod1. Lod1 for the YA male main face mesh should start with vertex 1116. Since all the other information for lod0 and lod1 is the same, I suspect you used the same morph mesh for both lod0 and lod1 when you made the slider. It doesn't work that way - the vertices of all the lods are numbered sequentially (including the other face part meshes) and the numbers are what the game uses to do the morphing. If it's using lod1 and doesn't find any of the vertex numbers for the lod1 mesh, it won't do the morph.

Why it should have worked before and not now I don't know, unless the patched game treats the lods differently and maybe uses lod1 for game closeups while lod0 is still used for CAS and thumbnails.
Lab Assistant
#59 Old 9th Sep 2010 at 12:55 PM
Well, okay. Thx so far.

So I have to do what? Make 2 seperate morphs for each lod? Cause, yeah. I used the same morph for both lod0 and lod1...
Then I will have to make a seperate GEOM file for the lod1 thing?
Lab Assistant
#60 Old 9th Sep 2010 at 1:38 PM
Okay, now I saved 2 seperate GEOM files, but with the same mesh in milkshape... Then I used the first one for the lod0 and the 2nd one for lod1. But it didn't change anything. It's still not working. -__-
I don't get it. <.< What exactly is the problem, and what do I have to do? ôo
Ms. Byte
Original Poster
#61 Old 9th Sep 2010 at 5:42 PM
I don't totally understand what you're doing so I'll give some basic background. There are separate meshes for each lod, and in the case of the face meshes there are also separate parts of the head. The mesh naming convention is [age][gender]face_lod[lod number][_part number].

For example:

amface_lod0_2 is the mesh for lod0 for the main face for adult males. (very high detail)
amface_lod1_2 is the mesh for lod1 for the main face for adult males. (high detail)
amface_lod2_1 is the mesh for lod2 for the main face for adult males. (medium detail)
lod3, the lowest detail, has no vertex numbers and can't be morphed so we can leave that out.
There's also amface_lod0, amface_lod0_1, etc. which are meshes for the teeth and eyeballs, I think. (Don't have them in front of me.) There are different lod versions of those parts as well. For lod2 and lod3, the main face is combined with one of them.

Anyway, the point is that there are different meshes for the face at lod0, lod1, lod2, and lod3. The vertices are numbered consecutively through all of them, starting at lod0 and ending with lod2. (lod3 has no numbers.) A morph can only be applied to the exact same mesh it was created from, and the lod0 and lod1 meshes are different with lod1 having fewer vertices. You've been making lod0 twice and no lod1.

You already have a morph mesh of the lod0 face. What you need to do is start with the lod1 face mesh and make a morph of that, the same way you did with lod0. Then make your slider with the two morph meshes loaded in lod0 and lod1 respectively.

I've attached a zip of all the face meshes.
Download - please read all instructions before downloading any files!
File Type: zip (1.07 MB, 50 downloads) - View custom content
Lab Assistant
#62 Old 11th Sep 2010 at 10:08 AM
Man, how did I miss that >.<

Alright, now it works. Finally. XD Thx so much. <3
Ms. Byte
Original Poster
#63 Old 11th Sep 2010 at 2:19 PM
You're welcome! I'm glad it's working.
Test Subject
#64 Old 31st Mar 2011 at 4:43 PM
I love you CmarNYC.
Just had to let that out.

I'd usually be following tutorials down to the teeniest details, but feeling lazy recently, I just breezed carelessly through this one.
I literally just went happy-go-lucky with it. And to my surprise, it worked! It must've had something to do with your infinite genius.

So once again, I love you.

The magic page 4 holds. I broke the rule.
Test Subject
#65 Old 5th May 2011 at 4:22 PM
This is great! Thanks soooo much =D

I have successfully made a slider for YAF I am so so happy!!

Thank you thank you!!
Test Subject
#66 Old 5th May 2011 at 4:26 PM
I just remember that I learnt how to make clothing longer from you too
( Clothing meshing for dummies )
omg you are amazing! xxx
Blenderized to Pieces
retired moderator
#67 Old 5th Nov 2011 at 6:56 AM Last edited by porkypine : 5th Nov 2011 at 7:32 AM.
Thank you for making this tutorial. I've had to try to create some sliders beccause I can't model the faces I want in the existing CAS.

I would really like to be able to just import a complete face rather than individual parts because I am trying to SIMize real people. I can model the faces in Milkshape fairly well... Anyway. I am finishing up my first GEOM morph for wide cheekbones and we'll see what the final product looks like. Wish me well. I'll show pictures of either my success or explosion.
Test Subject
#68 Old 4th Apr 2012 at 9:09 PM
help! i did everything the tutorial said and I just got a big mess of blue squiggles when i imported amface_lod0_2 into milkshop! it also said that it couldnt locate the bone structures or something.
Née whiterider
retired moderator
#69 Old 4th Apr 2012 at 10:04 PM
In Milkshape, go to File -> Preferences -> Misc, and set Joint Size to 0.01. Then restart Milkshape.

What I lack in decorum, I make up for with an absence of tact.
Ms. Byte
Original Poster
#70 Old 4th Apr 2012 at 10:07 PM
And the messages about not locating the bone file and (sometimes) 'hashed bone not in skeleton' are normal. Ignore them.
Lab Assistant
#71 Old 19th Jul 2012 at 6:43 PM
Would this be good for moving the entire nose in/out, or would I need to use the bone-based tutorial?
Ms. Byte
Original Poster
#72 Old 19th Jul 2012 at 8:34 PM
Since there's a 'nose area' bone that controls the whole nose, a bone-based slider would probably be easier.
Test Subject
#73 Old 22nd Jan 2013 at 12:12 PM
Mine keeps saying my simgeom file is not a morph mesh file. I've changed the comments and everything. What is this?
Test Subject
#74 Old 22nd Jan 2013 at 2:18 PM Last edited by jwghost : 22nd Jan 2013 at 4:47 PM.
Originally Posted by HystericalParoxysm
Thanks so much, Rez and Cmar! I really appreciate it.

Between your help and some from Delphy, I've been able to get a bi-directional slider working, woo! Now to make... so... many... more... Yay!

I'm attaching some .ms3d files - these are the templates I'm using to make my face sliders. They're just Cmar's faces from the first post, but two imported into MS, first one hidden, second one given the comments - so they're all ready to just start editing. I've done lod0 and lod1 for all ages - not lod2.

Figure it might save some other folks some time, if you're making multiple sliders or bi-directional sliders.

Thank you so much! I managed to get my slider to work thanks to you and the files you uploaded, it's working, in CAS! I can't believe

but it's missing the adult female version, can you please make the af version too?
Thanks a million! Everything worked!


I have more questions, how can I make my slider to work for all ages, at least just YAF and YAM? without doing multiple sliders for each, I'd like just one file that would work for all, and just one label in CAS, so merging the packages is not what I want, I did this slider for Young Adult Female and Adult Male, and it's showing two nasal bone sliders in CAS, one working for each, I wanted just one slider. :/

It's possible to make my work look the same in all ages? Or I'll have to remodel the nose everytime I choose a age group? It looks a bit different from the other. :d
Ms. Byte
Original Poster
#75 Old 31st Jan 2013 at 12:17 PM
In MorphMaker, load the morph meshes for all the ages/genders you're working with into the appropriate places. When you then make the BGEO and slider, it will make one slider for all those ages/genders.

The face meshes are different for each age, so you have to do separate morphs for each.
Field Researcher
3rd Mar 2013 at 7:25 PM
This message has been deleted by Sleepy-Genius. Reason: nothing to see here.
Page 3 of 4
Back to top