Replies: 234 (Who?), Viewed: 353895 times.
Page 2 of 10
Test Subject
#26 Old 2nd Sep 2009 at 3:21 PM
I extracted all files to MilkShape 3D 1.8.5 folder but still it doesn't show up on File > New > Import/Export options.

I'm using MilkShape 1.8.5 Beta, trial 30-period
Original Poster
#27 Old 2nd Sep 2009 at 3:54 PM
Did you check that the Visual Studio 2008 Runtime package is installed? It is required (and free from Microsoft).

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Test Subject
#28 Old 2nd Sep 2009 at 7:06 PM
Ops, my mistake, sorry.
11th Sep 2009 at 7:16 PM
This message has been deleted by Kiara24.
#29 Old 11th Sep 2009 at 7:45 PM
Which one Visual Studio 2008 I have to download?
#30 Old 12th Sep 2009 at 1:41 AM
welding verts
You can no longer use Milkshapes welding tool with these plugins.
It will double up(or more) the ammount of vertices, really strange.

I had a mesh of 1350 vertices and 2050 faces and welded a few seams to reduce the ammount of verts.
Those verts all have identical positions on the uvmap so no harm will be done.
After exporting and reimporting i end up with 5400 vertices and 2050 faces..
Any idea how to solve that?
Original Poster
#31 Old 12th Sep 2009 at 2:34 AM
Perhaps the UV positions are not as identical as you think. .obj files are laid out differently from the way the game requires vertices to be laid out. You cannot share vertices in this game between faces if they do not share identical UV locations.

The vertex splits it makes are those that are needed, using the same code I used for Sims 2 meshes, with 4 years worth of testing behind it.

If you like to say what you think, be sure you know which to do first.
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
#32 Old 12th Sep 2009 at 3:01 AM
Originally Posted by WesHowe
.obj files are laid out differently from the way the game requires vertices to be laid out. You cannot share vertices in this game between faces if they do not share identical UV locations.

So, the only way around this is not to use many seams?

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| (• ◡•)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Original Poster
#33 Old 12th Sep 2009 at 3:57 AM
If focusing on raw vertex counts seems like an important item to you, yes.

However, you should look at the way the EA-made TS3 game meshes are constructed. You will not import any that have UV seams without duplicated vertices. That's because the file format does not allow for that... UV coordinates are associated with vertices, following a one-to-one mapping (along with normals, assignmanets, weights and tangent normals).

Many modelling programs associate UV coordinates and normals with polygons as separate pooled items. That yields lower vertex counts, but that requires three indices per polygon point instead of one. It is, in the end, a design tradeoff. More of this, or more of that. In the end, if your mesh is more complex, it takes more resources to render.

Base didn't say what kind of mesh they were working on, 2050 polys is not a lot for a TS3 mesh. If you want to reduce the impact your mesh has, you will need to reduce the poly count. You can weld vertices all day long, and the exporter will keep splitting them at the seams. To not do so will yield broken meshes in the game.

I looked for an example picture, this one is from an object mesh, but it shows what happens when the UV map isn't split properly at the seams:

This is from the post at

If you like to say what you think, be sure you know which to do first.
#34 Old 12th Sep 2009 at 11:18 AM
I can't find Q-mesh in the program, please help!
Original Poster
#35 Old 12th Sep 2009 at 10:00 PM
If you installed the plugins into the MilkShape program directory, and it doesn't show up under the Import or Export menu, then you don't have the Visual Studio 2008 Runtime package installed.

If you like to say what you think, be sure you know which to do first.
#36 Old 13th Sep 2009 at 12:56 AM
Thanks for reply!
I installed Visual Studio 2008 Runtime but I think is not the right one...
#37 Old 13th Sep 2009 at 4:52 AM Last edited by Base1980 : 13th Sep 2009 at 5:17 AM.
You can test it out with with a simple mesh split up in 2 seperate halves.
Uv map those halves on the uvmap within the same region.
You now should be able to weld the duplicate verts on the seam and export them without any problems.
Exporting it in unimesh, wavefront, 3ds or watever plugin is used will give no problems only with the GEOM plugin i end up with 4 times(exact) as many vertices after reimporting.

Also giving vertices on the uvmap(UV coordinates) the exact same position be easy as Milkshape has a auto snap fuction build in.

Your picture does indeed display how it should look after welding parts that are seperated on the uvmap and that would you expect with these plugins also, but instead they generate new vertices.
It wouldn't be a problem if it would generate extra verts for the seams but it gives you back 4 times the verts of the whole mesh.

Maybe there is a diference between the object importer and GEOM importer?

Another thing i want to mention is that you can not duplicate parts of a mesh and say for instance mirror them without remapping them on the uvmap.
It will screw up the rendering/shadow ingame....

Thanks for wat you have done sofar Wes!!
If it wasn't for you we wouldn't be meshing arround at all....
Original Poster
#38 Old 13th Sep 2009 at 5:12 AM
I would like to see the exported mesh. I can easily reimport it, and I have more tools to disassemble it and count the vertices and so on than just the importer. Then I will be able to tell you exactly what is happening to it.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#39 Old 13th Sep 2009 at 5:20 AM Last edited by Base1980 : 13th Sep 2009 at 1:01 PM. Reason: adding screeny's
Were can i send it to?
I am not uploading it here

Ill try to be a bit more specific bout the issue i am having.
I made some tootsies from scratch, and they look wonderfull.
The whole mesh, 2 feet with toes have 1320 vertices and 2092 faces

But somehow i have a seam when ingame.(see 1st screenshot)
Things i already have done trying to fix this.
*Checked the boneassignements, they are identical.
*Realligned the normals
*uvmap the parts seperate and uvmap them with identical uvcoordinates

Now i found out that if i weld the verts on the seam(resulting in a mesh with 1289 vertices and 2092 faces within Milkshape) the problem on the seam gets fixed but when i export the mesh, the plugins generate 4 times the ammount of vertices.
So the exported mesh contains 5668 vertices and 2092, but all those extra vertices will then again screw up the normals(screenshot 2)
Original Poster
#40 Old 14th Sep 2009 at 2:55 AM
You changed names on me. I know who you are.

You did a nice job on these, and are almost finished. Good work.

To summarize here for others, I got the files from Base1980. As he recapped in his email to me, and from what I could determine here, the issue with a large number of added vertices cannot be replicated, I think it may have been something like a hidden group or something when he was checking.

So I checked the feet over, in game and in other tools. There is some extra coloration issue on the inside of the ankles which appears to be related to a couple of UV coordinates being uneven. Otherwise, the only issue I spotted is that the ankle and leg do not match, they have a gap.

It is not weights, because I looked at the weights, and I they are identical to the game on the top row, which is the only one that has to match perfectly. The gap does not change during animation, it is always the same size. I checked the ankles against the originals, and the positions are perfect.

Finally, I thought to check the VertexID values, yours are all zeroed out, lost in you OBJ import/export work. The VertexIDs are used as part of the mechanism that makes the sliders work. I don't think that all of the VertexIDs are completely necessary, especially when you added vertices. But it appears that at least the top row must be the same as the game for the gap to disappear.

Some people have just duplicated the closest VertexID in order to accomodate their extra vertices. I added the VertexIDs for just a couple of the vertices and nearly fixed all the gap.

I learned a lot chasing this down. VertexIDs are duplicated on duplicated vertices, for one. The vertex on the inner ankle, where the UV seam is at, is, by necessity duplicated, and both copies carry the same ID number (which is different for each foot). The presence of these values appears to be critical for final mesh sizing, again probably a part of the slider mechanism... without VertexIDs, positioning is being done on the bottom (which has them) that is not being duplicated on the feet.

I know you said you have issues with the Extra Data Tool there, this is probably the same, long standing conflict between OpenGL and Windows on child windows, the same issue that has plagued the BoneTool. Most people seem to have gotten around that by using the Mesa DLLs (software OpenGL drivers) available at Chumbalum Software.

I know of no alternatives to the Extra Data Tool other than Hex Editing to fix this, but I am pretty confident from just adding a few that by adding the proper VertexIDs on the top row (study the values used on the original by matching position) and perhaps a few tweaks on the UV mapping (and maybe not needed, but there are a few stretch points) you will be good to go on these feet.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#41 Old 14th Sep 2009 at 9:41 AM Last edited by Base1980 : 14th Sep 2009 at 10:16 AM.
Originally Posted by WesHowe
the issue with a large number of added vertices cannot be replicated

If you take the first file, were the seam is half way on top of the foot and weld one vertice on that seam the plugin then will generate all the duplicate verts on export.
That first file still has all original vertex IDs till the seam.....and were the gap is at.(screenshots)

You use the extra data tool to add the VertexIDs but is there a tutorial or a few lines on how to do so?
I hope i get the tool working first though...

From every mesh we still learn i guess. :D
Altough it was frustrating i now know how to weld seams(and match the uvcoordinates from the 2 parts) and fix the mesh with the tile texture mapper.

You are right about the uvmap, i might finetune it when done but then again...not one user of the feet will prolly ever notice.

Thank you for clearing things up!!

Installed the mesa GL drivers but the tool keeps freezing.
I can add values and such and commit them but i can not exit the program.
It should exit when clicking commit?
You have a screenshot on how the window should look like?
I have the feeling mine doesn't display all buttons.
Original Poster
#42 Old 14th Sep 2009 at 3:52 PM
Ah, the old button issue. That has something to do with the DPI setting, I think, as it seems to bite the EU people more than the US.

You should be able to just see the tops of the buttons, they are "Save All" and "Cancel".

The "TagVal" values are used for shading on hair meshes... not needed for clothes and body parts.

If you like to say what you think, be sure you know which to do first.
#43 Old 14th Sep 2009 at 4:28 PM
yup, cant see the bottom ones.
Not even a glimp..
I can close it now using the TAB key to select cancel.

How i find the settings from the originals?
If i select a vert that is already assigned it shows a number or something?
srry for all those questions.....
Original Poster
#44 Old 14th Sep 2009 at 5:02 PM
I think if you close it with Cancel your values will not update.

Load the original foot. Select a vertex (left innermost vertex). Open the Extra Data Tool, look in the VertexID box, it should say 30002 (I think that was the value, from memory). Go around the foot, making note of the values from the original, load teh clone and put the values in, Save All, Export, enjoy.

I will be issuing a new Extra Data Tool soon that should have the buttons visible, although I do not know for sure why they don't look there like they do here. My bad, I am sure, but we will work through all this eventually.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#45 Old 14th Sep 2009 at 9:08 PM Last edited by Base1980 : 14th Sep 2009 at 10:07 PM.
Thank you!!

I was puzzled how the first version worked ingame(the sims2 version) and after some testing i found out.
If you import the original foot first, then mine, select all and then weld the verts together from both the original and custom, the custom one gets automaticly the vertID's.
That is prolly why the first version of the feet didn't have the gap.
But when doing that it also generated new verts.
And i think those new verts prevent the seams on the uvmap from being screwed because welding all together normally will also connect all those uvcoordinates..

I changed DPI setting from 120 to96(normal) and i just can see the outer topline of the bottoms.
Got the top row fixed, gonna see ingame :D
#46 Old 15th Sep 2009 at 1:04 AM
Back again lol....
If i build a default replacement package from one of the female bra's and try to make a simple edit to the mesh(pull out a vert) the plugins will also generate 5 0r 6 times as many vertices for the morphs, not the base mesh.
I just noticed when i was importing the morphs with Postal
The base mesh has 1780 verts and 2926 faces while all the morphs have 10537 verts and 2926 faces.
Normally this will crash your game but the files get ignored(seems)
Original Poster
#47 Old 15th Sep 2009 at 1:14 AM
I did tweak the morph code the last time I revised them... for you, I think.
I will look here and see if I can replicate that. If not, I will ask for help.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#48 Old 15th Sep 2009 at 1:19 AM Last edited by Base1980 : 15th Sep 2009 at 1:39 AM.
I just tried v0.10 and those export correct(no huge ammount of verts) but they exported without any comments in the boxes.
That is wat you fixed earlier for me.

The morphs have now(with v0.14) the same comments as the base mesh.
Im switching back to v0.12 as those seemed to work.
Original Poster
#49 Old 15th Sep 2009 at 1:59 AM
I will review that carefully... the morphs should not have the same comments as a base mesh, that is wrong. Of course, it should not create a crazy number of vertices, either.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#50 Old 16th Sep 2009 at 4:47 PM
Please help me!
I think I installed everything but Q-mesh does not appear
Page 2 of 10
Back to top