Replies: 203 (Who?), Viewed: 172098 times.
Page 7 of 9
Test Subject
#151 Old 27th Jan 2007 at 4:39 PM
hi, i just tried your tutorial word for word. having a bit of a problem when doing the uv mapping in uvmapper classic. each time i load the model it comes up as a side view not a top view like the tutorial says. I've retried this WHOLE process from beginning incase i missed something and i haven't but i still get the same problem. any ideas?
Lab Assistant
#152 Old 29th Jan 2007 at 7:00 AM
Hehe, you have no idea just how cool it was to fire Blender up after reading this and actually be able to see the damn mesh, let alone the awesomeness of making something. Thanks heaps Lethe!

Stupid question though, I've gotten to the mapping stage and somehow I've managed to group/join the mesh together before I was able to export certain bits seperately. Is there any (why do I get the impression it's gonna be so obvious I'm a fool for asking :D) way to ungroup them??

We'll roll on with our heads held high,
Our consience in the gutter,
Our dreams up in the sky,
Fluffy
retired moderator
Original Poster
#153 Old 29th Jan 2007 at 8:27 AM
ukch1ckk,
if you have a newer version of blender, there's a rather silly default that imports things at a 90 degree angle.
When importing your 'example table', make sure to UNCHECK the 'rotate 90 degrees' button.
You can then flip your newly meshed table the right way round, line it up with the maxis table and export it again.

KatieKirby,
I'm sorry, I'm sure there is, but I haven't found it yet (you'd be amazed what functions I still find after two years in the program)
What I usually do, is clone the unified object, and delete the unnecessary bits. For instance, clone the table, in one clone, delete the legs, in the other clone, delete the top.
Lab Assistant
#154 Old 29th Jan 2007 at 9:17 AM
Thanks Lethe Just so long as I don't have to make the blasted thing again I've discovered that it's not the best idea to make a bed in blender when it's the first time you've done anything like this :D

We'll roll on with our heads held high,
Our consience in the gutter,
Our dreams up in the sky,
Field Researcher
#155 Old 29th Jan 2007 at 10:40 AM
Well, it's relative easy to separate the mesh in different subset with the option "separate vertices", and it's easy to re-group them, to export them in only one group or in different subset but only one file obj.
It's too diffcult for me to explain in English............. so I'll try with an example with some images.

Example:
The table dining diner 1x1 has two subset: tabletop and tablebase, export the obj file from SimPE and import it into blender.
The tabletop has only the face (in the screen is pink) , without its base, the table base has the leg and the top-base( in the screen is dark).


Click to increase size

Remeshing them:

- Select the tablebase, go to edit mode and select all the vertices of the the leg
- Pres Space bar and choose Edit -> Vertices -> Separate


Click to increase size

- Now you have 3 subset: the tabletop, the leg and the base for the top.
- Go to object mode and select the top and its base,
- Regroup: click Space bar -> Object -> Join Object and click ok


Click to increase size

- Now you have two new subset as you like: the top and the lag
Select both and in the export option deselect the option Objects and select Objects Groups



The option "Objects Group" is most important: it sets the "g" in the OBJ file and it maintains the different subset.

The option "Objects" sets the "o" in the OBJ file and it joins the different subsets in ONLY one.

Hope this help you.
Screenshots

If you like my creations, you may consider to make a little donation to support my site and my modding activity.
MaryLou's Sims 2 World - MaryLou Sims 2 Forum (Italiano)
Lab Assistant
#156 Old 29th Jan 2007 at 1:17 PM
Two and a half hours later, I have a throbbing headache and a working mesh...Thank you soooo much for that MaryLou, you helped heaps!

We'll roll on with our heads held high,
Our consience in the gutter,
Our dreams up in the sky,
Fluffy
retired moderator
Original Poster
#157 Old 29th Jan 2007 at 7:09 PM
ahhhhh,
see, I learn stuff about blender every day
thanks marylou
Lab Assistant
#158 Old 1st Feb 2007 at 11:56 AM
Argh, again with the problems I can't seem to export .obj files. When I try the resulting file either has no extension, or it says it's a .obj but is only 1kb in size and won't import into either Blender or UVMapper...

We'll roll on with our heads held high,
Our consience in the gutter,
Our dreams up in the sky,
Field Researcher
#159 Old 1st Feb 2007 at 12:59 PM Last edited by MaryLou : 1st Feb 2007 at 1:04 PM.
Here are the Import and Export options that I generally use, and I've never had problems with them.

IMPORT OPTIONS



I don't use any options to import the obj file........
1) Import *.mtl - There is no need to import the materials for the mesh (they are stored in the separated *.mtl file, if it exists: SimPE doesn't create a .mtl file anyway)
2) Re-Use Existing - If the option 1 is deactivated, this one is of no use.
3) Rotate X90 - If selected, it will rotate your mesh along the X axis: useless and misleading
4) Edges - basically, this doubles the vertices for each edge: we don't need duplicated vertices.
5) Smooth all faces - This applies the standard smoothing to the whole mesh; it doesn't give accurate results, it's way better to apply the smoothing using UVmapper.
6) Create FGons - this option, too, increases the number of vertices.

EXPORT OPTIONS



1) Triangulate: OFF. there's no need to automatically triangulate the *whole* mesh while exporting. You should triangulate only the visible faces before exporting.
2) Normals: ON. You must activate this, because SimPE expects to find the Normals stored in the OBJ file (otherwise, it gives error).
3) Materials: YOU CHOOSE. I set it to ON because this way Blender exports the materials, that I cna then import in UVmapper. But SimPE ignores the exported materials, so you can safely set this option to OFF.
4) OBJECTS and OBJECT GROUPS: these are the options that set the "o" and the "g" in the OBJ file. In order to create a OBJ file compliant with SimPE, you have to set OBJECTS to OFF (i.e. no "o" in the .obj file), and OBJECT GROUPS to ON (i.e. use the "g" instead).

Make sure your mesh has the faces mapped before export it.

File - >Export - >Wavefront (.obj)

If you delete the default name and rename the file as you like remember to add manually the extension write in the box the whole name with the extension i.e: new-mesh-tabletop.obj than choose the options and remember to click OK

Edit
Hint:Blender ( and UVmapper too in same cases) can't import file with too long file-name as usally make simpe........ you must use short file name.
Try to rename them.

If you like my creations, you may consider to make a little donation to support my site and my modding activity.
MaryLou's Sims 2 World - MaryLou Sims 2 Forum (Italiano)
Test Subject
#160 Old 23rd Feb 2007 at 11:39 PM
Default help
OK im fine untill i get to the part where you are trying to export the bookshelf mesh from simpe. i clone it then go into geometric container and i can't find the files that need to be exported
HELP PLZ
Part-time Hermit
#161 Old 24th Feb 2007 at 5:48 AM
vVv_klawz_vVv, can you elaborate a little bit? Do you mean there is no Geometric Data Container, or that the bookshelf mesh is not there? If there is more than one Geometric Data Container in the package, look into all of them.
Test Subject
#162 Old 24th Feb 2007 at 10:14 PM
when i go into the geometric container and there is only one file and it wont let me export it

When life hands you lemons, chuck um' back and say make your own lemonade!
Part-time Hermit
#163 Old 25th Feb 2007 at 7:55 AM
Can you post a screenshot of what the view in GMDC looks like?
Test Subject
#164 Old 3rd Mar 2007 at 8:31 PM
Quote:
Originally Posted by IgnorantBliss
Can you post a screenshot of what the view in GMDC looks like?

i would but i dont know how

When life hands you lemons, chuck um' back and say make your own lemonade!
Part-time Hermit
#165 Old 4th Mar 2007 at 7:32 AM
Press the Print Screen button on your keyboard, paste the image into a paint program (with Paint Shop Pro you can just click Ctrl+V, with Photoshop I think you have to first open a new image and paste into that). Then save the image and attach it to a post by using the Manage Attachments button.
Test Subject
#166 Old 6th Mar 2007 at 10:43 PM Last edited by IgnorantBliss : 7th Mar 2007 at 4:07 AM. Reason: edited to combine posts
what about gimp

never mind i figured it out

Oh my gosh i feel like such an idiot!! the only reason it wasn't working was i hadn't installed the direct x when i first installed simpe. it works now so now i can finish the toutorial SOOO sorry i wasted your time.

When life hands you lemons, chuck um' back and say make your own lemonade!
Test Subject
DELETED POST
6th Mar 2007 at 10:47 PM
This message has been deleted by IgnorantBliss. Reason: deleted to combine posts, please, use the Edit button instead of posting multiple times in a row
Test Subject
DELETED POST
6th Mar 2007 at 11:23 PM
This message has been deleted by IgnorantBliss. Reason: deleted to combine posts, please, use the Edit button instead of posting multiple times in a row
Test Subject
#167 Old 17th Mar 2007 at 12:15 AM
Blender Goodies
ANYTHING YOU CAN FIND TO HELP ENLARGE THE SCREEN FOR A almost BLIND GUY WOULD BE NICE...

iv got nose 2in from the screen now and the text is as large as i can get it.
Any help with Blender would be great....
Fluffy
retired moderator
Original Poster
#168 Old 17th Mar 2007 at 9:37 AM
umm, shadowwolf?
have you tried just changing the settings of your screen down to 600 by 800 pixels?
that will make *everything* bigger.
there's also stuff like virtual magnifying glasses for your pc (http://magnifier.sourceforge.net/)
Test Subject
#169 Old 18th Mar 2007 at 11:47 PM
Default OOOO Love that one More pleaseeeeee
Any thing to help
i have the moniter set as low as i can now and it still is hard to see
its just getting yo the point i may have to call it quits
but thank you
Test Subject
#170 Old 2nd Apr 2007 at 11:56 AM
Default Help!!!!!
I have created my Mesh in blender (Ve:1508 Fa:1698)
I exported it as a obj file
and I tried to import it into SimPE it came up with a error message:
============================================
Index was out of range.
Must be non-negative and less than the size of collection.
Parameter name: index
============================================
What can I do!!!!!?
HELPPPPP~~~~~~~~
Field Researcher
#171 Old 2nd Apr 2007 at 10:35 PM
Look at the post 159 for the Export Options.
Make sure your mesh has the uvmapping , then select the "Normals" (Simpe expects to find them in the obj file) and export it as an "Object Groups" even if it is only one subset.

If you like my creations, you may consider to make a little donation to support my site and my modding activity.
MaryLou's Sims 2 World - MaryLou Sims 2 Forum (Italiano)
Test Subject
#172 Old 3rd Apr 2007 at 7:14 PM Last edited by kusohead : 3rd Apr 2007 at 7:20 PM.
Quote:
Originally Posted by MaryLou
Look at the post 159 for the Export Options.
Make sure your mesh has the uvmapping , then select the "Normals" (Simpe expects to find them in the obj file) and export it as an "Object Groups" even if it is only one subset.


THX....I ''Kinda'' got it work.......
now I got rid of the first error message......then I got a different one:
========================================================
One or more of the importing Mesh groups contain too many verteices and faces
========================================================
Now I don't know what to do next...how am I going to sort this one?
I don't think my MESH is too complicated anyway...
The object that I am trying to make now is a Gachapon machine (Japanese capsule vending mach.)
here are 2 screenshots from blender...

Vert:5930 Faces:2790


plz plz plz~~~~~intellgent people plz help me
Field Researcher
#173 Old 3rd Apr 2007 at 8:20 PM
Your mesh has 1778 vertices ( isn't e simple mesh) and most probably when you import it in SimPE you'll get around 3500 vertices...........
When you import your obj file look at in the windows "Mesh Groups Importer" how many vertices the mesh really has.
You can try to reduce the vertices in blender ( with the option to "Remove Double") or import the obj file in uvmapper and make a different mapping, weld and smooth.

You must set SimPE in advanced mode.....Open SimPE go to Extra->Preferecens->Simpe Settings and select "Advanced Mode", than click ok.

If you like my creations, you may consider to make a little donation to support my site and my modding activity.
MaryLou's Sims 2 World - MaryLou Sims 2 Forum (Italiano)
Test Subject
#174 Old 8th Apr 2007 at 4:05 PM
Thank you so much for the tutorial!
Test Subject
#175 Old 11th Apr 2007 at 11:33 AM
First I want to thank for this great tutorial. After a few days of struggle, everything goes fine. Till the time to do UV mapping...
In the UV calculation, there's not such button as LSCM Unwrap... I'm using version 2.43 of Blender.
Is there a different command in the version I am using???
Page 7 of 9
Back to top