Replies: 2 (Who?), Viewed: 208 times.
Mad Poster
Original Poster
#1 Old 6th May 2022 at 11:49 AM
Default Alpha not showing up properly on hair
I wanted to add a new mesh group to a hair. I did so and fixed the property set etc. and finally managed to get the hair to show up properly when I exported it in Bodyshop.

But the hair looks like this.



I'm not sure what I missed to make the alpha not show up properly.

Thanks for any help.
Screenshots
Advertisement
Mad Poster
#2 Old 6th May 2022 at 4:10 PM
Looks like you've got the wrong TXMT settings.

Check these first:
"cMaterialDefinition" tab, under "Type": SimStandardMaterial

"Properties" tab:
stdMatAlphaBlendMode: blend
stdMatAlphaTestEnabled: 0

These are the most important settings, but it's possible you'll need to fix more, too.

(You can compare the rest of the settings to most other hairs - but make sure to copy settings from an hair_alpha TXMT and not from the plain "hair" TXMT, as this one is meant to get the rest of the texture from the skin texture, and isn't alpha enabled. If the cMaterialDefinition tab says "SimSkin" it's the wrong one).

You can export the settings from one TXMT to another (the export/import buttons in the TXMT), but make sure to copy/paste the "stdMatBaseTextureName" and possibly also the normal map texture if there is one (rarely hairs, but sometimes for clothes) from the original TXMT so it points to the correct texture. Mostly useful if the settings are very different from one file to the other.
Mad Poster
Original Poster
#3 Old 7th May 2022 at 9:22 AM
Thank you!

The new group used the same TXMT as the other alpha group, but I managed to figure out that I'd copied the extra property set lines off 'hair' instead of 'hair_alpha' and so it was pointing to the wrong TXMT. Fixed now.
Back to top