Replies: 1 (Who?), Viewed: 489 times.
Test Subject
Original Poster
#1 Old 7th Jan 2021 at 6:10 PM
Default How to correct thumbnails for objects
Hello, sorry for making two threads in a row - I am working on cleaning up & repairing things in my downloads folder. I have a couple objects that have borky thumbnails. Deleting the thumbnails and letting them refresh does NOT fix the issue, just regenerates the broken thumbnails.

They both seem to not be displaying the textures properly - one object has solid black thumbnails for both the mesh and recolors, and the other object has the proper thumbnail for the mesh itself, but the recolor thumbnails are a weird mashup of both the mesh texture and the recolor texture. Both objects display properly in game.

I found this tutorial to create custom thumbnails, but it's beyond my skill level, so was hoping that there was a way to adjust the original files in SimPE to pull the textures correctly. Thank you in advance for help!
Advertisement
Mad Poster
#2 Old 7th Jan 2021 at 7:17 PM
It depends on which objects, but this works well for most deco objects: https://gardenofshadows.org.uk/gard...p?topic=36165.0
It can apparently put a strain on some computers, maybe epecially if you regenerate the Thumbnails files every so often - but if the thumbnails work after that first try, you shouldn't have to do anything about them.

For objects that don't have a "thumbnailExtension" line, you're probably going to have to use the camera tutorial.

I'm not entirely sure, but it may be possible to delete broken thumbnails manually (to reset them after fixing) from the Thumbnail files with SimPE, so you don't have to delete the entire thing every time. It would most likely put less of a strain on the game if there's just a few new thumbnails to generate. Haven't done much testing on those files, but it is possible to do so with the Cigen file for Bodyshop.
Back to top