Replies: 6 (Who?), Viewed: 342 times.
Test Subject
Original Poster
#1 Old 12th Aug 2021 at 3:48 AM
Default REPO'd texture picks up from master, but the master won't show
Hello!
I'm trying to practice REPO'ing a texture to a master file for the first time (using an existing object where I just added two BHAVs). For some reason, I've run into the issue where the color shows up on the REPO but not the mesh. The master's texture doesn't show up at all; it's just "invisible" in-game! I followed HugeLunatic's tutorial, felt pretty good about it, but then I ran into this issue. Thoughts about how to fix this? I've attached both files.
Download - please read all instructions before downloading any files!
File Type: rar SnackPacks.rar (146.4 KB, 2 downloads)
Advertisement
Mad Poster
#2 Old 12th Aug 2021 at 5:45 AM
The master file lacks a MMAT, which means it's not recolorable. You'll have to add one.

Not entirely sure if the repo'd file will pick up recolors afterward without doing any changes to it, but I think so.

https://modthesims.info/showthread.php?t=103379 (Adding subsets/making recolorable)
https://hugelunatic.com/making-objects-recolorable/ (fixing non-recolorable subsets - more of a problemsolving topic, in case you get stuck on the tutorial)

You don't have to add the MMAT to the repo file.
Test Subject
Original Poster
#3 Old 12th Aug 2021 at 6:55 AM
Quote:
Originally Posted by simmer22
The master file lacks a MMAT, which means it's not recolorable. You'll have to add one.

Not entirely sure if the repo'd file will pick up recolors afterward without doing any changes to it, but I think so.

https://modthesims.info/showthread.php?t=103379 (Adding subsets/making recolorable)
https://hugelunatic.com/making-objects-recolorable/ (fixing non-recolorable subsets - more of a problemsolving topic, in case you get stuck on the tutorial)

You don't have to add the MMAT to the repo file.


Thank you! The master file is now showing up and is recolorable. Now the issue is the repo won't pick up recolors. Does the repo need a MMAT as well?
Mad Poster
#4 Old 12th Aug 2021 at 9:56 AM
No, but check that all the lines in the SHPE and GMND match. When you do a few of the steps involved in the MMAT, the names of the resources could change, and occasionally caps/small letters or an extra hyphen can throw the file off, especially if you changed any names during the "fix integrity" step.

Usually it's just some obscure item in the file. Hugelunatic's tutorial can be of help. You can upload the file again if you need a double-check.

If you can't figure it out, the easiest way to fix it is to re-clone the master file. That way you know it has everything it should have.
Test Subject
Original Poster
#5 Old 12th Aug 2021 at 6:38 PM
Quote:
Originally Posted by simmer22
No, but check that all the lines in the SHPE and GMND match. When you do a few of the steps involved in the MMAT, the names of the resources could change, and occasionally caps/small letters or an extra hyphen can throw the file off, especially if you changed any names during the "fix integrity" step.

Usually it's just some obscure item in the file. Hugelunatic's tutorial can be of help. You can upload the file again if you need a double-check.

If you can't figure it out, the easiest way to fix it is to re-clone the master file. That way you know it has everything it should have.


I tried this, and I also re-cloned the master file a few times to no avail I really appreciate your help thus far! I've attached the re-cloned file that I tried to turn into a repo, the new master file, and one recolor.
Download - please read all instructions before downloading any files!
File Type: rar V2-NoRepoRCs.rar (210.3 KB, 3 downloads)
Me? Sarcastic? Never.
staff: administrator
#6 Old 12th Aug 2021 at 7:12 PM
Hey there, so there seems to be some mismatch of subset names. In the gmdc, gmnd and mmat you are using SingleSnackPack, but the txmt and the shpe seem to be using the original sub set name of posterworship_poster. When previewing in SimPE the mesh shows full white, as the scenegraph isn't correct and the texture is not linked. Changing the gmdc, gmnd and mmat back to posterworship_poster in the master/repo and recolor fixed the issues when I tested. Changing subset names can be tricky, as different resources switch between hypen and underscore, usually it's easiest to use the default.

Looks like you might want to fix the thumbnail as well. https://hugelunatic.com/fixing-thumbnails/
Screenshots
Test Subject
Original Poster
#7 Old 13th Aug 2021 at 5:09 PM
Quote:
Originally Posted by HugeLunatic
Hey there, so there seems to be some mismatch of subset names. In the gmdc, gmnd and mmat you are using SingleSnackPack, but the txmt and the shpe seem to be using the original sub set name of posterworship_poster. When previewing in SimPE the mesh shows full white, as the scenegraph isn't correct and the texture is not linked. Changing the gmdc, gmnd and mmat back to posterworship_poster in the master/repo and recolor fixed the issues when I tested. Changing subset names can be tricky, as different resources switch between hypen and underscore, usually it's easiest to use the default.

Looks like you might want to fix the thumbnail as well. https://hugelunatic.com/fixing-thumbnails/


This worked!! Thank you so much
Back to top