Replies: 0 (Who?), Viewed: 176 times.
Test Subject
Original Poster
#1 Old 30th May 2022 at 6:24 PM
Default Issue with creating custom hair recolors (not showing up in Bodyshop or CAS)
Hello,

This is my first post here. I've been having a really weird issue while recoloring hairs and I can't figure out where I'm going wrong.

I am trying to recolor a mesh and add geneticized custom hairs--i.e. the custom colors are recessive to the EA colors, and each color has the same genetic code across all the meshes that I recolor in that specific color. I've seen other creators do this and at one point I got my hairs associated with the same color code from another creator (so men can properly inherit a custom hair color from their mother and vice versa.) Anyway, here are the steps I took to do this:

1. Used Bodyshop to create a project for each individual color I was doing.
2. Replaced the texture files with the recolors in Photoshop by saving over all of the original BMPs with new BMPs.
3. Exported the files to the game and renamed them.
4. Used the Color Binning plugin in SimPE to bin all the custom colors as custom, using the genetic code as the "family" as this set the family and the genetic code to the same value.
5. Opened the packages in SimPE and changed all the genetic values from 0 to whatever I wanted the color to be (it ranged from 1, 1.5, 2, and 2.5)
6. Saved the files (including a backup) and see if they showed up in game.
7. After confirming they showed up in game, I opened the files in SimPE again and changed the family value to what had originally been the family value of the first hair so they would be linked to each other over the different ages.
8. Copied them to the downloads folder again and verified that they showed up in game.
9. Binned all the "natural" hair colors.
10. After this I added tooltips to the files and changed the eyebrow color, which didn't work. The tooltips only worked on maybe one or two hairs, but I didn't care at this point.
11. Put them in the downloads folder and verified that they showed up again.
12. Put everything in a zip folder, including the mesh, because I assumed I was done.

However, I had issues after that. I created a subfolder in downloads with the name of the hair mesh and unzipped all the files into that, and... none of them show up in game except for the naturals. I tried this in a fresh Sims 2 folder as well and still get the same issues. CAS only shows the naturals (which work fine) and does not acknowledge that I have custom colors at all, while BodyShop shows icons for all the custom colors, except them thumbnails are black and clicking on them just brings me back to the black hair color. I was also having some issues with some of the hairs when I tried doing all the steps without verifying in between, which is why I did everything slowly, but it still doesn't work. Even putting the files in the main Downloads folder again doesn't do anything. So... I'm really at a loss as to what I'm doing wrong. The only thing I can think of is maybe I shouldn't be putting them all in the same family... anyway, if you've read this far, thank you. If you need any more clarification as to what I did feel free to ask.
Back to top