Replies: 209 (Who?), Viewed: 55957 times.
Page 7 of 9
Instructor
#151 Old 7th Apr 2015 at 7:19 PM
Quote:
Originally Posted by ~MadameButterfly~
If someone get's a tuning mod to work, give a shout. I think I'm having some rotten luck with GTW thus far. I need a victory to celebrate, even if it's not my own. :D

Edit: I missed Claudiasharon's post! (Woke up in the middle of the night, and groggy posted.) But Yay!! I guess I'll keep trying then.

Edit 2: I decided to approach my own problem from a different angle, and mod a different file...and that worked! So yay here, too!


Hi Madame

I'm redoing my romance4all family fun from scratch and It seems to be working fine, but not yet complete cos its alot of files to mod.
Mad Poster
#152 Old 7th Apr 2015 at 8:08 PM
Oh good! And good luck with all the files! There can be a lot of them at times. :o)

♥ }i{ Monarch of the Receptacle Refugees }i{ ♥
Lab Assistant
#153 Old 8th Apr 2015 at 1:12 AM
Well, Fogity files work, I guess I will have to make a better effort hahaah

I'm gonna try so hard.
Field Researcher
#154 Old 8th Apr 2015 at 9:58 AM Last edited by egureh : 8th Apr 2015 at 10:12 AM.
I guess there're still issues with Fogity's extracted files. Some are working well but not all of them.
I'm working on a mod needs updating, it won't affect properly with the lasteast code shared by Fogity.
And another question: Can we rename the files with S4_{TYPE}_{GROUP}_{INSTANCE}.xml pattern in a batch?
I have a mod altered nearly 150 files... I would rather die if I have to rename them manually...
Mad Poster
#155 Old 8th Apr 2015 at 12:55 PM
I have only been renaming them as needed. So you ran into one that doesn't work, too? I thought maybe I just hit a fluke. The file I was trying to edit was the si_Retail_RingUpCustomer, and it was not being cooperative for anything. I haven't tried it, but I am pretty sure that if I put it in the game unedited, it still wouldn't work. I really don't know what is wrong with it. (Although, maybe that is one where I have to grab up the Data file as well. That's probably what I'll try next time.)

♥ }i{ Monarch of the Receptacle Refugees }i{ ♥
Lab Assistant
#156 Old 8th Apr 2015 at 1:59 PM
I am pretty sure I know what the problem is, an oversight on my part. I will upload fixed files later today.

I will not be able to provide a tool, so I will extract them on my computer.
But while I am at it, are there any other changes or features you would like to see me implement.

What naming patterns would you like and how would you like the files to be formatted?
I have implemented string and reference comments, do you want to have those in the files?
Other requests?

But I will not bother with it unless there is actually a demand (i.e. responses).
Lab Assistant
#157 Old 8th Apr 2015 at 3:10 PM Last edited by JustAnotherSimsFan : 8th Apr 2015 at 4:27 PM.
I use a file search program so personally i'm not worried what the files are named, it's keeping the linebreaks and whitespace i find most useful. Just having files so we can mod GTW would be something Fogity
Field Researcher
#158 Old 8th Apr 2015 at 3:42 PM
Quote:
Originally Posted by Fogity
What naming patterns would you like and how would you like the files to be formatted?
I have implemented string and reference comments, do you want to have those in the files?

That'll be great if files are named in S4_{TYPE}_{GROUP}_{INSTANCE}.xml pattern.
e.g. S4_B61DE6B4_00000003_000000000001B468.xml instead of object_Collectible_Crystal_crandestine.xml
For files format, I think keeping the linebreaks and whitespace is pretty enough. And thank you again! :D
Mad Poster
#159 Old 8th Apr 2015 at 4:08 PM
Thank-you so much for doing this for us, Fogity! I can easily search the files as well, so the naming system Egureh mentioned would be handy for easier import.

♥ }i{ Monarch of the Receptacle Refugees }i{ ♥
Lab Assistant
#160 Old 8th Apr 2015 at 6:38 PM
I have now, as far as I know, fixed the problem and the new extracted tunings can be found on my site here: https://fogity.wordpress.com/extracted-tuning/

Please give me feedback on the format etc.
Test Subject
#161 Old 8th Apr 2015 at 6:57 PM
Quote:
Originally Posted by Fogity
I have now, as far as I know, fixed the problem and the new extracted tunings can be found on my site here: https://fogity.wordpress.com/extracted-tuning/

Please give me feedback on the format etc.


I'm unable to extract EP01 as an archive, however Base and GP01 work just fine.
Lab Assistant
#162 Old 8th Apr 2015 at 7:16 PM
Quote:
Originally Posted by Talisien
I'm unable to extract EP01 as an archive, however Base and GP01 work just fine.


I just re-uploaded the EP01 archive, it should be working now. Please download it again.
Test Subject
#163 Old 8th Apr 2015 at 7:26 PM
Quote:
Originally Posted by Fogity
I just re-uploaded the EP01 archive, it should be working now. Please download it again.


Yep, works now. Thank you
Lab Assistant
#164 Old 8th Apr 2015 at 8:36 PM
Thank you for the files Fogity, much appreciated
Lab Assistant
#165 Old 9th Apr 2015 at 1:12 AM Last edited by Marquillotuca89 : 9th Apr 2015 at 2:10 AM.
Thank you Fogity, I hope that solves my problem with my mod xD.

Edit: I tried something, I packed a XML with no modifications and runned the game, guess what?

The interaction keeps vanishing EVEN when I didn't do something to the XML file. ._.
Mad Poster
#166 Old 9th Apr 2015 at 2:30 AM
I tried again with my own file, but it still gave me the llama. (Although I have yet to find the corresponding DATA file that goes along with it, and I am kind of wondering if I will even be able to open it once I do find it.)

The XML files look beautiful, though. I especially like the attention to detail in the formatted versions of them, with the helpful comment info. That was more than what I ever expected.

♥ }i{ Monarch of the Receptacle Refugees }i{ ♥
Lab Assistant
#167 Old 9th Apr 2015 at 7:00 AM
Well, I am not able to test or search for what the problem is.

So I will say as I said from the beginning, it is up to you to find out what, if anything, is wrong with my files. Look through my files, compare them with working files. Look at my base game and game pack files and see if they are different then my files in any way.

I haven't made a tuning mod, nor have I got much time to spare at the moment. So if you want the files to be working you have to do the legwork yourself.
Top Secret Researcher
#168 Old 9th Apr 2015 at 7:11 AM
Hmm the XML files are working just fine for me, I was able to edit them and make my own mods from them. And the mods are working just fine, haven't run into any issues.
Field Researcher
#169 Old 9th Apr 2015 at 7:44 AM
Mine still has the same issue. I think it's better to get an example. Here are the same XML files from Sims4XmlExtractor and Fogity.
I made a mod for storing Easter eggs in Toybox with Sims4XmlExtractor version and it works fine.
But when I made a mod with Fogity's version, the Easter eggs are just vanished...like they've never been there.
Download - please read all instructions before downloading any files!
File Type: zip object_collectibles_EasterEgg.zip (1.9 KB, 8 downloads) - View custom content
Lab Assistant
#170 Old 9th Apr 2015 at 8:59 AM Last edited by Fogity : 9th Apr 2015 at 11:04 AM.
Perfect, I found the problem. It was just a typo in my code that prevented the "t" attribute from being read. I also fixed extracting of modules.

I have uploaded the files to the same location, so just re-download (each one has been updated).

For convenience, here is the link: https://fogity.wordpress.com/extracted-tuning/
Lab Assistant
#171 Old 9th Apr 2015 at 2:50 PM
Thank you again Fogity
Test Subject
#172 Old 11th Apr 2015 at 3:07 AM
so not sure if its been said but I'm having trouble getting Sims4XmlExtractor to do anything, I'm trying to extract from the SimulationDeltaBuild0.package but when I hit export in Sims4XmlExtractor it instantly says its finished exporting the files and then continually runs the loading bar at the bottom and nothing is done

what am I doing wrong
Test Subject
#173 Old 11th Apr 2015 at 7:10 AM
I am having the exact same problem as Ryu_Knight, the extractor reports that its finished immediately and does not actually extract any xml files. I am going to switch to an older version to see if I still have the same problem.
Field Researcher
#174 Old 11th Apr 2015 at 7:25 AM
Quote:
Originally Posted by Fogity
Perfect, I found the problem. It was just a typo in my code that prevented the "t" attribute from being read. I also fixed extracting of modules.
I have uploaded the files to the same location, so just re-download (each one has been updated).
For convenience, here is the link: https://fogity.wordpress.com/extracted-tuning/

Yes, it's perfect. All my mods are working properly now. Thank you so much! :D
Mad Poster
#175 Old 11th Apr 2015 at 12:31 PM
Quote:
Originally Posted by Ryu_Knight
so not sure if its been said but I'm having trouble getting Sims4XmlExtractor to do anything, I'm trying to extract from the SimulationDeltaBuild0.package but when I hit export in Sims4XmlExtractor it instantly says its finished exporting the files and then continually runs the loading bar at the bottom and nothing is done
what am I doing wrong


The XML Extractor doesn't manage to do the newest combined file, as written about above. The newest one can simply be downloaded from SGModSquad here:
http://forums.thesims.com/en_US/dis...ing-resource/p1

Change the name on the file (after unzipping) to .xml and run the Extractor on it.

MedievalMods and Sims3mods: Dive Cave Reset Fix, Resort Revamp, Industrial Oven Revamp, Will O' Wisp fix, UI Sounds Disabled, No Cars, Gnome Family Planner, Townies Out on the Town, No Martial Arts Clothes, Fast Skilling, etc. http://simsasylum.com/tfm/
Page 7 of 9
Back to top