Replies: 234 (Who?), Viewed: 354562 times.
Page 7 of 10
Original Poster
#151 Old 2nd Jun 2010 at 5:28 AM
The posted example was 0xFEDA6981... the 0x is a common prefix for a 32-bit hex number, and the 8 letters/numbers following are a representation of that number. You don't need to be able to convert that, the importer and exporter know how to speak that geeky tech stuff.

But yes, the identifier can vary between meshes when there is a joint present that is not one of the commonly used ones. Mostly, I'd say just ignore them unless the item gives some trouble.

If you like to say what you think, be sure you know which to do first.
#152 Old 30th Jun 2010 at 3:31 AM Last edited by Base1980 : 30th Jun 2010 at 8:26 AM.
Hey Wes,
I was wondering if you have some information on the sims 3 skeletons.
We know that the secret of making things transparant lays partly in the skeleton.(like the glasses)
Made my first alphaskirt(had to wait a full year lol) and again the skeleton contains some info that lets you edit mesh layers with a texture file.

I found the GEOM(embeddedtype) settings to make the layers alpha editible(Thnx to Cocomama) but it wont work without the correct skeleton.(wich is the last TGI reference right?)

So a specific skeleton and embedded type should be used together.
Is there a way to find out wich are linked or how to find the embedded types(material settings) in the game files or are they stored in the GEOM themselves?
Asking because i want the one that makes clothing transparant.
#153 Old 22nd Jul 2010 at 5:48 PM
Im a bit closer, seems those bonehash errors are related to the material settings.
Original Poster
#154 Old 23rd Jul 2010 at 2:35 AM
I doubt it is in the bones, rather it is the materials.

The equivalent of the MATD is embedded in the comments for the GEOM. It is in hex, and not easily editable without further work. But you should be able to cut and paste from one mesh to another. Just delete every line that starts with "Embedded" and replace it with the "Embedded" lines from the glasses mesh. Transparency should be one of the attributes that copies over.

Just copy the entire set, not just part. You will see that there is a type and size, and a number of lines of data. While copying the entire section should work just fine, copying just part such that the size data is incorrect may create undefined parameters in the mesh, rendering it unsuitable for use.

If you like to say what you think, be sure you know which to do first.
#155 Old 23rd Jul 2010 at 9:51 PM
But somehow its related to the glasses joint not?
If i want for instance clone the aviator glasses and replace the frame and lenses with a custom mesh the frame shows up correct but the lenses lose their reflection and are totally off position.
Original Poster
#156 Old 24th Jul 2010 at 2:57 AM
I would bet if you copy the part of the comments that start with "embedded" (all of them) from the original imported lens to the custom lens mesh, it should have the reflection and transparency characteristics. The off position is probably related to joint assignments, that might be the skeleton thing. But I think your transparency, etc. is specified in the embedded MATD. That is essentially the same data used in the objects, however there is no tool to easily extract and edit it (because it is embedded within the GEOM chunk itself). At the time I wrote the GEOM plugin, only the most rudimentary data format for it had been decoded, and it was not until much later that the tags (or at least most of them) were deciphered.

I seem to remember Delphy making a test edit external plugin for S3PE that decoded them, I am not sure he finished.

If you like to say what you think, be sure you know which to do first.
#157 Old 24th Jul 2010 at 11:02 AM Last edited by Base1980 : 24th Jul 2010 at 11:14 AM.
The import/export of the glass joint causes problems, both in the GEOM as the WSO exporter as the moment it gets exported it rotates arround all 3 axis.(with the lenses group that is, not with the frame!)
The lenses use the reflection and i am convinced that has something to do with it.

I have tried alot diffrent material settings with the GEOMS but i always have to copy the last TGI reference with it in order to get it working.
Thats why i suspected the involvement of the bones/skeleton.

TSRW has decoded the material settings, fun to work with.
The glasses cloned with TSRW have similar issues, no way to get them working properly(I did get one set working, but by accident.. and i cant remember how)
Its all really strange.

Take a look at the pictures here:
You will have the same results with CTU or TSRW.
Test Subject
#158 Old 21st Aug 2010 at 5:00 PM
I cant find the publisher on chimbalum, what's that and on what do i have to click
#159 Old 22nd Aug 2010 at 2:36 PM
If what you're trying to do is download Milkshape go to this link:

look on the left hand side of the page and click download. In the latest downloads section choose MilkShape 3D 1.8.5 BETA1.
Test Subject
#160 Old 26th Sep 2010 at 7:21 PM
hi Wes!
sorry i'f my question is silly...
how do i update Milkshape from 1.7.10 to 1.8.5? when I go to the official Milkshape page it sais i have to buy version 1.8.5......
ps.i have a registered version of milkshape

thanks in advance
#161 Old 26th Sep 2010 at 9:23 PM
If you have a registered version of Milkshape you should be able to download the latest version and use the registry key you were sent when you purchased the older version to get your new version to work.
#162 Old 26th Sep 2010 at 10:14 PM
Is it possible you fix the glass joint on the importer?
Always comes out rotated 90degrees out of MS
Lab Assistant
#163 Old 8th Oct 2010 at 3:02 PM
I may have just missed it (I looked fairly hard), but did anyone mention whether the Maya plugins are available? I use 2011, so that could be a problem....
#164 Old 9th Oct 2010 at 2:04 AM
There are currently no Maya plugins posted. If you want to use Maya to mesh with you can use MS or a < 2.5 version of Blender as a bridge to get the item into obj format and export it to Maya. Then you can do your meshing with Maya, reimport the final version as an obj to MS or Blender, assign joints and then export to overwrite the MLODs/MODL from there.
Lab Assistant
#165 Old 9th Oct 2010 at 2:11 AM
Ah, I didn't know I could do that. Thanks for the tip!
Lab Assistant
#166 Old 31st Oct 2010 at 4:41 PM
WHERE do You put it, exactly??
I have no clue...
#167 Old 31st Oct 2010 at 6:34 PM
That depends on what you're talking But if you're talking about the plugins the directions are in the MSProgramNotes.txt included in the download:

"Installation for all MilkShape plugins consists of unzipping the file and placing it
in the MilkShape program folder. It you used the installation defaults, this will be
"C:\Program Files\MilkShape 3D 1.8.5" or, on Vista 64-bit it will be
"C:\Program Files (x86)\MilkShape 3D 1.8.5".

After placing the plugin in the program directory, close (if you are using MilkShape) and
restart the program. Plugins are searched for only when the program starts up. If you
put this in the right place, you will find a new entry in the File->Export or File->Export
labelled as lised above."
17th Nov 2010 at 4:34 AM
This message has been deleted by KuruRaiko. Reason: found my answer, thanks <3
Field Researcher
#168 Old 20th Nov 2010 at 10:44 PM
I'm confused .. I have the stuff from Microsoft you mentioned, and the right version of Milkshape .. I've put them in the right directory, yet the plugins are not showing up.
Test Subject
#169 Old 21st Nov 2010 at 8:50 AM Last edited by theWul : 29th Nov 2010 at 9:00 AM.
Sorry if I ask something answered elsewhere, but I'didnt find anything about the following issue:

I tried to copy a part of a mesh to another mesh (a top).

Beeing quite familiar with Milkshape the tutorials available guided me pretty fast to the point where my added deco showed up in game.

But it was displaced, hoovering over the chest, instead of beeing attached to it. The CAS Sliders and animations work, but the added stuff is in a different position than in MS. I rechecked in MS, redid everything (I forgot to copy extra data on regrouping), but it didnt help.

Then I read about your VertexID Autonum thingie and used it - now the added geometry is properly placed, but the sliders in CAS stopped working for the whole mesh.

Solved - the Solution was to assign vertIDs manually, for each vertex of the added mesh I used the vertId of the closest vertex of the original mesh. Works like a charm in CTU, only issue it breaks TSRW (who cares anyway =]).
#170 Old 28th Apr 2011 at 3:00 PM
Wes, will you ever fix the b_glass joint or maybe explain how to fix it?
I just cant figure out how to assigne custom glasses in order for them to show up

When i follow your tutorial on the aviator glasses all goes well but if i do a simple reassigning of those lenses to the b_glass joint they will dissapear
It prolly has to do with losing the bonehash when reassigning but i wish someone could figure this out
Original Poster
#171 Old 28th Apr 2011 at 6:11 PM
If I am remembering correctly, it was reported that the lenses were over on the floor somewhere. It would appear there is something special coded in the game about the lenses, but I do not know what it is. I do know that the actual joint information is never exported, just the per-vertex assignments, so the joint itself is not altered in the process.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#172 Old 28th Apr 2011 at 10:31 PM
It has something to do with the bonehases, maybe linked to the shader used.
You can assigne the lenses to any joint but every joint used will rotate 90degrees on all axisses.
TSRW did manage to fix the rotation but we are still forced to use the glass joint to make something transparant like the lenses
#173 Old 8th Jun 2011 at 4:09 AM Last edited by BloomsBase : 8th Jun 2011 at 5:14 AM.
Hey Wes
sorry to bother you again but im running into some issues.

1st is that the exporter does not update changes made to either the comment box or the uvmap when your exporting and overwriting the original simgeom you started with.
you always need to rename the exported simgeom in order to update.
Can this be fixed?

EA made a mistake on the uvmapping of the female eyes that i want to correct but i keep getting the bonehash error on the teens, even when i use the correct skcon.
files are:
Original Poster
#174 Old 8th Jun 2011 at 4:31 AM
1. Are you sure that you are not having an error caused by the caches on this? Or perhaps something not updating when making the package? After the file save dialog box returns with a filename, the exporter code that writes out the GEOM just writes the same data no matter what the name is, so it should not vary between a renamed file or an overwritten one. The prompt that you see when you overwrite an existing file is actually thrown up by Windows, as part of the standard file dialog, so unless you hit cancel, whatever name that comes back is what it writes.

2. The skcon file that is needed will be the one listed in the comments, I am not sure which tutorial you mean, the only one I remember writing was the aviator sunglasses... there are a lot of .skcon files, many having only tiny variations in them. The process is that the importer reads the GEOM data, and then tries to build a filename from the TGI that was in the file. In the format S3-TTTTTTTT-GGGGGGGG-IIIIIIIIIIIIIIII*.skcon, where T if type, G is group and I is instance, in hex digits. * of course means anything after the last instance digit and before the extension matches, so that the extra name info that S3PE generates should still allow the file to load. It then tries to find that file in the same folder with the GEOM file... if it succeeds, it adjust the bone positions based on the .skcon, if it cannot find that name, it complains and uses the raw positions that were in the auRig file, which are usually very close, but not always exact.

If you want some help, copy the last parts of the comments (the TGIRefs) and the filename to a message and let me look, because it could be a naming issue on the extracted .skcon file.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#175 Old 8th Jun 2011 at 5:08 AM Last edited by BloomsBase : 8th Jun 2011 at 5:21 AM.
1.No, i have this already since i started using the plugins.
Had it with XP and Windows 7
If you for instance change a TGIreference number it wont overwrite the GEOM.
Today i discovered it also happens when edting the uvmap, reason i posted.

2.I am puzzled about this,
The last GEOM TGI ref says:
TGIRef02: 00AE6C67 00E85121 00000000 A41DC69C
while the skcon is named:

Used your Aviator tut to export the skcon
Another option could be that i need a adult skeleton like teen morph clothing GEOMS need a adult GEOM before you can import them?

I am now fixing the GEOM with Delphy's simgeomeditor by reimporting the bonehashes, hope this works.
Last thing i want is messing up someones game...
Download - please read all instructions before downloading any files!
File Type: 7z teen.7z (7.8 KB, 21 downloads) - View custom content
Page 7 of 10
Back to top