Replies: 12 (Who?), Viewed: 5573 times.
Field Researcher
Original Poster
#1 Old 31st Jan 2006 at 6:10 PM
Default Changing "shadow" size...
Ok so I cloned the "Lady on Red" painting to make a tiki mask.
I went through the whole process (with a lot of trial and error)
following the Basics tutorial here on MTS step by step.... adjusting
slightly as I was making a single-tile painting and not a table.

It looks awesome in the game but the "shadow" on the thumbnail is huge.
Again, I did not alter the shadow because I followed the tutorial which
does not explain how you would do that, so I didn't touch it because I
didn't want to mess everything up. I should note this is my very first
actual working mesh. LOL!

So now that I've made my package... how do I go in and fix this?
I'm not sure what to do as its not casting a shadow in the game at all.
Can I just delete the shadow all together? Or should I just clone
the "shadow" of the mesh, make adjustments and re-import that part?
*Please don't say I have to start over.... *sobs*
Screenshots
Advertisement
Part-time Hermit
#2 Old 31st Jan 2006 at 6:18 PM
No, you don't need to start over. Do you have shadows turned on in your game settings? The shadow for wall objects only shows up in certain lighting, I think, not all the time.

You have several options. You can just try to edit the shadow texture, where the gray parts will appear as a shadow, and the black parts as transparent. You can try to make the grey part to the right shape for your new object, but it may be difficult. To make the shadow mesh closer to the right size for the object, you can export the shadow mesh from GMDC. It's just a flat plane that you can move and/or resize in your mesh program like any other mesh. You can also uv-map it if you want to (but it's not necessary, since it's already mapped). Then import the new mesh into your package and apply your texture to that one.

Important: Make sure you import the shadow image in ExtRawBit8 format. That means you can't use Build DXT, but the regular texture image Import, then Update All Sizes, and Commit.

If you don't need the shadow, you have two ways to get rid of it. The easy way is to make the shadow texture image completely black, import it into the package the way I described aboved, and it'll be invisible. The more complicated way is to delete the shadow texture image, TXMT, mesh and Shape reference altogether. If you delete the shadow texture, you should delete all of these.
Field Researcher
Original Poster
#3 Old 31st Jan 2006 at 6:23 PM
Well that is good news... LOL!

Sorry, I'm not trying to be a pain with all my stupid questions.
I don't do well with trial and error... I'd rather ask outright
and do it correctly the second time.

TSR Featured Artist
Monster Party Sims2... ITS ALIVE! :D

You may recolor my object meshes here on MTS2, but do not redistribute the meshes.
Link people here to MTS2 to get them. Objects can only be available in lots submitted to MTS2.
Field Researcher
Original Poster
#4 Old 31st Jan 2006 at 7:41 PM Last edited by shannanisims : 1st Feb 2006 at 1:37 AM.
Well I have changed the actual mesh shape of the shadow and imported it
into the package. In the SimPE preview screen its the correct size, and to
be "safe" I turned the alpha totally black. But the thumbnail still looks exactly
the same. And I can't view object shadows apparently... I have a crap
graphics card. Do I need to do something to make the thumbnail update?

I have no idea what I could possibly be doing wrong.

TSR Featured Artist
Monster Party Sims2... ITS ALIVE! :D

You may recolor my object meshes here on MTS2, but do not redistribute the meshes.
Link people here to MTS2 to get them. Objects can only be available in lots submitted to MTS2.
Part-time Hermit
#5 Old 31st Jan 2006 at 10:13 PM
To update the thumbnail, delete the package files in the Thumbnails folder in the Sims 2 folder in My Documents (leave the folder, but empty). New thumbnails will be generated the next time you look at the lamp in the catalog in the game, and it should have the correct shadow .
Field Researcher
Original Poster
#6 Old 1st Feb 2006 at 1:27 AM
Yay it worked! Thanks for answering all my silly questions today...

TSR Featured Artist
Monster Party Sims2... ITS ALIVE! :D

You may recolor my object meshes here on MTS2, but do not redistribute the meshes.
Link people here to MTS2 to get them. Objects can only be available in lots submitted to MTS2.
Lab Assistant
#7 Old 10th Jun 2006 at 3:22 PM
I am having a similar problem. I've figured out how to change the size of the shadow mesh per boblishman's tutorial, but I've made a new shadow texture as well and I can't figure out how to apply the new texture to the shadow mesh in SimPE. Could you explain how I might do this?
Forum Resident
#8 Old 10th Jun 2006 at 3:39 PM
You have to apply the new texture to the reworked shadowmesh in Milkshape or UVMapper and then import the shadowmesh and textures the usual way in SimPE. You are able to import only selected subgroups, so only import or replace the new shadowmesh.

Then you have to replace the original shadowtextures by your own. I hope I'm making sense here...

happy simming,
Xanathon


Xanathon's Laboratory :: WishList

.: Do not harass me with requests via PM, you will only get ignored :.
.: Don't post my objects or objects derived from them on paysites or the exchange! :.
Lab Assistant
#9 Old 10th Jun 2006 at 5:29 PM
My problem is that there is only one texture image in the package -- the one for the main object -- and none for the shadow. (Or at least, if there is a texture for the shadow, I can't find it.) I presume I would have to add one for the shadow, but how would I do that?
Part-time Hermit
#10 Old 10th Jun 2006 at 5:33 PM
zeroth, which object have you cloned?
Lab Assistant
#11 Old 10th Jun 2006 at 11:19 PM
"Two Dogs and an Olive" from Nightlife. The shadow is just a plain rectangle with no texture on it.
Scholar
#12 Old 11th Jun 2006 at 1:43 AM
it's best to pick a base object already with a shadow in it otherwise you have to add a group and it's a real pain to do. the shadow is usually called shadow or alpha and it's always black and grey/or white.
Part-time Hermit
#13 Old 11th Jun 2006 at 6:51 AM
If you check the "stand-alone" option when cloning that painting, the shadow is included.
Back to top