Replies: 2423 (Who?), Viewed: 453380 times.
Page 6 of 97
Mad Poster
#126 Old 1st Oct 2007 at 5:35 PM Last edited by niol : 1st Oct 2007 at 5:54 PM.
Lol, I kinda doubt that people without BV can get their sims to swim in a pond with just the beach portal due to lack of some transitional animations or more, so release it for BV users who wanna use it in their normal lot's lake or ponds... :D
Advertisement
One horse disagreer of the Apocalypse
#127 Old 1st Oct 2007 at 5:46 PM
Quote:
Originally Posted by niol
Lol, I kinda doubt that people without BV can get their sims to swim in a pond with just the beach portal due to lack of some transitional animations or more, so release it for BV users who wanna use it in their normal lot's sea lake or ponds... :D


No it doesn't work on ponds at all. I think EA hardcoded that the sims cannot go where there is pond water. Testing with a pond with water in, the sim just gets a slope icon. Using exactly the same pond, after a land-lowering click in the right place has let the water go down, the sim can happily pretend to swim in the now-empty pond. On the other hand, sea water is not counted as water at all. A sim will quite happily walk under the sea if you tell him to.

With the custom painting problem, could it be the material definition and texture is stored on a part of the lot you deleted?

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Mad Poster
#128 Old 1st Oct 2007 at 5:54 PM Last edited by niol : 2nd Oct 2007 at 7:28 AM.
Yes, the ocean reflection is defined in the neighbourhood shader that I'm working on besides modding or building lots. It's only slightly related to the reflection shader, which I just finalised my modifications these 2 days, for only the fallback material. Maxis reused the EP5 Swim-pool's Hi-end pool surface pass function with some modifications to make the ocean reflection and wavy animation. Maxis modded its own codes! The day I checked it, I was screaming for the irony and realised I needn't do that modification on the lotskirt water which now we call the beach in a beach lot. I'd add the swim-pool codes there, too but now Maxis saved my work .
I'm gonna try to make fewer EP versions of the neighbourhood shaders mods that may include modified lines as alternative choices for users. so as the swimpool ones. I'll see what seems right.
And surely, I wanna see a beach with big waves to engulf the poor sims .

But I'm not an expert.


No, that's not my lot, it's the user "Tsouka" stated in Mootilda's post. But, I'm gonna try too now...

Also, I missed the neighbourhood water (lotskirt water, the now ocean or beach water)-based lake, sea, pond since NL, may check the linked to see what I mean if not.http://www.modthesims2.com/showpost...976&postcount=4
Site Helper
Original Poster
#129 Old 1st Oct 2007 at 5:59 PM
Quote:
Originally Posted by niol
As for deletion of objects in the arrays of both 2D and 3D,
The up-messed lot is an instance of that. Yet, I could have made more than 1 mistake during that trial..

I 'm gonna try a copy of it and remove all the arrays after the stated offsets and the depth offsets for 3Ds (as long as I figure it out) to see what will happen after my excercises... :D

I was thinking last night about the results from your first test. As far as I could tell, you ended up with strips of unbuildable land in the middle of the buildable portion of the lot. I believe that there is a 2D Array Instance which controls which part of the lot is buildable; I'd have to research this.

If I am correctly interpreting the results of your test, I was wondering whether there might be a quick fix for these unbuildable areas... Have you tried running the LotExpander on the "messed-up" lot and not specifying any expansion (ie, Front, Back, Left and Right all set to zero)? You will get a warning message:

"No Value Changed

"You didn't change any of this Lot's Values. So the only effect is unlocking all tiles of the lot. Tiles will only remain unlocked until you replace the lot the next time. Is this your intention?"

Click on the "Yes" button. The LotExpander will unlock all of the tiles on the lot and you should get a final screen to that effect.

Now, make sure that all of the excess road and sidewalk tiles are deleted and save the lot. With any luck, the unbuildable areas will become and remain buildable.
One horse disagreer of the Apocalypse
#130 Old 1st Oct 2007 at 6:02 PM
Well - if you can make the entire lot buildable, we won't have to shrink lots to get row houses :D

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Site Helper
Original Poster
#131 Old 1st Oct 2007 at 6:05 PM Last edited by Mootilda : 1st Oct 2007 at 8:56 PM.
Quote:
Originally Posted by Inge Jones
With the custom painting problem, could it be the material definition and texture is stored on a part of the lot you deleted?

As far as I know, the LotExpander doesn't delete any part of the lot. The only exception is the 3D Array Instance 3 documented above. That's why I suspect this particular record instance.
One horse disagreer of the Apocalypse
#132 Old 1st Oct 2007 at 6:09 PM
Quote:
Originally Posted by Mootilda
As far as I know, the LotExpander doesn't delete any part of the lot.


Oops! Oh yes lol! I was getting too eager for the shrinker :D

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Site Helper
Original Poster
#133 Old 1st Oct 2007 at 6:13 PM Last edited by Mootilda : 3rd Oct 2007 at 6:29 PM.
Quote:
Originally Posted by Inge Jones
Well - if you can make the entire lot buildable, we won't have to shrink lots to get row houses :D

That thought just occurred to me as I was typing that post.

Has anyone tried this? I must admit that I'm not familiar with this section of the LotExpander code at all. I'm making some assumptions about what kinds of things it might be able to fix.

I should definitely look into this before starting to work on the logic to decrease the size of the lot. If anyone learns anything before then, please let me know.

[Updated:]
If the unlock feature doesn't work for townhouses, it's possible that Andi only unlocked the normally-buildable areas of the lot (ie, he left 2 spaces locked around the outside of the lot. So, the fact that it might not currently work doesn't mean that it will never work... just requires me to try to figure out some code that I've been avoiding so far.

[Another Update:]
I tested this and it doesn't unlock the tiles at the edge of the lot. So, I need to research this whole issue.
Mad Poster
#134 Old 1st Oct 2007 at 6:20 PM Last edited by niol : 1st Oct 2007 at 9:20 PM.
The mislocated road pieces can be built with the moveobjects on cheat already, but SimPE had been giving me some hard times to save lots properly in-game until I turned it down for a while before I run the game again for proper saving on the neighbourhood and lot files...
The problem is only that SimPE prevented these files to get over-written by the game even the files are closed in simPe.
Just some dumb moments for the memory dumps.

Oh yes, knowing how the lot edge is locked to build is the way to probably disable it :D
But, I'll worry about the stability of the resultant. I had used fences as default replacement for the wall-1 wall partition and built it at the edges of a testing dummy lot. Access to that lot without the default replacement crashed the game but at least not a deadly crash to the whole game system like some custom windows do that I had to reinstall the whole game .
So, a by-passing strategy is necessary to stabilise partitions that "support" the next level of gridlines in a lot or enervate the check.

Quote:
Originally Posted by Inge Jones
No it doesn't work on ponds at all. I think EA hardcoded that the sims cannot go where there is pond water. Testing with a pond with water in, the sim just gets a slope icon. Using exactly the same pond, after a land-lowering click in the right place has let the water go down, the sim can happily pretend to swim in the now-empty pond. On the other hand, sea water is not counted as water at all. A sim will quite happily walk under the sea if you tell him to.
...


Can sims become moving pond plants? :D
]
added the attached 3 pix for the next post.
Screenshots
Mad Poster
#135 Old 1st Oct 2007 at 7:11 PM Last edited by niol : 1st Oct 2007 at 9:19 PM.
So, I made 30x30 lot in strangetown
1. + a sims family
2. + painting slot on the top left 1st ground grid (deleted later)
3. sims max creativity by insimenator
4. paint still life with "c" (Paintinglot001-paintingStart.jpg, Paintinglot002-paintingIntermediate.jpg, Paintinglot003-paintingFinished)
5. With "moveobjects on" cheat, painting over persons (Paintinglot004-paintingOverSims-mot.jpg)
6. Somehow the painting got diagonally placed at the third grid from the top left of the lot (when the road is closer to the viewer) in the base game (EP0) (Paintinglot005-paintingDiagonallyPlaced-EP0.jpg)
7. + Inge's shrub teleporter plus to turn the sims a townie (Paintinglot006-TeleportorInge.jpg, Paintinglot007-sims=townie.jpg)
8. PaintingSlot is removed (Paintinglot008-SlotPaintingRemoved.jpg)
9. sims's graphical and the painting are stuck in the lot even after reload. (Paintinglot009-simsPaintingStuckInLot.jpg)

The attached are the lot.package file and the exported file.

Special Notices:

3D array
0x00000000: repeated chains
0x00000003: ---01x10-00x20--- repeated chains after Andi's stated offsets.
0x0000000C: "random" sparse values -000000-0N-

txmt:
#0x7fdf25b4!painting_540dd470_txmt for the painting material definition
txtr:
#0x7fdf25b4!painting_540dd470_txtr for the painting graphic

ObjT at least first few ones have portal infos just in case for readers who just didn't know.
instance 0x0000000C : easel infos
instance 0x0000001B : easel painting
instance 0x0000008B : easel painting
instance 0x0000008F : easel pallette

I skipped obj xml (I'm sleepy at the moment)

unknown type 0x6C589723 holds the lot name

That's it for now except the unchecked obj xml

I need a nap now .

The other 3 pix are attached in the previous post.
Screenshots
Download - please read all instructions before downloading any files!
File Type: rar N002_Lot24-[ainting.rar (631.2 KB, 7 downloads) - View custom content
One horse disagreer of the Apocalypse
#136 Old 2nd Oct 2007 at 12:04 AM
Experiments with 3-D array resources. Lot included tree, fish pond, swimming pool, roof, railings, modular and non-modular stairs, portrait, still life, foundation, walls, floors, wallpaper, furniture.

Deleting each one of the following in turn resulted in:

3D-00 Sidewalk, road and floor tiles missing, leaving just space. All objects still apparently supported in previous places.

3D-01 Terrain contour info. Terrain flattened to road level leaving all objects where they were in absolute co-ords (ie now sunk or floating). Walls gone (except loft walls). Roof and railings collapsed onto ground. Pond just a black shadow. No new objects can be placed

3D-03 Nothing
3D-09 Nothing
3D-0A Nothing

3D-0B Interior objects have shadows as if they are outside. Half-down walls setting all walls remain up. Fully down walls still works. I would say this is losing the info about what is inside and what is outside.

3D-0C Nothing
3D-14 Nothing
3D-15 Nothing
3D-1B Nothing
3D-20 Nothing

At no point did I lose the textures on my portrait or still life. Was I meant to also test an actual custom painting?

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Site Helper
Original Poster
#137 Old 2nd Oct 2007 at 12:49 AM
Quote:
Originally Posted by Inge Jones
Experiments with 3-D array resources. At no point did I lose the textures on my portrait or still life. Was I meant to also test an actual custom painting?

This is all useful information and, for now, I'll add comments to the LotExpander code about your findings. Must admit that I'm surprised at how many records you deleted that had no effect.

My intention is to try to reproduce Tsouka's problem:
Quote:
Originally Posted by Tsouka
I have Nightlife and Pets, no stuff packs. The portraits were created from within the game with the 'Paint Portrait of...' option on the easel.

At this point, I don't know how to reproduce her problem. I don't even know whether her problem is caused by the LotExpander (although it seems likely, since it always seems to occur when running this program).

I guess that the first thing that I'll try, when I get a chance, is to create a painting using Tsouka's method, and then expand the lot. If the painting survives the process, I might try installing just Nightlife and Pets, then try again. If the painting still survives, I might ask for her lot, to see whether I can reproduce the problem with or without her custom content. If that doesn't work... hmmm, guess I'm stumped.

Once I manage to reproduce her problem, I'll try deleting the 3D Array Instance 3, to see whether it affects the custom painting. If not, I'll probably look through the code to try to find other record instances that have "strange" logic. I'm just trying to figure out where to start looking for a problem with this type of painting in the LotExpander code.

I must admit that this seems like a horrible way to approach the problem, but I just don't know how else to find a problem like this when I don't have access to the game source code. I really am a newbie when it comes to modding and my skill-level is pretty low. As a programmer I'm fine, but modding seems to require a whole new set of skills.

If anyone has any other ideas on how to approach this, I'd love to hear them.
Alchemist
#138 Old 2nd Oct 2007 at 3:21 AM Last edited by aelflaed : 2nd Oct 2007 at 8:37 AM. Reason: spelling
Default 1 x 1 lot
I'm back! What a lot has happened here over the weekend. I had a little trouble finding what related to me again, but I'm up to speed now.

Quote:
Originally Posted by Mootilda
To swap the side of the road used, we just need to swap the Y values between the Car Portals and the Service Portals:
(...)
Note that this will not change the direction that the cars are travelling. If that's wrong, too, then we'll need to change the X values as well.


I thought I had done that, but maybe I only changed one set of values - the cars moved onto the Maxis side of the road, but the direction didn't change. I'll have another go.

I will also try the suggestion of running LotExpander on the lot to see if that re-enables the building area. I agree, that is a far more serious issue than what side of the road the cars travel on.

I'll report back later.
....

(edit) I changed the portal values, but as happpened before (I DID try it), the cars moved to the other side of the road, without altering their direction at all. The values I used were
Service start 2.5, 15.5
Service Stop 9.5, 15.5
Car Start 9.5, 14
Car Stop 3.5, 14

The cars aren't completely in the other lane, though, more in the middle of the road. But definitely facing the same direction.

Also, I can't use the LotExpander on this lot. My old version seems to run, but offers only the fullgame neighbourhoods, without a browse option. The newer version Mootilda has posted won't run, and gives me this error "Index was outside the bounds of the array." I posted this error in the LotExpander thread, too. I already tried re-downloading.

In any case, if LotExpander won't show me the Minigame neighbourhood, how can I use it on this lot? If I put the lot temporarily into my full game, won't that make it unusable when it gets back to the basegame Starter? Does the new version have a browse option?

Stumped again.
One horse disagreer of the Apocalypse
#139 Old 2nd Oct 2007 at 10:54 AM Last edited by Inge Jones : 2nd Oct 2007 at 11:07 AM.
Quote:
Originally Posted by Mootilda
I guess that the first thing that I'll try, when I get a chance, is to create a painting using Tsouka's method, and then expand the lot. If the painting survives the process, I might try installing just Nightlife and Pets, then try again. If the painting still survives, I might ask for her lot, to see whether I can reproduce the problem with or without her custom content. If that doesn't work... hmmm, guess I'm stumped..


No need, I've just confirmed this myself. I have all EPs and SPs. On the same lot I was using for my previous tests, just using my saved version to overwrite the one in the hood like I always did, so not even the Sims have changed their activities. I ran the lot expander on it and expanded it one tile to the right. Went into the game, and the portrait and still-life had writing all over them. So I would say yes the Lot Expander is losing custom painting materials, but no it's not to do with any of the 3DARYs. I did test deleting instance 0x03 *twice* to make sure, but my paintings were fine.

Interestingly, the expanded part of the lot turned into a fish pond, with fish, and the man was actually allowed to fish there. I have a feeling I could have made it swimmable, too! Image attached.
Screenshots

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Site Helper
Original Poster
#140 Old 2nd Oct 2007 at 2:18 PM Last edited by Mootilda : 2nd Oct 2007 at 3:13 PM.
Quote:
Originally Posted by Inge Jones
No need, I've just confirmed this myself. I have all EPs and SPs. On the same lot I was using for my previous tests, just using my saved version to overwrite the one in the hood like I always did, so not even the Sims have changed their activities. I ran the lot expander on it and expanded it one tile to the right. Went into the game, and the portrait and still-life had writing all over them. So I would say yes the Lot Expander is losing custom painting materials, but no it's not to do with any of the 3DARYs. I did test deleting instance 0x03 *twice* to make sure, but my paintings were fine.

Thanks for doing this. Obviously this is going to require some code investigation on my part. I now have a theory about where to look for the problem.

Does anyone know whether this worked in earlier versions? Even better, does anyone know when it stopped working?

Quote:
Interestingly, the expanded part of the lot turned into a fish pond, with fish, and the man was actually allowed to fish there. I have a feeling I could have made it swimmable, too! Image attached.

Yes, I've seen this as well. We definitely need the neighborhood terrain for these lots! Unfortunately, it's not going as smoothly as I had hoped and I need to take a break to look at aelflaed's issue with array bounds.

Ah, if only I could clone myself a couple of times.
Site Helper
Original Poster
#141 Old 2nd Oct 2007 at 3:24 PM Last edited by Mootilda : 3rd Oct 2007 at 5:05 AM. Reason: New test version
Quote:
Originally Posted by aelflaed
I changed the portal values, but as happpened before (I DID try it), the cars moved to the other side of the road, without altering their direction at all. The values I used were
Service start 2.5, 15.5
Service Stop 9.5, 15.5
Car Start 9.5, 14
Car Stop 3.5, 14

Your portal values certainly look right to me. This must mean that there is some other value in the file which determines the direction of travel. I have been assuming that the vehicles would always travel from Start to Stop. This will require some more research into the portals.

Does anyone else here have any ideas on this?

Quote:
The cars aren't completely in the other lane, though, more in the middle of the road. But definitely facing the same direction.

Until we fix the direction of the portals, I wouldn't worry about this. This should be easy to fix by tweaking the values a bit.

Quote:
Also, I can't use the LotExpander on this lot. My old version seems to run, but offers only the fullgame neighbourhoods, without a browse option.

In any case, if LotExpander won't show me the Minigame neighbourhood, how can I use it on this lot? If I put the lot temporarily into my full game, won't that make it unusable when it gets back to the basegame Starter? Does the new version have a browse option?

Try the TEST version of the LotExpander, below:
http://www.modthesims2.com/showthread.php?p=1785958
Site Helper
Original Poster
#142 Old 2nd Oct 2007 at 7:19 PM
Quote:
Originally Posted by niol
3D array
0x00000000: repeated chains
0x00000003: ---01x10-00x20--- repeated chains after Andi's stated offsets.
0x0000000C: "random" sparse values -000000-0N-

txmt:
#0x7fdf25b4!painting_540dd470_txmt for the painting material definition
txtr:
#0x7fdf25b4!painting_540dd470_txtr for the painting graphic

ObjT at least first few ones have portal infos just in case for readers who just didn't know.
instance 0x0000000C : easel infos
instance 0x0000001B : easel painting
instance 0x0000008B : easel painting
instance 0x0000008F : easel pallette

Thanks so much. Based on this information, I was able to find the problem with the portraits. Now, I just need to figure out how to fix it.

Quote:
Originally Posted by niol
unknown type 0x6C589723 holds the lot name

I knew that it was in there somewhere... just couldn't seem to find it when I wanted it.
One horse disagreer of the Apocalypse
#143 Old 2nd Oct 2007 at 8:01 PM
The new version works nicely for expanding flooded lots backwards into the sea, without worrying what orientation they were created, so thank you for that

Now, am I to understand the custom painting info was in 3Darray instance 0xC? Because I swear my custom paintings didn't go funny when I deleted that one.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Site Helper
Original Poster
#144 Old 2nd Oct 2007 at 9:07 PM
Quote:
Originally Posted by Inge Jones
The new version works nicely for expanding flooded lots backwards into the sea, without worrying what orientation they were created, so thank you for that

Excellent. Sorry that the rest of the neighborhood terrain is taking so long... turned out to be a harder problem than I thought.

Quote:
Now, am I to understand the custom painting info was in 3Darray instance 0xC? Because I swear my custom paintings didn't go funny when I deleted that one.

No, not in the 3DArray at all; that was a false lead. The tests that you and niol did helped me to narrow down the problem... I must have been working on this problem in a background thread in my brain, because all of a sudden, I knew what the problem was.

I'm hoping to have a new version really soon... would you mind testing it again with your custom paintings?
One horse disagreer of the Apocalypse
#145 Old 2nd Oct 2007 at 9:23 PM
I accidentally deleted the paintings lol - meant to put them inthe inventory before moving the family but at the last moment got distracted. Never mind though he can paint really quickly now :D

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Mad Poster
#146 Old 2nd Oct 2007 at 9:50 PM
No, it can be due to the sims or other things,,, along the course for the whole testing, or even irrelevant completely that we have to look at somewhere else. At least it's less complex than a built lot.

All the listed are to further reduce the field of search. The differences are unnecessarily specific or directly related to the portrait problem.

But one thing I'm pretty sure, the character scene means the game can't get to the txtr for portrait picture to show up, so missing txtr file or anything on the related referencing pathway can be the case. Yet, not missing the material which in turns should have caused blue flashing. It's not material syntactic error with the magenta flashing. It's not the red or yellow flashing either.

The portrait in question still existed in the lot properly only missing the texture. So, it can be the reference linking the texture to the portrait is broken or not moved along with the portrait object's location.


Inge, you can use the one I've posted, too.. if you want...

One horse disagreer of the Apocalypse
#147 Old 2nd Oct 2007 at 10:33 PM
It's my bedtime now, but I have the paintings done and ready to test the new version with my morning cup of tea, if it's ready then

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Site Helper
DELETED POST
Original Poster
2nd Oct 2007 at 11:25 PM Last edited by Mootilda : 3rd Oct 2007 at 3:55 AM.
This message has been deleted by Mootilda.
Alchemist
#148 Old 3rd Oct 2007 at 1:20 AM Last edited by aelflaed : 3rd Oct 2007 at 1:35 AM.
Quote:
Originally Posted by Mootilda
Your portal values certainly look right to me. This must mean that there is some other value in the file which determines the direction of travel. I have been assuming that the vehicles would always travel from Start to Stop. (...)


Try the TEST version of the LotExpander, below:
http://www.modthesims2.com/showthread.php?p=1785770


I have messed with these values enough in this process to know they don't necessarily move from start to stop anyway - should have mentioned it, I suppose. Sometimes things/people have appeared on the edge of the lot where they always do, when I have put the value somewhere in the middle of the lot. On the x values, anyway - the road-to-rear axis seems to respond as expected.

I will try the test version - thanks.

Interestingly, I have just tried putting the lot into my full (Seasons) game, just to see what happened, and it worked perfectly - all the correct tiles were buildable and placeable, and the normally-locked tiles were locked. Go figure. However, the original lot, and the re-installed version of it, remain locked all over in the basegame starter. Weird.

I'll go see what I can do with the test LotExpander. Thanks.


EDIT - Aaargh! Same error as before with the 1.2.5 version. Does that mean it's something wrong in my system?
Site Helper
Original Poster
#149 Old 3rd Oct 2007 at 2:02 AM Last edited by Mootilda : 3rd Oct 2007 at 2:28 AM.
Quote:
Originally Posted by aelflaed
I have messed with these values enough in this process to know they don't necessarily move from start to stop anyway - should have mentioned it, I suppose.

This is valuable information; I'm obviously going to have to look at the portals some more. I'm sorry that moving the portals has been so difficult; I honestly thought that this would be a pretty simple process.

Quote:
Interestingly, I have just tried putting the lot into my full (Seasons) game, just to see what happened, and it worked perfectly - all the correct tiles were buildable and placeable, and the normally-locked tiles were locked. Go figure. However, the original lot, and the re-installed version of it, remain locked all over in the basegame starter. Weird.

Yeah, this seems very odd. I've been thinking about installing the basegame starter, to try to look into the rotation / portal issue. However, it sounds like you're having a lot of problems with it. I really don't want problems with my development machine.

I suppose that it's time to consider installing just the base game on my secondary machine. Luckily, I won a copy of Deluxe right after purchasing Bon Voyage, so there's no legal issues involved. And, since it's just the base game, it may even run!

Quote:
EDIT - Aaargh! Same error as before with the 1.2.5 version. Does that mean it's something wrong in my system?

At this point, I really don't know what the problem is. I know that you're using the basegame starter, but I really don't know much about how it works. Do you have this directory:
\My Documents\EA Games\The Sims 2\Neighborhoods

If not, try creating the directory structure, even if everything is empty. Then, try running the new LotExpander 1.2.6 again. If this works, then it's an easy thing for me to fix. In the interim, I'll take a look at the code and see if I can figure out what might be happening.
Alchemist
#150 Old 3rd Oct 2007 at 2:34 AM
Quote:
Originally Posted by Mootilda
This is valuable information; I'm obviously going to have to look at the portals some more. I'm sorry that moving the portals has been so difficult; I honestly thought that this would be a pretty simple process.
(...)
At this point, I really don't know what the problem is. I know that you're using the basegame starter, but I really don't know much about how it works. Do you have this directory:
\My Documents\EA Games\The Sims 2\Neighborhoods


The directory is there. Same error. I could try to uninstall the starter, although I'm not sure if I would lose anything I need to keep - have to do some checking beforehand. I don't have any other computer to install things on. Anyway, I really want it to work for basegame, so everyone can use the results.

The portals themselves weren't so bad, once I knew what to do - it's just unfamiliar, and I need to do it all with the Starter Pro (to keep things interesting?). Obviously I should have started this discussion two months ago, when I didn't have any expansions! I've barely played Seasons, since I'm spending all my computer time messing with basegame stuff.

Maybe I should try altering a larger lot, just to see what happens to that.
Page 6 of 97
Back to top