Replies: 249 (Who?), Viewed: 112166 times.
Page 10 of 10
Pettifogging Legalist!
retired moderator
#226 Old 25th Jun 2010 at 8:07 PM
Quote:
Originally Posted by Ceixari
Did you select the texture enable button as in this post
http://www.modthesims.info/showthre...019#post3212019 ?

EDIT:

Actually I went into the other .blend which crashes when you change to textured view. It also crashes for me, but if you click the button I refer to just above this edit, it doesn't crash.

Just confirming that this works for me – I ticked the button for both groups in my "Edit 4" version, and I can now view it in Textured mode without crashing. I can also export and re-import the 00000000 mesh successfully now.

I'm still puzzled why the low-res mesh won't import, but I'll now try making my own from the 00000000 one and just export over the original one; I seem to recall that I've done that in Milkshape before and it worked.

Stuff for TS2 · TS3 · TS4 | Please do not PM me with technical questions – we have Create forums for that.

In the kingdom of the blind, do as the Romans do.
Field Researcher
Original Poster
#227 Old 25th Jun 2010 at 8:40 PM
It is weird that the low res doesn't import. Just to make sure this is the 0000001 files you attached?

That did import fine for me, but it was very small. I had to zoom in a fair bit. You should see what was imported in the Outliner view.
Pettifogging Legalist!
retired moderator
#228 Old 25th Jun 2010 at 9:05 PM
I checked the Outliner view and saw nothing .. oh wait!

Seems like this is a display/redraw issue: upon resizing the viewport, it shows up in Outliner, and when I select stuff in that, it also shows up in the main view.

I moved the blender window out of the way just now so I can type .. that made it show up. Multitasking ftw!

Stuff for TS2 · TS3 · TS4 | Please do not PM me with technical questions – we have Create forums for that.

In the kingdom of the blind, do as the Romans do.
Field Researcher
#229 Old 29th Jun 2010 at 8:16 AM
I managed to create the object model in blende and export and package it, but in the game the filling was all cut into triangles (see image) - I was using all square faces, but only half of each face would be filled in the game, the rest would be transparent.
I figured out that if I used the "Convert to Triangles" option in blender to turn all faces from rectangles into triangles it would fix it, but I was wondering if this was a limitation of the import/export scripts, or something I could have messed up in blender, or if it's just the way the game works...
Screenshots
Pettifogging Legalist!
retired moderator
#230 Old 29th Jun 2010 at 1:25 PM
Pretty sure it's the game that needs triangular faces. I've never come across a TS3 mesh with quads before.

Stuff for TS2 · TS3 · TS4 | Please do not PM me with technical questions – we have Create forums for that.

In the kingdom of the blind, do as the Romans do.
Field Researcher
Original Poster
#231 Old 29th Jun 2010 at 1:48 PM
Yes, the game wants triangles

Note to self: check if there's a way to check for this when exporting.
Field Researcher
#232 Old 30th Jun 2010 at 7:05 AM
Ok, triangles it is then...
thanks
Lab Assistant
#233 Old 4th Aug 2010 at 11:08 PM
Thank you. I am a Blender user, and I have been using Blender for maybe about a year and a half now. I often create mods for games (where possible). This may be my entrance to a new line of modding...
Lab Assistant
#234 Old 10th Dec 2010 at 12:40 AM
Hi all,

First Congralutations to Ceixari and to everybody who works to this project. I'm now running Blender v2.55 Beta under Vista 64b... Do you think thhese Plugins are working fine with this Blender and Windows versions ?

I've tried to put them in the Blender's v2.55 new Python plugins folder located at:

[Drive:\][Program_Folder\]2.55\scripts\

but I can't get the plugins to be recognized under Blender's File Import Function !!!!

Here are some snapshots:

http://www.4shared.com/photo/CHOJJ5...nder_post0.html

http://www.4shared.com/photo/MUOeKj...nder_post1.html

http://www.4shared.com/photo/DumkDI...nder_post2.html

As you can easily see it on the previous snapshots, I've created a new folder (under \scripts\) named ts3 and save the 2 files there.... No success :-(

I dont know anymore what to do...

Thanks for answers. Nice day to all.
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
#235 Old 10th Dec 2010 at 4:42 AM
Quote:
Originally Posted by zano972
Hi all,

First Congralutations to Ceixari and to everybody who works to this project. I'm now running Blender v2.55 Beta under Vista 64b... Do you think thhese Plugins are working fine with this Blender and Windows versions ?


These scripts were written for Blender 2.49, and will not work in 2.55 (different API). I have written a script for 2.55 that is in testing:http://modthesims.info/showthread.php?t=423406

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| (• ◡•)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Lab Assistant
#236 Old 14th Dec 2010 at 12:48 PM
OK cmomomney Thanks a lot for your great job.
Test Subject
#237 Old 13th Jan 2011 at 10:54 AM
Awesome, been waiting for this really ever since the sims 3 came out. I am a looong time blender user... i remember getting v1.something. Love to give you some feedback on it too.
Lab Assistant
#238 Old 13th Jul 2011 at 5:43 PM
Default TS3 Blender plugin does'n work with blender v2.57
Hi all,

Hi cmomomey I come one more time with an error who has something to do withe the new updated blender plugin (I mean: io_TS3_tools.py)... I've last year installed your python plugin on blender v2.55 and it worked fine.
I've now installed the new script version (for Blender v2.57) and I get these scripts errors!













Is this script very Python's version dependant ? or what I'm doing wrong ?

Thanks in advance for answer.

PS: i'm running W7 Ultimate 64b (and i've tried it on Vista Ultimate 32b and I get the sames errors).

Thanks a lot for answer.

If you want to know your future...create it!
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
#239 Old 16th Jul 2011 at 6:11 PM
Are you using the latest version of the S3PE helper, or are trying to import an s3asc from a MLOD you decompiled with the Object Tool?

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| (• ◡•)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Lab Assistant
#240 Old 26th Jul 2011 at 8:08 AM
Hi cmomoney,

I'm using the new 64 bits S3PE version (I believe that the rights Helpers are included) and yes i'm importing an S3SAC from a MLOD decompilled with S3ObjTool... The normal way to do that.

Thanks a lot for your answer.

If you want to know your future...create it!
One horse disagreer of the Apocalypse
#241 Old 26th Jul 2011 at 9:18 AM
Do you have the 24th July test version? The helper and included wrappers are still being tweaked so unless you have the *very* latest you could still have a problem version.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Alchemist
#242 Old 26th Jul 2011 at 11:35 AM Last edited by orangemittens : 26th Jul 2011 at 11:59 AM. Reason: Added links
Quote:
Originally Posted by zano972
Hi cmomoney,

I'm using the new 64 bits S3PE version (I believe that the rights Helpers are included) and yes i'm importing an S3SAC from a MLOD decompilled with S3ObjTool... The normal way to do that.

Thanks a lot for your answer.
Zano, the latest stable version of S3PE exports .s3asc files that do not require decompilation with the ObjTool. The latest Blender plugins take advantage of this improvement but if you try to import a .s3asc into Blender that has been through the old ObjTool decompilation process you will cause an error.

The downloads thread for the Blender tools has instructions on how to export the LODs using s3pe's improved functionality so that they will work with the latest Blender tools version. Here's a link to that: http://www.modthesims.info/download.php?t=433882 If you still have questions after reading that, I've written a mini-tutorial on the topic which is posted at Simlogical. The tutorial is for Milkshape but the basics of exporting and reimporting the LODs from/to S3PE are the same no matter which editor you're using.

If you're using the current stable version of s3pe, the 0402-0951 version, you will also need the helpers and wrappers that go with it in order to utilize the new .s3asc export/import function. I've posted those with permission from Inge, Peter, and Atavera at Simlogical here: http://dino.drealm.info/den/denforu...php?topic=606.0
Note that those are only for the 0402-0951 version of s3pe.
Lab Assistant
#243 Old 27th Jul 2011 at 10:50 AM
OK Inge and orangemittens greats informations and thanks a lot. I think troubles are gone! loool

Nice day to all.

If you want to know your future...create it!
Test Subject
#244 Old 4th Apr 2012 at 2:02 PM
script error
hello! I'm having a big problem with the script in blender s3asc, when I import something occurs the error: error, pynthon script error, check console .. do not know what to do help me please, my blender version is 2.49
Alchemist
#245 Old 4th Apr 2012 at 2:49 PM
Quote:
Originally Posted by priscila25
hello! I'm having a big problem with the script in blender s3asc, when I import something occurs the error: error, pynthon script error, check console .. do not know what to do help me please, my blender version is 2.49
This tool is outdated. You're better off getting the current version of S3PE and then using the meshHelper for Blender. The meshHelper is here:

http://dino.drealm.info/den/denforu...php?topic=803.0

That is made to work with the Blender tools Cmo made which are up to date. That's here:

http://www.modthesims.info/download.php?t=433882

You'll have to update your Blender though most likely.
Test Subject
#246 Old 4th Apr 2012 at 7:10 PM
thank youuuuu....you are the best!
Test Subject
#247 Old 5th Apr 2012 at 8:32 PM
there is plug tsrworkshop to blender..for make obejcts?
Alchemist
#248 Old 5th Apr 2012 at 11:02 PM
Quote:
Originally Posted by priscila25
there is plug tsrworkshop to blender..for make obejcts?
There is no addon that goes directly from tsrw to Blender that I know of. Ceixari started working on one I think but afaik never finished it. There's workarounds but prolly the easiest thing for Blender users is to use S3PE and 3T (which have several nice features not found in tsrw).
Test Subject
#249 Old 8th Apr 2012 at 12:15 AM
I learned that I can import from tsr for the blender if I import as obj. file and vice versa, how I do it? is there any tutorial teaching? Thank you
Alchemist
#250 Old 8th Apr 2012 at 2:22 AM
Quote:
Originally Posted by pris25
I learned that I can import from tsr for the blender if I import as obj. file and vice versa, how I do it? is there any tutorial teaching? Thank you
There are no tutorials i know of that show how to do that. If you're using Blender you're best off using s3oc/s3pe. It's a more powerful editing system than tsrw is.

If you really want to stick with tsrw you will probably have to get Milkshape so you can use it to turn their extension into a .obj and then use it again to convert your completed .obj back into whatever extension it is they're using.
Lab Assistant
DELETED POST
10th Dec 2012 at 8:16 PM
Default Blender Export Script
This message has been deleted by PWN9483. Reason: Found resolution, use the right ver of Blender
Page 10 of 10
Back to top