Replies: 532 (Who?), Viewed: 180896 times.
Page 21 of 22
Test Subject
#501 Old 9th Jun 2014 at 9:59 PM
Quote:
Originally Posted by mr_db1
using windows 8.1 and SimPE runs without a problem on it
until this help thread was made my game justn didn't go past the 'sul-sul' sound and bodyshop came just as far as homecrafter
it's window-outline
happy to have found this thread I can finally go make the repairs to my game, thanks for that to those that made the files
I hope to have it in working order some time this week.
---------------------------------------------------------------------------
no succes yet, next thing to try:
(something I found in the windows 8.1 settings by accidentally clicking the right thing)
turning on support for old programs and the reboot to activate that
-----------------------------------------------------------------------------------------------------------------
last time update to this one:
the sims 1 always worked without problems only the creator needed a crack (but you don't need that info, do you?)
o.k. after the above mentioned "thing to try" my the sims 2 and the sims 3 both started working as they should

launchers both functional without anygame to help and running the game at optimal speed
and as with all new installs the CC came in with the second startup

here is what I did...........

I made sure all the updates were correctly installed
I set the DEP to exclude all the "the sims * " related programs
and I activated the checkbox for support of old software

now, my windows 8.1 is Dutch and translating the OS-names back to English is not my thing so,
I really can't tell you where to find the little checkbox, only that it is called support for old software
and that it has to be active to work with the games

I hope I helped







Hi, I installed The Sims 2 on my laptop (W8.1), everything goes fine until I try to use the Body Shop or to modify a sim's appereance in the game. I also patched the game, but nothing happened, I still have this problem. Can someone please help me?
Lab Assistant
#502 Old 10th Jun 2014 at 8:45 PM
Quote:
Originally Posted by annastreet94
Hi, I installed The Sims 2 on my laptop (W8.1), everything goes fine until I try to use the Body Shop or to modify a sim's appereance in the game. I also patched the game, but nothing happened, I still have this problem. Can someone please help me?


i also had that. have a look at this http://www.leefish.nl/mybb/showthread.php?tid=5446 , download the new graphics rules file and try again. strangely enough, it fixed the problem for me.
Test Subject
#503 Old 20th Jul 2014 at 7:47 AM
Anyone who had a problem with their UC version get it to work?
Lab Assistant
#504 Old 20th Jul 2014 at 7:53 AM
Quote:
Originally Posted by malonewashere
Anyone who had a problem with their UC version get it to work?


Yeah, turns out you have to wait until your game decides to react

My game freezes as soon as the intro finishes so I followed someone's advice from here and if you wait for about 10 minutes the game will then start running, I don't know what causes it but it works, lol.
Test Subject
#505 Old 20th Jul 2014 at 7:54 AM
I dont have a problem loading my game up, its CAS where it crashes. :/
Test Subject
#506 Old 20th Jul 2014 at 3:16 PM
A few notes about Ultimate Edition and Windows 8/8.1: (These are from my experience)

1. The Loading Screen will take forever, with the sound looping, on the FIRST bootup.
2. Wants and Fears sometimes will not appear, leaving a gray box.
3. Clicking some hair styles crashes the game in CAS.

I cannot fix these issues at all, and running in compatibility mode does nothing.
Lab Assistant
#507 Old 20th Jul 2014 at 8:43 PM
I still haven't try CAS, but after the endless startup freeze (it happens t me every time) all seems to run just fine. I've only played 1 family, though.
Test Subject
#508 Old 21st Jul 2014 at 1:55 AM
So, I'm using it on VMware player (XP) right now, the game is currently loading, taking forever. It did run Bodyshop though, which never worked on 8, but looked like complete crap. Anyone know how to fix that?
Lab Assistant
#509 Old 21st Jul 2014 at 2:01 AM
I have Windows 8 and the Sims 2 has worked just fine.

What are you talking about?

"'Why is Shinji blushing over everything Kaworu does,' you ask? He's gay..... gay gay gay gay gay" -Actual Kaworu
Test Subject
#510 Old 21st Jul 2014 at 2:06 AM
We're talking about our experiences with the game...
Lab Assistant
#511 Old 21st Jul 2014 at 2:08 AM
Quote:
Originally Posted by malonewashere
We're talking about our experiences with the game...

Oh, I see.
I thought The Sims 2 and Windows 8 wouldn't be compatible with Windows 8 and I had the most difficult time with it at first, then I finally got it to work by... I actually can't remember.

"'Why is Shinji blushing over everything Kaworu does,' you ask? He's gay..... gay gay gay gay gay" -Actual Kaworu
Test Subject
#512 Old 21st Jul 2014 at 2:13 AM Last edited by malonewashere : 21st Jul 2014 at 2:41 AM.
Did you have trouble installing it or crashes? I feel like most solutions are for installing the game.

EDIT: It runs on VM, but the neighborhood, CAS, and house walls are all flashing red/pink. -.-
Lab Assistant
#513 Old 21st Jul 2014 at 4:07 AM
Quote:
Originally Posted by malonewashere
Did you have trouble installing it or crashes? I feel like most solutions are for installing the game.

EDIT: It runs on VM, but the neighborhood, CAS, and house walls are all flashing red/pink. -.-


I just made a mistake with installing/compatibility. I'm uninstalling Ultimate Collection now because I didn't install that correctly either.

"'Why is Shinji blushing over everything Kaworu does,' you ask? He's gay..... gay gay gay gay gay" -Actual Kaworu
Forum Resident
#514 Old 21st Jul 2014 at 6:25 AM
Er...my laptop's on Windows 8 and the game works fine...
Top Secret Researcher
#515 Old 21st Jul 2014 at 6:35 AM
Quote:
Originally Posted by Averex
Er...my laptop's on Windows 8 and the game works fine...


Not everyone is so lucky, dear. It's mostly a hit and miss sort of thing, as TS2 was never optimized to run on anything newer than Windows Vista.
Test Subject
#516 Old 21st Jul 2014 at 10:03 AM
Quote:
Originally Posted by SakuraKiss
I just made a mistake with installing/compatibility. I'm uninstalling Ultimate Collection now because I didn't install that correctly either.


How are you installing UC? You don't just click 'download' in origin?
Test Subject
#517 Old 21st Jul 2014 at 10:53 AM
Quote:
Originally Posted by malonewashere
How are you installing UC? You don't just click 'download' in origin?

No idea why people are having issues. Once your download finishes in origin it installs by itself. How on earth could people be making mistakes? lol
Lab Assistant
#518 Old 22nd Jul 2014 at 5:57 AM
Quote:
Originally Posted by cameroncr95
No idea why people are having issues. Once your download finishes in origin it installs by itself. How on earth could people be making mistakes? lol


My game was really glitchy at first and I thought it was due to some installation or CC issues? You're quick to assume things.

"'Why is Shinji blushing over everything Kaworu does,' you ask? He's gay..... gay gay gay gay gay" -Actual Kaworu
Test Subject
#519 Old 23rd Jul 2014 at 2:07 PM
looks like i'm lucky that it works on my windows 8 - my friend also installed the sims 2 onto his windows 8 computer, but it didn't work for him. :P
+ if gta iv doesn't work on your computer, change the compatibility settings to "windows vista service pack 2". i did that and it worked like a charm. at first it didn't even allow me to install the game but when i changed the compatibility settings it worked. i'm playing it on maxed settings and it runs smoothly and doesn't crash at all.

p.s.: la noire also works very well on my pc.
Test Subject
#520 Old 24th Jul 2014 at 12:53 PM Last edited by malonewashere : 24th Jul 2014 at 2:02 PM.
Quote:
Originally Posted by acrylicpainting
i also had that. have a look at this http://www.leefish.nl/mybb/showthread.php?tid=5446 , download the new graphics rules file and try again. strangely enough, it fixed the problem for me.


I just tried this and it actually worked! Well, atleast I got to make a sim, move them into a house, and play one sim day.

The real test is if it handles CC.

EDIT: I put some cc in and it still runs great. Bodyshop works too! :D
Test Subject
#521 Old 20th Sep 2014 at 9:07 PM
Default Thank You ^_^
Thank you this works also tell ur boyfriend he saved my life Ty so much ty ty ty ty tyyyyy!!
Quote:
Originally Posted by Raven Dragonfire
Sure!
I'm uploading it here, so other people can use it too.

You just have to run the GrumpyLoader and then load the patch exe file in it. Proceed with the patch installation as usual and then the GrumpyLoader will tell you that it encountered an error and will ask you if you want to ignore it. You click yes and go on. It will find another error, just ignore it again and the GrumpyLoader will shut down. Then try to run the patch exe file again and it will tell you that "the sims 2 university has been already updated" (for example).

After this procedure, I've checked every single file in the "Sims 2 University" folder, comparing the win8 ones with the xp ones I have on the virtual machine, and there's a 100% match.

I used this program just for uni and nightlife patches, since I don't have problems with the other ones, because they don't need any cd to run.
I've played for several hours and everything is fine, no bugs no crashes

In case you have troubles, just let me know!
Test Subject
#522 Old 27th Sep 2014 at 8:54 AM
Quote:
Originally Posted by zoey7828
Thank you this works also tell ur boyfriend he saved my life Ty so much ty ty ty ty tyyyyy!!


Well, I don't know if anyone saved my life ... I may as well have lost it as all my spare time can now be spent Simming ...

It was instafling the config files that worked for me ... went made last night just creating Sim families just in case it started crashing

thank you ... thank yu .... thank you
Test Subject
#523 Old 10th Oct 2014 at 12:07 AM
Hi, I'm new here, so I'm not sure if I am posting in the right place (or if this had already been answered), but I can't run GrumpyLoader at all.

When I download it, it downloads as a non-existent ".7z" file and I can't find another way to get it to run properly. Does anyone know a fix for this?
Forum Resident
#524 Old 10th Oct 2014 at 9:53 PM
Quote:
Originally Posted by Irvine
Hi, I'm new here, so I'm not sure if I am posting in the right place (or if this had already been answered), but I can't run GrumpyLoader at all.

When I download it, it downloads as a non-existent ".7z" file and I can't find another way to get it to run properly. Does anyone know a fix for this?

You need 7zip to open a .7z file.

http://www.7-zip.org/
Test Subject
DELETED POST
5th Jan 2015 at 12:40 PM
This message has been deleted by trish2013.
Test Subject
#525 Old 11th Jan 2015 at 2:57 PM
I can't find grumpy loader. If anyone can please help me. Greatly appreciated.
Quote:
Originally Posted by Raven Dragonfire
Sure!
I'm uploading it here, so other people can use it too.

You just have to run the GrumpyLoader and then load the patch exe file in it. Proceed with the patch installation as usual and then the GrumpyLoader will tell you that it encountered an error and will ask you if you want to ignore it. You click yes and go on. It will find another error, just ignore it again and the GrumpyLoader will shut down. Then try to run the patch exe file again and it will tell you that "the sims 2 university has been already updated" (for example).

After this procedure, I've checked every single file in the "Sims 2 University" folder, comparing the win8 ones with the xp ones I have on the virtual machine, and there's a 100% match.

I used this program just for uni and nightlife patches, since I don't have problems with the other ones, because they don't need any cd to run.
I've played for several hours and everything is fine, no bugs no crashes

In case you have troubles, just let me know!
Page 21 of 22
Back to top