Replies: 110 (Who?), Viewed: 80207 times.
Page 2 of 5
Ms. Byte
Original Poster
#26 Old 19th Sep 2011 at 5:05 PM
LOL, the game likes to give you a challenge!
#27 Old 19th Sep 2011 at 6:02 PM Last edited by BloomsBase : 19th Sep 2011 at 6:42 PM.
I wanted to make a replacement for the simbot from Ambitions but that file seems a bit complicated....
Both male and female share the same body mesh but both have a extra GEOM for the head/face(listed as hairfiles)
First i thought about replaceing the CASP for it but that didn't work out.

And, there are 2 versions of the Simbot, one you buy and one you create
Both share the same meshes and textures exept for the overlay texture(wich is rusty for the one you buy)
I suspect the rusty one only uses a full overlay while the created one is colored
Another thing is that whenever i make a change to the textures they wont get aplied(even when deleting my caches...)
As always i have awsome ideas but have to give up early.....

Wanted to give the bot eyelashes, thats why i asked
But with one texture conflicting with another it seems impossible(for now)

The lashes do show up therefore.......i thank you
Just need to make em bigger
Here is a teaser
Ms. Byte
Original Poster
#28 Old 19th Sep 2011 at 9:16 PM
LOL, that's a bit scary! I'm glad you had some success.
#29 Old 22nd Sep 2011 at 1:38 AM
I have figured it out but its not possible to make a replacement for both the male and female.
#30 Old 1st Oct 2011 at 9:53 PM
i am still having problems.....
I did a simple test with the earrings(hoops) but no matter wat i try i do not get them transparant.

Cloned the hoops with TSRW and changed it to 4 color file(maybe i shouldn't have done that?)
And i updated the DXT1 multiplier to DXT5interpolatedalpha(edited with a transparant alpha layer)

After extracting and converting i opened the file with S3PE etc etc
But no transparancy
Ms. Byte
Original Poster
#31 Old 2nd Oct 2011 at 8:25 PM
I tried the hoops using CTU and got a change in shape I don't understand - less smooth, as if it's using the wrong lod. I tried twice and got the same thing. No transparency, just like you. All I did was change the shader in the meshes and import them, and change the alpha in the base texture. Maybe it just doesn't work with earrings? Or maybe with this particular mesh?
#32 Old 2nd Oct 2011 at 8:47 PM
yes, CTU doesn't always uses the correct meshbox for accesoires.
Delphy just used one setup for all while some have a veryhigh lod( lod0)

Ill use the bracelet instead, no problem
#33 Old 31st Jan 2012 at 11:29 AM
This is awesome if it can be implemented to Master Suite Stuffs lingeries.

EA lingerie transparency is fake!
Test Subject
#34 Old 5th Feb 2012 at 8:57 PM
I'm trying to make a transparent dress but I really can not get the hang of this. I am perfectly fine at making stuff for the sims 3, however this tutorial just stumps me.
Everytime I try to scroll down to my dress in game it crashes. I have more experience with TSRW than I do making clothes with other programmes, however I do have some knowledge with such programmes (s3pe, ect.). If theres any tutorials I should look at or if someone could develop a more indepth 'dummies' guide that would be greatly appreciated
All help given will be highly appreciated
Ms. Byte
Original Poster
#35 Old 5th Feb 2012 at 10:42 PM
Maybe I do a more in-depth tutorial at some point, but this is a pretty advanced topic and IMO any tutorial of the type you're talking about would be pretty involved. Maybe if you get more familiar with meshing and texturing you'll be able to follow this one.
Lab Assistant
#36 Old 27th Sep 2012 at 5:32 AM
Ms. Byte
Original Poster
#37 Old 27th Sep 2012 at 11:29 PM
SMBD? I don't know what that is.

Accessories often have coloring problems. Maybe it's just worse when they're transparent - I don't know.
Lab Assistant
#38 Old 28th Sep 2012 at 2:53 AM
smbd = somebody .... like smth = something...
we lerned it in scool... may be it's wrong XDDD
#39 Old 28th Sep 2012 at 8:04 AM Last edited by BloomsBase : 28th Sep 2012 at 8:32 AM.
downloading the file, 22.5 mb!!!????
curious wats in it :D

Beautiful work!!
There are 2 or 3 things that might will fix the file:
You mixed 2 setups, you either use the simhairshader and edit through the multiplier or
you use the ep6 shader and edit through both multiplier and trancsparancymap.

In your file you used the transparanymap but enabled the simhairsimple shader.
And i dont know if that shader works correct with accesoires.
SO, you best use the ep6 shader:

-open project contents
-right click the GEOM
-open in S3PE - select the GEOM and click the GRID button at the bottom
- open the Chunkentries and open the RCOLblock till you see the shader listed
- Change the shader number into 0xDC077A45 (3691477573)
- commit and save the file

The ep6 shader needs transparancy enabled, you need to enable it at the bottom of each texture preset tab
IT is under parthighlighting, open the + and enable transparancy(set to true)

Another thing that needs changed is the specular texture, those are DXT1noalpha
You either save as DXT1noalpha or you save it as DXT1onebitalpha(with a completly white alpha channel, it gets killed when saving)
Lab Assistant
#40 Old 28th Sep 2012 at 11:08 AM Last edited by Cat_Kira : 28th Sep 2012 at 11:27 AM.
well if it help to somebody

but we have not solved the problem =))

it works

but i cant open it in TSRW... try to use CTU and S3PE
Download - please read all instructions before downloading any files!
File Type: zip (241.3 KB, 14 downloads) - View custom content
Lab Assistant
#41 Old 28th Sep 2012 at 12:14 PM Last edited by Cat_Kira : 28th Sep 2012 at 12:38 PM.
omfg, it works!

1. mask must be dtx5 with black areas* on alpha
2. mult must with black areas* without alpha
3. spec must be none

*areas - what must be transparent

but... there is other problem...
#42 Old 28th Sep 2012 at 12:44 PM
that is the ep6 shader, the simhairsimple is much more smooth and supports transparancy
Lab Assistant
#43 Old 28th Sep 2012 at 12:48 PM Last edited by Cat_Kira : 28th Sep 2012 at 1:03 PM.
yes, but will be problems with multiple may be... will try and write results here

doesn't work...
may be there is some flag that block intersection of textures at different objects...
#44 Old 28th Sep 2012 at 1:47 PM
The problem is that EA never uses diffrent multiplier setups in one file, it something toolmakers discovered.
It does work when you use the ep6 shader and the transparancymap but the simhairsimple shader has diffrent setup.
I think that if you try this on clothing you have the same results
#45 Old 28th Sep 2012 at 2:21 PM
i can not get it to work in CAS, i am sorry
Only thing you can do is release the wings as seperate accesoires.
Not sure if you want to release it as sims3pack?

If i would release this i prolly go for the dxt1 texture(less space) and make one file with the mesh in it.
I would delete the vpxy files and GEOMS and clone the file few times for the other texture setups
Then stuff everything together as dbc package

On the other hand, its a small meshfile so you also could release 5 seperate sims3packs
you still have to test if it works with just one multiplier setup(when using other accesoires aswell)
If even that is not going to work then it is definatly the simhairshader causing this and not the diffrent multipliers

I could try a clone with S3OC but i doubt if it will make a diffrence
Lab Assistant
#46 Old 28th Sep 2012 at 2:35 PM
if multiple is one, have same issues.

it is never mined s3pack or package it will be.
i just want make it work correctly...
Lab Assistant
#47 Old 28th Sep 2012 at 3:36 PM
pfff, i cant make clear is too blurry
#48 Old 28th Sep 2012 at 4:47 PM
to crispy arround the edges you mean?
There is another shader that works with the transparancymap, the one from the store hula.
It uses 0xDC077A45 (3691477573)
But i doubt it will be better, i used it on a alphaskirt testfile:
Not sure but i thought i never got it to work without the hash or correct Bone file
Lab Assistant
#49 Old 28th Sep 2012 at 5:17 PM Last edited by Cat_Kira : 28th Sep 2012 at 5:35 PM.
no... i about texture
look at attachments - in TSRW is good, in game is awfull

about 0xDC077A45 (3691477573)
i tried use it, but it was like here

i want to clone mesh with high, medium and low meshes, does it help with textures problem?
Lab Assistant
#50 Old 28th Sep 2012 at 5:55 PM
try use clothes to use normal map... when transparent (0xA7B368FB) sets i get this...
Page 2 of 5
Back to top