Replies: 0 (Who?), Viewed: 331 times.
Test Subject
Original Poster
#1 Old 11th Jun 2020 at 2:39 PM Last edited by Lemurphs : 11th Jun 2020 at 2:49 PM.

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life, Island Paradise, Into the Future
Default Installing my Sims3Pack files has started to cause TS3 to launch to a black screen with no response
Second post within the space of a week. Oof. Not having a good one.

Recently I had to re-download all my Sims 3 Store content again because it stopped working (separate issue) and I did what I usually do, which is to select all my content in the launcher and install it one batch (third party custom content and Store Items). When I clicked play, the game launched but only got as far as a blank screen which becomes unreponsive if I try to minimise it or click on it.

I can't work out why this has only started happening now, I've been playing with these Sims3Packs installed for years. I'm not using more content than I used to, and never had this issue before. No recent changes to my PC, either. I've done a lot of reading and troubleshooting to fix it myself but nothing so far has helped. I've tested it in batches and I know that there isn't any one piece of content that's causing the issue. It works fine until I build them up to a certain point. It could potentially be a conflict but I've not been able to work out if that's the case - the conflict tool didn't seem to help me resolve the issue.

I've tried waiting to see if the game will launch properly after a delay but after half an hour it's still on a black screen and trying to click on it stops it from responding until I manually end the task.

I've cleared my caches, which hasn't helped. I also read that it's best to install things via the launcher in small batches instead of all in one because the launcher is bad at handling large amounts of data at a time. I've tried that (it took a very, very long time) and tested the game every time I'd installed a new batch but inevitably, it happened again when I got less than half way through. The only way to stop it from doing it is to do delete my folder and start again.

So I'm wondering a few things:

- Is there a reason it's started happening?

- Is there a way I can fix this?

- Is there a limit to how much content you can install through the launcher? I have about 6000 items (it's never been a problem until now) which is a lot but the performance has never been an issue. Weirdly, even when I've halved it to 3000, much less than I usually use, the issue still happens.

I just want my content back! Thanks for reading, and hopefully thanks in advance for any advice?
Back to top