Replies: 3 (Who?), Viewed: 537 times.
Test Subject
Original Poster
#1 Old 9th Jun 2020 at 10:21 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Seasons, University Life, Island Paradise
Default Sim is unable to sleep on command
Hey there community,

I'm having an issue regarding one of my sims in a family of three (2 adults, 1 child). One of my sims is unable to sleep on command.

Normally, when a sim has been selected and you click on the bed, there should be the option "Sleep" popping up. (I try guessing the right English words for these commands since my game is Dutch so forgive me if these aren't accurate.) This option does not pop up. However, the options "Take a nap", "Relax" and any other commands are available for the sim.

A short, probably important story: I started with a female sim and everything worked just fine. This sim found a boyfriend and he became her roommate. In this stage the male sim wasn't "mine" yet so I didn't have control over it back then but it did sleep on its own when he needed to. The couple got married and so I received control of the male sim. At that point I noticed I immediately did not have the sleep option for this sim. As far as I know everything else works. Here is a line up of things I tried and noticed:

- I have a 2-persons bed, I tried to replace it multiple times with multiple beds.
- The option also doesn't come up on 1-person beds.
- I moved to another house, the issue still occurs.
- The sim does sleep on its own when he needs to.
- "Take a nap", "Relax" and other options are available for the sim.
- Other sims aren't having this issue.
- There are no obstacles or anything in the way. The option "sleep" simply does not exist for this sim.
- I used the resetsim * cheat but this did not have any effect on the issue.

I feel like this issue has to do with the fact that the sim wasn't mine to start with? Since he moved in and became my sim after marriage.

If any other information is needed, please let me know.

Thanks in advance,
Juneau.
Advertisement
Mad Poster
#2 Old 9th Jun 2020 at 11:27 PM
I believe the issue is not that the sim was once a Roommate exactly, but that sims who are to be married must come from a proper and identifiable resident household. Roommates are technically homeless NPCs and share a "household" with all other non-resident sims. A better way to have proceeded there would have been to dismiss this roommate and them immediately get them into a resident household first, either that of your active household or one of their own, before proceeding with the marriage plans.

If not averse to using NRaas mods, Overwatch and ErrorTrap "should" have caught this and corrected the sim. A MasterController Reset of the sim might still help. But I would be more inclined to load a prior save from before the marriage and proceed with this one another way, even with the mods in play.
Test Subject
Original Poster
#3 Old 10th Jun 2020 at 11:14 PM
Hi igazor, thank you for your answer.

The problem strangely disappeared after I downloaded the NRaas mod Overwatch, could that be? However, I can use the sleep option for this sim now! Thank you very much for the tip.
Mad Poster
#4 Old 11th Jun 2020 at 1:32 AM
If we both had unlimited amounts of spare time, there's all kinds of tests we could do to confirm which precise issue Overwatch fixed. It's not that strange, but it could have been something as odd sounding as broken genealogy on the new household member. But the point is that your sim (and you) may now sleep at night, or whenever you choose to, so it's probably better to just go with that.
Back to top