Locked thread | Replies: 891 (Who?), Viewed: 257754 times. | Locked by: CmarNYC Reason: Tool now in Downloads - comments should go there.
Page 6 of 36
Test Subject
#126 Old 16th Sep 2014 at 8:42 PM
hello to everybody, do someone know how to make lower lod and higher lod because my game crashes and i think it is the problem..
Test Subject
#127 Old 18th Sep 2014 at 8:19 AM
Can this tool convert original S3 meshes to S4? If so, what goes in the "Original S4 GEOM" field?
Lab Assistant
#128 Old 18th Sep 2014 at 7:04 PM
Yea the new tool just works fine for me thx cmar :D

I have a silly question. I made a quick hair mesh, decimated the polycount and made the UVs. Is it possible to bring the mesh in game(its again and as always an OBJ) because its not a sim geom and I dont know how to assign the bones etc. But maybe theres a way somehow...to project the bone data from a s4 hair geom on this hair mesh? Or do I have to wait until other tools are out?


♘ visit my tumblr here
Ms. Byte
Original Poster
#129 Old 18th Sep 2014 at 9:19 PM Last edited by CmarNYC : 19th Sep 2014 at 3:02 AM.
@jh3nry and trap lorde: Bones are not the only problem, there are three major sections of data in the meshes that control morphing and skeleton adjustments (arm position in thin/fat morph, maybe other stuff). No one in the modding community, that I know of, knows how to calculate these values. This is why you can only modify an existing clothing mesh at this time.

Things that don't morph or use only a bone morph, like some accessories and probably hats and short hairs, don't need all these values. This is why TS4 Studio can let you use obj files in Blender or other meshing programs to make accessories. In a future version of CAS Tools, if I can figure out how to determine the one set of values that has to be included, I'll include an option to convert without a reference mesh for non-morphing items only.

From making a male anatomy mesh I've learned and have some ideas about how an auto-morph function to convert an original mesh in obj or TS3 geom format might work, but I need to work on it and do a lot of testing, and it may not work. Even at this time I can tell you it probably won't work well for high-poly meshes unless/until we understand better how the TS4 meshes work.

Edited for stuff I forgot about.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Field Researcher
#130 Old 18th Sep 2014 at 11:35 PM
This is what was wanting to know also - Before I start playing with the meshes, I wondered if they were morphable.
Lab Assistant
#131 Old 19th Sep 2014 at 10:46 AM
@cmar: woa okay thats rly depressing but thx for the info. But I hope your testing and your male mesh gonna work one day I trust in you, you are a genius and you'll make it :0

If anyone of you smart guys want someone/or meshes to test with Im always willing to share my meshes or to test something. Im actually not skilled enough to write my own programs/scripts whatever ughh. I hope anyone can read the skeleton or understands morphing in TS4, otherwise modding TS4 will be extremly... boring... I uploaded a zip folder with the obj and the texture to share it for testing purposes. I could also make a neck morph quickly if anyone knows how to find the general neck morph for females in the fullbuilds...(Ive seen that most hair needs a neck/breast/shoulder morph but the hair doesnt affect the breast and shoulders so maybe only one morph is needed idk) The mesh is only about 12K not that much the game should be able to handle it somehow... I made really quick uvs (see the checkerboard pic) they arent perfect but one can work with them somehow





I know orangemittens (here ) already got a new hair mesh in game (in the demo) so how has she done it? I hope so bad anyone can still get it somehow in game. Btw has orangemitten shared her clip/rig she has used?
Download - please read all instructions before downloading any files!
File Type: zip [trap lorde] test hair.zip (322.7 KB, 15 downloads) - View custom content

♘ visit my tumblr here
Test Subject
#132 Old 20th Sep 2014 at 12:46 AM Last edited by FoFuxx : 23rd Sep 2014 at 3:39 AM.
I hope that soon have a way to make new hairs for the sims 4, i'm excited to do that

I see that in TSR the people already made new objects

I tried to apply the joints just exactly the same as the original and didn't work :/




I saw that the meshes (original and my mesh) have different shaders, I don't know if this helps in something but...
Test Subject
#133 Old 20th Sep 2014 at 9:33 AM
I don't know if this is a bug, or if I'm doing something wrong, first minor thing, for whatever reason now the package files no longer include the IMG for the swatches, the one I was working on started out with them...then they were gone, and everyone I've done since they aren't in the file anymore, and then the second thing, when I make a mesh for clothing, top/outfit, there is a noticeable difference between the head and neck line, I had downloaded the tool on the 16th and i saw there was an update saying it fixed a head bone issue around the same time so I did re install it and I'm still having the same problem
Test Subject
#134 Old 20th Sep 2014 at 2:11 PM
Hey cmar! I'm not sure if you figured out an issue with the CAS crashes yet, but I, too, am experiencing CAS crashes with my cloned meshes.
I've spent the last 3 days trying to figure out what I was doing wrong, to realize it might not be me. and I've noticed somethings and I wonder if anyone else has figured this out yet?

So first, it never happened unless I had a recolor.
Once I added more swatches switching between them would cause the game to crash.
I ended up cloning my mesh and making each color a standalone, and that remedied the crashing a little.
The crashing was really intermittent though? I noticed it happened when my Sims would blink or move, there would be kind of a lagspike before the crash. omg lightbulb!!!!

edit: I just installed Shimrod's No Move CAS mod, tested my unisex glasses (switching between swatches) and it actually really really helped.
I was kind of dodging when my Sim would blink. I didn't crash at all.
Tested it again w/ No Move CAS - switched swatches when my Sim was about to blink and I crashed.
Tested it a third time w/ No Move CAS - Wasn't able to get the game to crash.

If someone wants to double check, and see if my method helped a little? I should be going to bed, so I'm not going to test it again (without Shim NMC).
Anyways. I don't even know if this information will help you find a fix, but I thought I'd let you know. Or anyone if they really want a clone to work.


Windows 7 x64 - i5 - Intel HD3000 (integrated)
My game is the Digital Standard, but I did buy the upgrade separately.
Ms. Byte
Original Poster
#135 Old 20th Sep 2014 at 3:28 PM
@FoFuxx: Right now you can't assign joints. TS4 has bones that don't exist in TS3, and the Milkshape importer/exporter removes them. The mesh probably wouldn't animate properly. I don't know if the Blender plugins will work with TS bones.

Since the TSR creators don't seem to believe in crediting the tools they use, I can only assume the items that say they have a new mesh were made with S4 CAS Mesh Tool, unless there's beta of TSRW that hasn't been released to the public.

Your mesh doesn't have ANY shader. How did you make it?

@UKTRASH: LOL, the 'bonehead' remark for that update referred to my stupid mistake I was correcting, not to the head bone.

Not all CAS items have swatch images. Many just use standard colors that don't require an image.

What did you do to modify your mesh and at what point did you get a seam or break at the neck? Please list everything you did.

@Meowchelle: Any information is useful! I got complaints that cloned items are causing crashes without being recolored or changed in any way, and it seems to happen only on Windows 8 and possibly Vista, so your issue may not be the same thing.

Does this only happen with glasses?

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Lab Assistant
#136 Old 20th Sep 2014 at 7:55 PM
I'm having the following issue:

1. Clone yfBottom_SkirtSkater with TS4 Mesh Tools.
2. Open package in S4Studio.

Result: the legs of the Sims are invisible. Same result when you copy the extracted package in the MOD folder and boot the game. Legs are invisible in CAS and in-game.

Note that the legs mesh are present in Milkshape when u open the S3 converted mesh. And they are also visible in the Geom Preview in S4PE. So I have no idea what's the issue.
Lab Assistant
#137 Old 20th Sep 2014 at 8:04 PM
Quote:
Originally Posted by CmarNYC
Since the TSR creators don't seem to believe in crediting the tools they use, I can only assume the items that say they have a new mesh were made with S4 CAS Mesh Tool, unless there's beta of TSRW that hasn't been released to the public.


Here's your answer.

It has begun - the first Sims 4 object set is here! TSR Workshop is currently being beta tested by a few of our Artists. It will be released to the public once we feel confident it can handle everything properly and we don't release something that will cause damage throughout the community. https://www.facebook.com/TheSimsRes...elevant_count=1
Test Subject
#138 Old 20th Sep 2014 at 8:48 PM
Quote:
Originally Posted by CmarNYC
@FoFuxx: Right now you can't assign joints. TS4 has bones that don't exist in TS3, and the Milkshape importer/exporter removes them. The mesh probably wouldn't animate properly. I don't know if the Blender plugins will work with TS bones.

Since the TSR creators don't seem to believe in crediting the tools they use, I can only assume the items that say they have a new mesh were made with S4 CAS Mesh Tool, unless there's beta of TSRW that hasn't been released to the public.

Your mesh doesn't have ANY shader. How did you make it?


Oh I see

I made in Maya, then exported to milkshape with joints and in geom format
Then I don't know why it doesn't have Shaders
Test Subject
#139 Old 20th Sep 2014 at 11:46 PM
Quote:
Originally Posted by CmarNYC
@Meowchelle: Any information is useful! I got complaints that cloned items are causing crashes without being recolored or changed in any way, and it seems to happen only on Windows 8 and possibly Vista, so your issue may not be the same thing.

Does this only happen with glasses?


I ended up cloning EA's mesh again (same mesh I used for my glasses), this time I didn't edit it at all and it indeed crashed CAS when I put it on my Sim.
I tested LumiaLover's hat (a lot of people are having issues with it crashing their game) and it crashed my game as well. He notes in that post that if you take individual .packages instead of the combined colors it might help.
I guess I should mention that my .package is smaller than the unedited clone because I removed the GEOMs for the lenses. It's really confusing because sometimes it happens and sometimes it doesn't. You almost have to give the game some breathing room for it to load when you're about to switch to a new swatch or thumbnail. Hovering over the swatches and waiting for the thumbnail to load a preview kind of helps. Maybe the size of the files are messing with something? If you can get past CAS it's completely usable in game.

Anyway, I probably sound like I'm all over the place so I'll just upload my .packages and maybe that'll be helpful? If there's anything I can do, just let me know.
The glasses will be found here. They're unisex. Having both mine & the EA clone installed at the same time seems to cause more crashes.


What I'm def. experiencing is this[link]:
Download - please read all instructions before downloading any files!
File Type: rar mishlish_glasses920.rar (180.8 KB, 5 downloads) - View custom content
Ms. Byte
Original Poster
#140 Old 21st Sep 2014 at 2:35 AM
Quote:
Originally Posted by FoFuxx
Oh I see

I made in Maya, then exported to milkshape with joints and in geom format
Then I don't know why it doesn't have Shaders


If you didn't copy comments from another mesh in Milkshape, it won't have a shader. Shaders are included in GEOMs, but not present in meshes in other formats, so if you convert but don't get the shader data from somewhere it won't be there.

@meowchelle: I'll take a look and see if I find anything. Meanwhile I'm exploring some possibilities for why this crashing keeps happening. When I add more test packages to my thread in CAS Parts I hope you'll try them.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#141 Old 21st Sep 2014 at 2:38 AM
I never got a break in the neck, its more of a ...light difference? this http://i.imgur.com/enjJc7h.png

so list everything I did, opened the tool, picked the shirt and color i wanted to clone, then extracted the mesh to s4, then converted it to s3, opened in milkshape, edited it [made it shorter, i didnt edit anything on the top half] then saved and converted back to s4, and imported it into the original package file and replaced the old mesh, and thats pretty much it.. also whether this is relevant or not a few people seem to be having it crash in their game, works fine for me though so I don't even know where to begin to find out why it isn't working, any quick thoughts on that?
Ms. Byte
Original Poster
#142 Old 21st Sep 2014 at 2:43 AM
Quote:
Originally Posted by UKTRASH
I never got a break in the neck, its more of a ...light difference? this http://i.imgur.com/enjJc7h.png

so list everything I did, opened the tool, picked the shirt and color i wanted to clone, then extracted the mesh to s4, then converted it to s3, opened in milkshape, edited it [made it shorter, i didnt edit anything on the top half] then saved and converted back to s4, and imported it into the original package file and replaced the old mesh, and thats pretty much it.. also whether this is relevant or not a few people seem to be having it crash in their game, works fine for me though so I don't even know where to begin to find out why it isn't working, any quick thoughts on that?


Do you have Auto-smooth checked in the Groups tab? If so, your normals are being smoothed and that would cause the visible line at the neck and other mesh seams. Make sure it's unchecked. That pic really looks like that's the problem.

So far no one knows why some cloned packages cause crashing on some computers, but I'm trying to figure it out!

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#143 Old 21st Sep 2014 at 3:45 AM
Hi there, first I just want to say thanks for working on this tool. It's pretty awesome.
Second, I've run into a bit of an issue.
I'm trying to edit a hair mesh, so I opened the game's files up in the tool and exported them as a TS3 mesh. I then edited the meshes in blender (I removed some vertices) and used the FrankenMesh to convert them to a TS4 mesh. When I tried to import the mesh back into the package, I got the error stating that the source number of vertices does not equal the target number of vertices. So I went through this forum and found that meyomey had luck by re-frankenmeshing the new mesh with the original TS4 mesh again, so I tried that, but still got the same error. I also tried just flat out importing the edited TS3 mesh, no luck. Not sure what I'm messing up here, sorry!
Ms. Byte
Original Poster
#144 Old 21st Sep 2014 at 4:24 AM
Are you sure you didn't try to import the TS3 mesh into the package? If you import a TS4 mesh it shouldn't check the number of vertices. I'll double-check in the morning, and meanwhile you can always use s4pe - right-click the mesh, click Replace, and select your modified TS4 mesh.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#145 Old 21st Sep 2014 at 5:55 AM
That was a quick reply! And I'm 100% certain that it was not a TS3 mesh I was importing, I even tried again just to be double sure. I did it via s4pe and got the meshes into the package file at least, so thanks for letting me know about that! Now however, the hair appears in my game but once I try to even move my mouse over it (not kidding) the game crashes. I'm convinced this is probably an issue on my end, though, and not your tool. I am relatively new to this.
Test Subject
#146 Old 21st Sep 2014 at 6:40 AM
auto smooth was in fact, checked in the groups tab lol, made an almost identical mesh and no line, thank you so much! ugh it was this easy the whole time lol
Instructor
#147 Old 21st Sep 2014 at 1:47 PM
Since the latest update, CAS Tools won't make it through Norton. Any advice? Even if I turn off Norton, I double click the .exe and then click run - nothing. I've also tried running as an administrator - still nothing. At a loss here as I had planned a whole day of meshing/playing.

Thanks,
JD
Test Subject
#148 Old 21st Sep 2014 at 5:16 PM
Quote:
Originally Posted by JosephTheSim2k5
Since the latest update, CAS Tools won't make it through Norton. Any advice? Even if I turn off Norton, I double click the .exe and then click run - nothing. I've also tried running as an administrator - still nothing. At a loss here as I had planned a whole day of meshing/playing.

Thanks,
JD


JD, have you thought about switching virus protection software. I don't know about anyone else, but Norton has never been that great to me anyways. Just a thought. Also, doesn't Norton have a way to exclude certain folders and files from its scanning? Most virus protection software does, have you tried that?
Test Subject
#149 Old 22nd Sep 2014 at 3:26 AM
Quote:
Originally Posted by CmarNYC
If you didn't copy comments from another mesh in Milkshape, it won't have a shader. Shaders are included in GEOMs, but not present in meshes in other formats, so if you convert but don't get the shader data from somewhere it won't be there.


Thank you for the information!
Test Subject
#150 Old 22nd Sep 2014 at 6:00 PM


TADAA! OMG I DID IT.
It's the NEW MESH

I wanna thank YOU CmarNYC for all the information and help and your tool that helped me do this!
Instructor
DELETED POST
22nd Sep 2014 at 9:09 PM
This message has been deleted by Sadisticpyro.
Locked thread | Locked by: CmarNYC Reason: Tool now in Downloads - comments should go there.
Page 6 of 36
Back to top