Replies: 67 (Who?), Viewed: 40143 times.
Page 3 of 3
Alchemist
#51 Old 22nd Nov 2009 at 12:35 PM
Cache files are in Documents/Electronic Arts/The Sims 3 folder.

I always delete all 4 of the packages with the word cache in them although it may be that this is overkill. The ones I delete are:

CASPartCache.package
compositorCache.package
scriptCache.package
simCompositorCache.package

Sometimes if you make changes to an object and put it into the game without deleting the caches the changes you made will not show up. If you're making something new it's always a good idea to delete these before checking your object in the game just to be sure you're actually seeing the effect of whatever alterations you made to the object.

I'm glad your object worked out.

OM
Field Researcher
#52 Old 1st Dec 2009 at 12:55 AM
I have a problem which i've bumped into twice now the first time i was able to resolve it by repackaging but i have a funny feeling its not the root cause and its just gonna wear me out completly repacking over and over O.o, so anyway here:

Now i've recently made a set MIA Living Set and i had this problem with the two seater but repackaged it and it some how reolved the issue, now the pillow has its own recolour patch on CAS and so the body and the legs but for some reason... when you change the colour or pattern on the legs you get a transparent projection on the pillow aswell... i really dont know whats causing this i've worked with other meshes fine but random things keep cropping up everytime i make new packages -.- its slowly annoying me.
Now this projection was... showing on the body of the chair but after repackaging it switched to the pillow, its not 100% noticable if you just use plain colours but it will hue the pillow some what.. and its just not finished then is it.... so plz if anyone has an idea as to why this is happening i would appreciate it, i'm guessign its probs in the DDS files but i very much doubt it.. but hey i'm really open for answers ty x
Alchemist
#53 Old 1st Dec 2009 at 1:02 AM
Trust me...I know exactly how you feel when you say, "i've worked with other meshes fine but random things keep cropping up everytime i make new packages,"...every single object has it's own ins and outs this is for sure.

Do you want someone to just give the thingy a second look for you?
Field Researcher
DELETED POST
1st Dec 2009 at 1:05 AM Last edited by melanise : 2nd Dec 2009 at 9:17 AM.
This message has been deleted by melanise.
Alchemist
#54 Old 1st Dec 2009 at 1:15 AM Last edited by orangemittens : 1st Dec 2009 at 1:48 AM.
What did you clone this from...is this the elusive chair with two groups that some people have been looking for?

Edited to add: I'm not sure your groups are how you want them. The map looks right but there are two shadow groups and only one chair group...could this be the issue? Check your groups out in MS and see what I mean. I was looking at the MLOD. Is this how the original object was grouped? With Group 00 the entire chair, Group01 a shadow (full square), and Group 2 another shadow made up of the four patches where the legs go?

But the MODL has only one group...that's strange. Usually when an object has three groups in the MLOD there are 2 in the MODL.

I'll admit, I haven't really worked much with chairs and maybe this grouping is normal for them...but it's not what I would have expected from looking at the set-up of other kinds of meshes.
Field Researcher
#55 Old 1st Dec 2009 at 9:18 AM
Quote:
Originally Posted by orangemittens
What did you clone this from...is this the elusive chair with two groups that some people have been looking for?

Edited to add: I'm not sure your groups are how you want them. The map looks right but there are two shadow groups and only one chair group...could this be the issue? Check your groups out in MS and see what I mean. I was looking at the MLOD. Is this how the original object was grouped? With Group 00 the entire chair, Group01 a shadow (full square), and Group 2 another shadow made up of the four patches where the legs go?

But the MODL has only one group...that's strange. Usually when an object has three groups in the MLOD there are 2 in the MODL.

I'll admit, I haven't really worked much with chairs and maybe this grouping is normal for them...but it's not what I would have expected from looking at the set-up of other kinds of meshes.


Its exactly how it came i never touch the shadows i only ever re-size my object to comfortably fit just about right where the other chair did then i assign my chair and delete the old one, as of now its the only sofa i know which ahs the extra shadow under the feet but i've cloned this chair before with no problems so the shadows isnt the issue. When you say MLOD you mean the 2 shadow and 1 low detail files ? because those are the 3 which come with this sofa and most other objects. those 3 files only have 1 group "group00" as from what i've seen eeverytime i export them into MS, and the MODL file has the 3.
Alchemist
#56 Old 1st Dec 2009 at 11:30 AM
Well, if this is how the groups always are then that must not be the issue with your chair now. I was just wondering about it because it looked strange compared with most objects I've seen.

The MLODs usually come in threes, one has the group and the indoor shadow, and the other two are lower poly (and much larger) versions that have to do with the sunshadow. Your chair here is no different...you can look at the group arrangement by using the MLOD/MODL Info button in the ObjTool. Here are pics of your first MLOD and MODL:





This arrangement for MLOD and MODL is pretty typical from what I've seen and read. What is less so, at least to me, is how the MLOD has three groups and 2 of them are shadows.

Anyway, since that isn't the issue I'll look again although the problem you're describing isn't one I've run into before so I've got no clue as to what the root cause of it could be. Hopefully someone else happens along in the meantime who has some better idea.
Alchemist
#57 Old 1st Dec 2009 at 8:35 PM
Quote:
Originally Posted by melanise
now the pillow has its own recolour patch on CAS and so the body and the legs but for some reason... when you change the colour or pattern on the legs you get a transparent projection on the pillow aswell.


Is the patch on the colored map a pure color? Blended mapping colors will have blended recoloring on them.

If you like to say what you think, be sure you know which to do first.
Field Researcher
#58 Old 1st Dec 2009 at 11:28 PM
Quote:
Originally Posted by WesHowe
Is the patch on the colored map a pure color? Blended mapping colors will have blended recoloring on them.


On the coloured map? i dont understand... where do you mean on the DDS file ?? if so then the Chair it self is red the legs are blue and the cushion is green. The pillow is meant to be plain white its a shame i should have printscreened so you can see my CAS, but ya the pillow is pure white and when ever i darken lighten or patternt he legs i get the transparency on the pillow..
Alchemist
#59 Old 1st Dec 2009 at 11:45 PM
Well, I am thinking this is an issue with the color DDS map that defines the CAS zone, not anything to do with the grouping. I do remember that making a zone on the color map something that isn't a pure color, for instance 0, 255, 80 for green instead of 0, 255, 0 will mix the green zone texture with about 1/3 of the blue zone texture.

So I think something like that is happening, and you guys are looking for the solution in the wrong place. I could be wrong (I am far too often), as I didn't test this myself, but that is where I would look next to resolve it.

If you like to say what you think, be sure you know which to do first.
Alchemist
#60 Old 2nd Dec 2009 at 12:44 AM Last edited by orangemittens : 2nd Dec 2009 at 1:43 AM.
No, that seems to be right. The green on Melanise's R/G/B is 0/255/49 instead of 0/255/0.

So Melanise, look at the IMG that is red/green/blue and fix the green so that it is pure.

Edited to remove unnecessary reiteration of post above.
Field Researcher
#61 Old 2nd Dec 2009 at 9:16 AM
Ok fantastic that could be my problem because the blue i just maxed the colour to the top corner instead of copying the original or using those settings i will do this ty so much OM and Wesh xx always the simplest of things which makes a load of mess lol
Alchemist
#62 Old 2nd Dec 2009 at 2:43 PM
Quote:
Originally Posted by melanise
always the simplest of things which makes a load of mess


So true... after all the polygons and UVs and everything were just right, just a wee difference in one color made a problem.

If you like to say what you think, be sure you know which to do first.
Test Subject
#63 Old 10th Dec 2009 at 9:56 AM Last edited by Phantagora : 10th Dec 2009 at 1:30 PM.
My table is ready for the UVMapper but when I open the object in it, it doesn't look as in the tutorial.

Will it affect anything as I continue? What did I do wrong? Can I remove it?



Thanks for a great tutorial.

/Phanta

Edit: I did everything in Milkshape again, and this time it worked. I am still interested in what went wrong the first time though. The two tables look the same in Milkshape.
Test Subject
#64 Old 29th Dec 2009 at 6:47 PM
Melanise: I had this same problem and I realized that I still had another version of my object left in a home!
Theorist
#65 Old 8th Jan 2010 at 3:14 AM
Flabaliki, I just watched your video tutorial and I think you make it look entirely too easy, but at the same time that's a very encouraging thing. Thanks so much!
Test Subject
#66 Old 8th Jan 2010 at 11:19 PM
Does this work for clothing meshes?? :S
Test Subject
#67 Old 29th Jul 2010 at 12:09 AM
I know that this tutorial has been called "outdated" due to the new tutorial by EllaCharm3d, however, I tried her tutorial and it is almost as if we should know how to do it already. I like your tutorial, because you explain things in a way that is a lot easier for me to understand. I just have one problem... The very first step. It says in s3oc, to click file > new (clone). That is not an option. When I click file, I get 2 choices: open package and exit.

In EllaCharm3d's tutorial, she says to click cloning > normal objects. Will this get me the same result that I need to follow your tutorial?

And BTW, please do not give up on us. A lot of people would prefer your way of explaining things, because EllaCharm3d seems to expect us to read her mind half the time. You at least understand that we are not all as experienced as others may be.
Alchemist
#68 Old 29th Jul 2010 at 1:12 AM
I'm not noticing that this tutorial has been labeled "outdated" although you've certainly run into a part that needs updating

The S3OC has undergone some changes since this tutorial was written and to do step 1 you should follow the directions in the Ella tutorial...that is, click cloning and then pick normal objects unless you want to clone a counter or fence or some other modular object.
Test Subject
DELETED POST
29th Jul 2010 at 5:21 AM
This message has been deleted by Emily_Rugburn. Reason: got it
Test Subject
DELETED POST
17th Jul 2014 at 3:42 PM
This message has been deleted by GoAgain.
Page 3 of 3
Back to top