Locked thread | Replies: 1347 (Who?), Viewed: 417739 times. | Locked by: tiggerypum Reason: Outdated, replacement tutorial posted
Page 2 of 54
Nearly alive
#26 Old 6th Feb 2005 at 2:56 PM
The most likely cause for this, is that you are using blender, and blender (well for me anyway) renames the meshes (it`s likely to have renamed it to something like "g_body g_body", so the mesh in the obj file you create with blender will not be the same as the original (what should be "body"), as I`ve said a number of times now, that when the mesh tool is importing a modified mesh , that it will look at the names in the obj file and try to match them up with the parts in the gmdc. If the names of the meshes in the obj file don`t match the names in the gmdc file, then the new meshes will not be imported. (there is no other way for it to know what parts go to what)

You can either rename the mesh(es) back to their original in blender (not sure how you do that) or you can open the obj file up in notepad and edit the names in there. (look for the lines starting with g or o )
Guest
#27 Old 6th Feb 2005 at 3:11 PM Last edited by NancyJames : 6th Feb 2005 at 3:54 PM.
I get the mesh to change but its seriously messed up som of the vertices are in th eright place but most are just all over. I triecd importing the maya obj into milkshape and reexporting, even checking the naming in wordpad and now the model doesnt change at all
Lab Assistant
#28 Old 6th Feb 2005 at 3:17 PM
What do you mean in step 25: "Delete the shape and resorce node from the package"?
Do you mean from the plugins view window or the packed files window?
Test Subject
#29 Old 6th Feb 2005 at 3:48 PM
Whoa... Thanks for replying, Miche! Now a different model shows up in Body Shop. It just... looks a bit strange. The polygons are ALL OVER the place! I guess Blender saves the obj's in a format that, to the Mesh Tool, LOOKS like it's valid, when it really isn't.

Taking a closer look at the obj exported from SimPE and the one exported from Blender, the only differences I can see (except for Blender changing the names) are that Blender saves the coordinates with a higher precision and that SimPE adds a number after every set of coord's (which should be completely unneccesary as they are just enumerated 1 to [number of vertices] in the order that they are saved in the file).

I'm going to try and write a simple program to fix these things in the Blender obj's, and hope it will work.
Lab Assistant
#30 Old 6th Feb 2005 at 4:01 PM Last edited by MimeWhite : 9th Feb 2005 at 11:21 AM.
Thank for the tutorial!

, I didn't really follow the way you did but' it help me understand more of what I should do,now I complete my new hair mesh(well alter mesh I mean) and it seems to work ok in game as well,

I got a bit more question tho
the GMND picture on the right i, is it possible to change the name "hair_alpha3 [cDataListextention]" to other name such as "hairalpha3" ?
(a completely different name) I can't find a way to change it,


*Edit* ok..I figure it out all of those things except the animation part..........


will the moder looking into Maya plugin?, I couldn't use it to export my object(it will get those explode mesh)
Screenshots
Lab Assistant
#31 Old 6th Feb 2005 at 4:18 PM
Thank you so much! This is the help I've been waiting for. Now, hopefully, I can do a bit of remapping of the existing meshes so transparencies and alphas will work for all meshes and not just a few of them. Will be playing with this a bit tomorrow! Thank you thank you thank you!

(And thanks, of course, to all the folks who made the tools that will make this possible).

X.
Nearly alive
#32 Old 6th Feb 2005 at 4:26 PM
Quote:
Originally Posted by Vinther
Whoa... Thanks for replying, Miche! Now a different model shows up in Body Shop. It just... looks a bit strange. The polygons are ALL OVER the place! I guess Blender saves the obj's in a format that, to the Mesh Tool, LOOKS like it's valid, when it really isn't.

Taking a closer look at the obj exported from SimPE and the one exported from Blender, the only differences I can see (except for Blender changing the names) are that Blender saves the coordinates with a higher precision and that SimPE adds a number after every set of coord's (which should be completely unneccesary as they are just enumerated 1 to [number of vertices] in the order that they are saved in the file).

I'm going to try and write a simple program to fix these things in the Blender obj's, and hope it will work.



did you make sure you only had the import vertices option selected in the options screen in the mesh tool, sounds like you are importing the faces too.
Test Subject
#33 Old 6th Feb 2005 at 4:53 PM
I was actually doing it with all options checked except the "overwrite names", like the tutorial said. Now I tried just checking "import vertices" but I got the same result.
It looks like the model has frozen in an explosion or something, the polygons are scattered around the center, rotated and sized WAY off of where they should be.
Nearly alive
#34 Old 6th Feb 2005 at 5:57 PM
Quote:
Originally Posted by Vinther
I was actually doing it with all options checked except the "overwrite names", like the tutorial said. Now I tried just checking "import vertices" but I got the same result.
It looks like the model has frozen in an explosion or something, the polygons are scattered around the center, rotated and sized WAY off of where they should be.



I`ve just seen where it say that in the tutorial, and while I`d say each person should try changing which options are checked to see what ones best works for them and their mesh, I`d advise if at all possible not to import the faces/polygons, as I can think of a number of ways this could mess up the animations. (but if it does work for you by importing the polygons/faces, then that`s ok)
Lab Assistant
#35 Old 6th Feb 2005 at 5:57 PM
Ok, i got mine done, yay! There are some minor places where i can see the skin, but that's caused to me movie the vertises too far...

But what do we do about the hard edges? Are we allowed to create vertises? Lemme just try...
Guest
#36 Old 6th Feb 2005 at 6:10 PM
I followed the tutorial and made sure to only import faces and this is what I get :s
Screenshots
Lab Assistant
#37 Old 6th Feb 2005 at 6:16 PM
Ok, smoothing it is a nono, due to it exploding...(i use Rhino)
Nearly alive
#38 Old 6th Feb 2005 at 6:17 PM Last edited by Miche : 6th Feb 2005 at 6:24 PM.
Quote:
Originally Posted by NancyJames
I followed the tutorial and made sure to only import faces and this is what I get :s


To only import faces ?

if that wasn`t a mistake and you didn`t mean that you didn`t import faces, then see my post above.

As we have said before, the amount of changes you can make is limited (we are wroking on allowing completely new meshes to be imported and used as bodies) so if the changes you make don`t work and cause the mesh to explode or look wrong, and if changing the options don`t make any difference , then there is a good chance that you have tried to make too many changes.

For one a vertice, once it has been moved, HAS to be close to it`s original position, as they are attached to the bones, which is used for animation, so you can`t for instance move a vertice from the top of a leg to the bottom and expect it to work without problems. as the game would still consider it attached to the top of the leg and move it as though it was.
Lab Assistant
#39 Old 6th Feb 2005 at 6:55 PM
Ok, i'm gonna try it in Milkshape...it's not SimPE, it's Rhino, for some reason when using point editing on it it instantly goes to 'showing all splits'.....it doesn't do that in milkshape so far, so fingers crossed...
Guest
#40 Old 6th Feb 2005 at 7:02 PM
I meant vertices not faces.

Sorted it now, I model in maya, then export the obj, import to milkshape, reexport then do a little editing in notepad but all is working now and I have my busty dominatrix with sexy thigh boots :D
Lab Assistant
#41 Old 6th Feb 2005 at 7:47 PM
Ok, i edited in in Milkshape this time (from scratch), and there are no ugly straight edges! Also, the design is better now that i got to do it again....i guess milkshape will be staying on my computer after all! ^_^

Now, we just need a program which can take these final meshes, group them to parts of the sim 2 skeletons, allowing the use of more vertises (and maybe give the skeleton new bones like the hair, and allow an option to change animations for that cloth/hair)...any chance of that happening soon?
Lab Assistant
#42 Old 6th Feb 2005 at 8:18 PM Last edited by Saikatsu : 6th Feb 2005 at 9:15 PM.
I told it not to import normals and it looks a bit better... the texture at least shows up. But it looks just like the screwy polygon explosion someone posted a screenshot for above.
Guess I'll try again and tell it not to import polygons either. If that still doesn't work, I'll try using only MilkShape, leaving 3DS out of it. Which is too bad... I hate MilkShape's interface and how to tools work >.<

EDIT: Still screwed over. *sigh* Guess I'll be trying without using 3DS...

EDIT 2: Yup... works just fine with MilkShape. I don't get how that works, since I can use 3DS for objects just fine :\
Lab Assistant
#43 Old 6th Feb 2005 at 9:18 PM Last edited by Brasstex : 7th Feb 2005 at 12:04 AM.
Thanks for the tutorial WDS BriAnna! Your method works great, but I wonder if it will be possible in the future to make the mesh_ package part of the original file for distribution -- For that matter, I still wonder how telamon put together the minidress package. Oh well, great tutorial though.

Brasstex

Ps, here's some pictures of a very rudimentary wing skin I did.

Edit: BTW, I use max v.6 and it works fine for me. To convert files I use 3dWin5.
Screenshots
Lab Assistant
#44 Old 6th Feb 2005 at 9:24 PM
Success, my jumper based on Raine Loir from FF8 is complete! Check out Skinning forum for screenshot! ^_^ THANK YOU!

http://forums.modthesims2.com/showthread.php?t=43293
Test Subject
#45 Old 6th Feb 2005 at 9:29 PM
Let me thank you, brianna, for this very good tutorial...
i've tested it out with my new charleston-skirt-mesh,
and it works fine...
it's a good method to put new meshes into the game...
telamon was going another way, i think... or not?
Screenshots

this is my HP - cu there?
Guest
#46 Old 6th Feb 2005 at 10:25 PM
This is my first new mesh
Screenshots
Nearly alive
#47 Old 7th Feb 2005 at 12:33 AM
Quote:
Originally Posted by Bishounen_Taurus
Ok, i edited in in Milkshape this time (from scratch), and there are no ugly straight edges! Also, the design is better now that i got to do it again....i guess milkshape will be staying on my computer after all! ^_^

Now, we just need a program which can take these final meshes, group them to parts of the sim 2 skeletons, allowing the use of more vertises (and maybe give the skeleton new bones like the hair, and allow an option to change animations for that cloth/hair)...any chance of that happening soon?



I have a version which does that , but am still having problems with it , so I can`t say when it will be ready. Where the parts of the body mesh is deformed (like when a sim is pregnant or the fat and thin changes) causes a lot of problems.
Lab Assistant
#48 Old 7th Feb 2005 at 11:02 AM Last edited by poi_boi : 7th Feb 2005 at 11:11 AM. Reason: I can't spell real good ;P
I got to step 20 and there was no package button. I have SimPE v 0.15.1862.1623 and the obj extractor plugin listed in the tutoral.
Is there another plugin I could be missing?

(20. Go to the 3D ID Referencing File (3IDR). In the plugin view tab, you will see a button that says package. Click it. A window will pop up.)
Nearly alive
#49 Old 7th Feb 2005 at 11:42 AM
Quote:
Originally Posted by poi_boi
I got to step 20 and there was no package button. I have SimPE v 0.15.1862.1623 and the obj extractor plugin listed in the tutoral.
Is there another plugin I could be missing?

(20. Go to the 3D ID Referencing File (3IDR). In the plugin view tab, you will see a button that says package. Click it. A window will pop up.)



no it shouldn`t require any new plug-in

here` a picture so you know where to look for it:
Screenshots
Lab Assistant
#50 Old 7th Feb 2005 at 11:56 AM Last edited by poi_boi : 7th Feb 2005 at 12:17 PM. Reason: added question.
I must have done something wrong with upgrading SimPE as my pugin view looks quite different. I'll see if can figure out what I missed.

Edit - I tried extracting the rar again over the top of the old install and it changed nothing. Could it have something to do with the order of the plugins like the moving of the GMDC wrapper in the start of the tutorial?
Screenshots
Locked thread | Locked by: tiggerypum Reason: Outdated, replacement tutorial posted
Page 2 of 54
Back to top