Locked thread | Replies: 1347 (Who?), Viewed: 417727 times. | Locked by: tiggerypum Reason: Outdated, replacement tutorial posted
Page 6 of 54
Guest
#126 Old 14th Feb 2005 at 3:19 PM
The before and After pictures look the same to me
Lab Assistant
#127 Old 14th Feb 2005 at 3:34 PM
Gotcha Miche - thanks!

After checking, it seems that Poser (which is what i was using because of the MAGNET Presets) doesn't export the names the way I'd expected it to.

Good to know that this is the problem and I'm sorry for the headache it presented you to look at this and give me an answer that had already been given - I though I had checked that, but deeper looking just now showed that I did check - just not properly! Sorry.

X.
Nearly alive
#128 Old 14th Feb 2005 at 4:00 PM
Quote:
Originally Posted by Xenos
Gotcha Miche - thanks!

After checking, it seems that Poser (which is what i was using because of the MAGNET Presets) doesn't export the names the way I'd expected it to.

Good to know that this is the problem and I'm sorry for the headache it presented you to look at this and give me an answer that had already been given - I though I had checked that, but deeper looking just now showed that I did check - just not properly! Sorry.

X.


No problem.

So if poser won`t export a name, then I would suggest opening the file in note pad and changing the g lines in there.
Field Researcher
#129 Old 14th Feb 2005 at 4:17 PM
Quote:
Originally Posted by Miche
Xenos,

The problem is one what a number of other people have and I`ve repeatedly pointed out.

There is no name for the mesh/group in your edited obj file.
When a object is being treated as a modified mesh, the name of the object(s) in the obj file must match those in the gmdc file, this is the only way the mesh tool can match up the parts , so it knows what belongs to what.
So for a body mesh the name in the obj file must be "body" so it matches the name in the gmdc file.

The format in a obj file for giving a name to a mesh/group is : g [somename]
So this for a body mesh should be : g body

Your obj file has no name at all , just blank g lines (your file also has two g lines, where only one really is needed, but this shouldn`t of been a problem if it at least had the name "body")


The reason your object is displayed in the 3d view and works when you use the wizard feature is because they don`t take notice of the name, as they aren`t trying to match things up with existing objects.

So to solve your problem you need to name your mesh to "body". either in the 3d program you are using, or you could open up your obj file in notepad and search for lines starting with "g" (you should in your file find two next to each other, delete one of them and add "body" to the other).


Thank you so much! I was having the same problem... my 3d program named the mesh to g bottom_default... so I had to go into notepad and change it. But it is working now and I am so happy! Thanks for all of your help!! :bump:

~faeriegurl~
Sims 2 Creations - http://www.sims2creations.com

faerie's blog - http://spaces.msn.com/members/enchantedrealm/
Lab Assistant
#130 Old 14th Feb 2005 at 4:18 PM
Bri this is just a thank you for the Tutorial I've made two completely new bodies for the sims 2. I haven't tried multi obj imports --yet LOL.
Field Researcher
#131 Old 14th Feb 2005 at 4:54 PM Last edited by faeriegurl : 14th Feb 2005 at 5:33 PM. Reason: new zip file
Any ideas on why this is happening? :confused:



I have tried checking and unchecking all of the boxes in the mesh tool and this is the best I end up with... I attached my all my files also. Thanks so much for all of your help so far!
Download - please read all instructions before downloading any files!
File Type: zip mini.zip (409.6 KB, 40 downloads) - View custom content

~faeriegurl~
Sims 2 Creations - http://www.sims2creations.com

faerie's blog - http://spaces.msn.com/members/enchantedrealm/
Lab Assistant
#132 Old 14th Feb 2005 at 5:55 PM
Thanks to everyone (especially Miche who got me headed in the right direction)! Everything works now! WOOT!

Fariegurl - are you using Poser too? Or something else? I had the same problem. I found that when I imported the model that if I checked "Weld Identical Vertices" and "Make Normals Consistent" (but unchecked everything else) that it got rid of the problem. Everything worked perfectly. And, if you're not using Poser, then see if your program has one or both of those options and give that a try. (I noticed that you could also see that line on the shadowy side of the figure in the SimPE 3D preview, so you don't need to load up body shop each and every time to see if it's fixed - you can pretty easily tell directly in SimPE).

And now, I'm off to post a little tutorial on using Poser and DAZ Studio to edit meshes since I heard other people talking about it quite a bit before all these great tools were released.

Thanks again, all!

X.
Field Researcher
#133 Old 15th Feb 2005 at 5:25 PM
X - Thanks for trying to help, but Wings3D doesn't bring up an options box when importing or exporting and I don't think I have those options.

I posted this somewhere else too, but I haven't gotten a lot of responses to my questions (I know everyone here is very busy working for us - thank you ), so I am posting it here too, so maybe I can get an answer from this thread.:

Hi. I hope someone here can help me... I have been having so much trouble making new meshes. :weep:

I am using Wings3D to edit my meshes because it is free and it is the only one that is easy enough for me to use since I am new to the 3D modelling thing. I also downloaded Milkshape and have been trying to use it for exporting with Wes's plugins but I can't use it for the editing because it is too hard for me to use.

Anyway... my problem is that when I make a mesh and test it in Bodyshop, I come up with something like this:



I have tried deselecting everything in the mesh tool except for import vertices but it looks even worse when I try that.

This is what my mesh looks like in Wings3D:



When I preview it in SimPE, it looks fine, see?



Anyway, this is just driving me slowly into insanity and I would SO appreciate it, if someone of you brilliant people here can take a look at my zip file I am posting and just give me some insight on what is wrong with my files. I REALLY REALLY need some help! I saw something about welding vertices causing this problem, but I didn't choose any options for that, and I don't know how to do a lot since I am so new to this.

I should probably just give up, but I have so many ideas for meshes and I want to make them so badly that I can't bring myself to give up yet.

I'm begging... PLEASE HELP ME!!! :bangs head:
Download - please read all instructions before downloading any files!
File Type: zip shirt.zip (764.4 KB, 44 downloads) - View custom content

~faeriegurl~
Sims 2 Creations - http://www.sims2creations.com

faerie's blog - http://spaces.msn.com/members/enchantedrealm/
Lab Assistant
#134 Old 15th Feb 2005 at 6:15 PM
faerirgirl- i am not a genious you seek but i have had similar problems...
i was welding the mesh
you can't do that apparently
not smoothing either...nothing
just try moving the vetices around and don't do anyting fancy to see if this is your problem
and if you're not doing what i mention then i don't know
Lab Assistant
#135 Old 16th Feb 2005 at 12:16 PM
I followed every steps of this tutorial. I didn't add or delete any vertices. I just edited the mesh with Blender and then save the texture map and mesh with UV Mapper Classic before importing the mesh to the mesh file.
The picture shows the result in bodyshop.
What 's the matter?
Screenshots
Lab Assistant
#136 Old 16th Feb 2005 at 12:22 PM
Mabelline - I haven't used blender, but with a few other programs, this has been the problem. Try this:

When you export your OBJ from SimPE, don't give it the default name, but name it "body.obj". Import that into Blender. If at any point during the import and export from blender it asks you to use "names", make sure that "yes" is checked off.

X.
Lab Assistant
#137 Old 16th Feb 2005 at 1:46 PM
Quote:
Originally Posted by Xenos
Mabelline - I haven't used blender, but with a few other programs, this has been the problem. Try this:

When you export your OBJ from SimPE, don't give it the default name, but name it "body.obj". Import that into Blender. If at any point during the import and export from blender it asks you to use "names", make sure that "yes" is checked off.

X.

Yes
I tried this but it doesn't help.
When I clicked 'preview',it said 'could not initialize Direct 3D'.
What does that mean?
Screenshots
Lab Assistant
#138 Old 16th Feb 2005 at 1:49 PM
Go to the SimPE site and in one of the three "bugfixes" announcements, it talks about the direct3D error. Download the new version and when you do it the next time, rather than giving you that error, it'll automatically patch itself so it works. Pretty cool, actually.

Basicially, you've got an old version of SimPE that had some bugs in it.

X.
Lab Assistant
#139 Old 16th Feb 2005 at 2:43 PM
Yeah!The preview is fixed.My mesh looks fine in the preview but it is still transparent in Bodyshop and the game. Should I try Milkshape?
Screenshots
Field Researcher
#140 Old 16th Feb 2005 at 3:17 PM Last edited by faeriegurl : 16th Feb 2005 at 3:25 PM.
Quote:
Originally Posted by Mabelline
Yeah!The preview is fixed.My mesh looks fine in the preview but it is still transparent in Bodyshop and the game. Should I try Milkshape?


This is probably what is causing it -

Before you export your mesh with the mesh tool, open up your .obj file in notepad and scroll down to the line that starts with g. This line needs to say something like g body, g bottom, g top depending on what you are making. Whatever it says there change it to g body for a whole outfit, g bottom for a bottom, g top for a top, etc.

The name on this line of your obj file has to be the same as the original sims 2 mesh file in order for the game to find the new mesh and display it.

Hopefully that will help. If that is not the problem then I'm not sure.

~faeriegurl~
Sims 2 Creations - http://www.sims2creations.com

faerie's blog - http://spaces.msn.com/members/enchantedrealm/
Lab Assistant
#141 Old 16th Feb 2005 at 6:29 PM
I changed it to g body too but Bodyshop and the game have to stop running immediately after I choose the dress with my mesh.
Also, I tried to use Blender, Milkshape and Maya(free version) to generate wavefront OBJ files for import to the mesh file. The results are the same.
I spent about 2 hours to learn the basics of Blender and 1 hour to edit the mesh (not to mention the hours I spent for searching tutorials and threads that are useful)but I still cannot bear fruit. How disappointing it is!
Field Researcher
#142 Old 16th Feb 2005 at 7:39 PM
Mesh Tool version 0.9.44

This is a new version of the MTS2 Mesh Tool.

better working animation, look for it here in tools.
Field Researcher
#143 Old 16th Feb 2005 at 7:47 PM
Quote:
Originally Posted by Mabelline
I changed it to g body too but Bodyshop and the game have to stop running immediately after I choose the dress with my mesh.
Also, I tried to use Blender, Milkshape and Maya(free version) to generate wavefront OBJ files for import to the mesh file. The results are the same.
I spent about 2 hours to learn the basics of Blender and 1 hour to edit the mesh (not to mention the hours I spent for searching tutorials and threads that are useful)but I still cannot bear fruit. How disappointing it is!


sorry to here this, and afraid I can't help you much ither.
I spend most of my time on objects, and havn't really played with body's much. the new version of mesh tool is now available and may help you, look for it here in tools, for download and read more info about it.

one thing everyone needs to learn more about what they are doing before jumping into trying body meshes, just my opinoin.
Test Subject
#144 Old 16th Feb 2005 at 8:38 PM
Default Is there any zip file for this tutorial
Does anyone have mesh and clothing tutorials in a zip file thanks
Field Researcher
#145 Old 17th Feb 2005 at 12:15 AM
I can't find the GMDC plugin....
Field Researcher
#146 Old 17th Feb 2005 at 6:51 AM
Quote:
Originally Posted by mbunnell
I can't find the GMDC plugin....


this is included already in the new version of simpe.
no need to add.
Lab Assistant
#147 Old 17th Feb 2005 at 10:00 AM
This looks like a great tutorial! Wonderful job!
However I have the same problem as roxxy... SimPE freezes at step 22... I have tried to shut down all other running programs but no succes... Any ideas why this is happening, I would really like to give this a try...
Lab Assistant
DELETED POST
17th Feb 2005 at 2:26 PM Last edited by Mabelline : 17th Feb 2005 at 2:29 PM.
This message has been deleted by Mabelline.
Lab Assistant
#148 Old 17th Feb 2005 at 2:38 PM
1) BriAnna's tutorial says leave everything BUT overwrite names checked off - you have it exactly the opposite of that in your example.

When you export your Original OBJ file in SimPE, name it "body.obj". I had this problem too - basically it comes down to "names" and "internal names" in object files - they are different. I won't go into the long and confusing explanation, but... simply...

Export your object from SimPE with the name "body.obj". Repeat the editing process in blender and export it as you did. Run it through mesh tool but fix the checkboxes. (By default, they should be right, actually).

This should fix it.

X.
Nearly alive
#149 Old 17th Feb 2005 at 3:31 PM
Quote:
Originally Posted by Mabelline
I have had enough with it! :fight:
I spent my holidays to try to fix my problem but it still doesn't work.

Here is what I did to my files after I exported the obj file:
import the obj file to Blender
>edit
>export it with Blender
>import it to milkshape(installed the latest plugins)
>export it in milkshape
>open it with notepad
>add 'g body' in the line just above the line start with 'v' (see attachment)
>save in notepad & close it
>extract .5gd with gmdc
>import the obj with the latest version of the mesh tool
>just tick 'overwrite names' and leave others blank in the settings of the mesh tool(exactly the same as Brianna's tutorial)(see attachment)
>save the file as .simpe with mesh tool
>replace the gmdc of the mesh package file with the .simpe file
>press 'commit'
>save in SimPE Result: When the dress I edited is chosen, a warning message shows up and says that the program must stop running immediately.

I tried my very best to make myself clear. Here are my files in the attachment. Hope someone can take a look at it and help me locate the problem.

Ps: thank you to everyone who replied to my threads



As Xenos said you should have the other options checked (or sometimes leave import polygons unchecked depending on what works for you)
Currently overwrite names is unused and doesn`t do anything, also your obj file (well the one in the rar file) already has the required "g body" line lower down in the file, so the one you added isn`t needed and while it shouldn`t stop the mesh tool from working, it is possible that having two g lines the same, could confuse it . So I suggest removing the top one.
Lab Assistant
#150 Old 17th Feb 2005 at 5:08 PM
Quote:
Originally Posted by Mabelline
I have had enough with it! :fight:
I spent my holidays to try to fix my problem but it still doesn't work.



hey Mabelline since I am the one that told you to have a look tutorial in this
forum, so I will be look at this file here the result, (see the pix)

I assume your nameing and so on are ok, but' the mesh that you export from your 3D programe doesn't work, I guess I couldn't help with that cuz I'm also having this problem when I tried to export it from Maya

*so here my suggest if you do this I am quite confident that your mesh will work

- edit/export/import your mesh in Milkshape ( no I'm not a milkshape fan, I am also "have" to learn to use it, now I'm about 2 weeks old milkshape user, tell you what ..I been swearing a lot while using that programe )
-leave the name as it's, for example if the original name is "body" then don't change it
Screenshots
Locked thread | Locked by: tiggerypum Reason: Outdated, replacement tutorial posted
Page 6 of 54
Back to top