Replies: 1 (Who?), Viewed: 1862 times.
Test Subject
Original Poster
#1 Old 2nd Jun 2014 at 10:09 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life, Island Paradise, Into the Future
Sims 3 Download Manager fails to initiate fully
I have the sims 3 and all packs and expansions. I have a few custom content downloads and packages. Up until yesterday, they worked. When I logged into the game, or tried, the game crashed. I repeated this issue 3 times to make sure it wasn't just a simple glitch. I restarted my laptop, three times, each time tried to initiate the sims 3 with the same result. I removed all the downloads and packages and saved sims folders from the documents folder, storing all three on a thumb drive so there was no chance of them even being found. ran the game, same result... well, after 4 hours of trying to get things to work, i finally uninstalled the sims 3 and all the expansions and packages, completely deleted all folders from both documents and from c drive/ea games involving the sims 3, ran a virus scan, ran malwarebytes, even went as far as setting my computer to an earlier date, funny enough, one of my saved setbacks was just before i installed the sims 3 the first time. no viruses were found, no malware was detected. I reinstalled the game, initiated the launcher, and was happy to see sims 3 again! I then closed out the game and pulled the files i saved on that thumb drive, all my custom content and store bought downloads and my packages, and firstly I tried to re-download the violin I purchased off the store, just to make sure everything was working. I first tried the file i had saved. the downloader starts to initiate, but remains on a small black block on my screen which my task manager states is not responding... i wait for a hour. no change. I finally force the downloader closed. I get a fresh copy of the violin figuring i may have corrupted the file accidentally. tried to use the downloader again, same result... It's been sitting idle for an hour now as a black block and only the violin as it's only target.
I've played sims 3 on this laptop for a couple years, I have a toshiba satellite L745-S4310, it's standard, nothing added, haven't downloaded any new programs in some time, rarely on the internet with it, and the last time i downloaded content was when i purchased the violin a week ago. I'm not sure if i am doing something to cause this or how to fix the problem. I have reinstalled the game 3 times now, tried to download the violin from the store, from my save, tried to download other items both through CC and Store... same result... black block, downloader not responding. How can i correct this please?
Née whiterider
retired moderator
#2 Old 2nd Jun 2014 at 11:22 PM
By downloader, do you mean the Launcher? The launcher is essentially the definition of dodgy and unreliable, and I'd recommend you avoid using it whenever possible. There are some things you can try as far as fixing it goes: Game Help:Launcher Issueswiki

I've also moved this to the Sims 3 Help section, since no mater how frustrated you are, this problem is not caused by MTS.

What I lack in decorum, I make up for with an absence of tact.
Back to top