Replies: 4 (Who?), Viewed: 3241 times.
Test Subject
Original Poster
#1 Old 4th May 2006 at 3:13 AM
Default S2PCI Problems
I've reinstalled S2Pack Clean installer, but when I try to run the program I'm getting the following error:

Sims2Pack Clean Installer.exe - Common Language Runtime Debugging Services
Process id=0x4cc (1228), Thread id=0xd0c (3340).

Click OK to terminate the application.
Click CANCEL to debug the application.

When I click CANCEL, I get:

Registered JIT debugger is not available. An attempt to launt a JIT debugger with the following command resulted in an error code of 0x2 (2). Please check computer settings.

cordbg.exe !a 0x4cc

click on Retry to have the process wait while attaching a debugger manually.
Click on Cancel to abort the JIT debug request.


It might be a .Net error. I have .Net v2 installed.

Any suggestions? Please help
Advertisement
Lab Assistant
#2 Old 3rd Jul 2006 at 12:12 PM Last edited by cwykes : 3rd Jul 2006 at 12:25 PM.
I've been reading the long closed thread to try and help someone else with the problem. here are a few extracts for anyone on the same mission....

It's supposed to work with Net 1.1 (?) version 2 won't work. - I think I'm paraphrasing SimDebster there..

post 1156 phervers in reply to post 1155 about the problem
"well it's one of the mysterious bugs i have not managed to resolve, i'm starting to work on new version soon, after all my commercial projects are finished. You know i got to eat something "

1237 CormorantEnt
Actually, I installed it, and installed again. I finally went with .NET 2.0 rather than 1.1, and went with the previous version of CleanInstaller. I found that if you open CleanInstaller through the file rather than opening the file through the program, it helps overcome some of the problems. But the more recent version of CleanInstaller is very filled with JIT bugs.

Moreover, I know .NET was installed even before trying, because when I tried to install the program in either version on a system without .NET, it wouldn't even allow the installation of CleanInstaller to go through!

So that means, if I understand the message correctly, that the newer version isn't writing something correctly to the Registry. It's bugged.
Test Subject
#3 Old 23rd Feb 2007 at 1:45 AM
Hi
I went one further. When I installed Net2.0 the problems started. So silly me uninstalled Net 1.1. and Net 2.0. When I tried to reinstall 1.1 it woudn't let me. And clean pack wont install with either in any version.so I had to reinstall Net 2.0 again. Should I unstall them both and just reinstall ( if I can) Net 1.1 only. Do you think that would work? what do you think?
Test Subject
#4 Old 1st Mar 2007 at 1:17 PM
And the tricky part is that SimsPe 0.60 wants .net 2.0, so I can't have it one way nor the other. I could give up SimPE 0.60 and seddle with previous version, but that's just not an option for me. Anyway I tried uninstalling .net 2.0 to get S2PCI working, too. I even cleaned my PC thoroughly so there woudn't be a trace of .net 2.0 left. Obviously it didn't work. HELP!
Test Subject
#5 Old 5th May 2007 at 5:42 AM
its work!
it happened to me too, i spent the night and take a lot of coffee
im frustated find a way to solve this problem. but at last, im installing a Microsoft .NET Framework 2.0 and uninstalling Microsoft .NET Framework 1.1 in control panel -> Add or Remove Programs and then i restart my computer.... its WORK!! The CI its work... i dont find any problem yet cause the unistalling Microsoft .NET Framework 1.1. all the program work as usual. give it try... hope this can solve ur problem too. thanx!! irzal - indonesia
Back to top