Replies: 58 (Who?), Viewed: 37348 times.
Page 1 of 3
Lab Assistant
Original Poster
#1 Old 11th Apr 2007 at 1:33 AM
Default Vista and Sims Clean Installer
Hi!

I just got a new computer with Vista Home Edition, and I installed the Clean Installer. The actual program works fine with one exception...

When I right-click on a folder and select "Install All" as I did on my old XP computer, it comes up with the following error:

"Error: System.Security.SecurityException: Requested registry access is not allowed.
at System.ThrowHelper.ThrowSecurityException(ExceptionResource resource)
at Microsoft.Win32.RegistryKey.OpenSubKey(String name, Boolean writable)
at S2PCISE.S2PCISE.ShellExt.IContextMenu.InvokeCommand(IntPtr pici)
The Zone of the assembly that failed was:
MyComputer"


Please help?

Thank you!
Advertisement
Lab Assistant
#2 Old 9th May 2007 at 5:31 PM
Mine keeps doing this as well! I can't find a way around it at all. Help!
Test Subject
#3 Old 15th May 2007 at 9:52 PM
Just chiming in to add that this seems to be a universal problem with Vista. I'm pretty sure it has to do with UAC. I am going to try turning it off and seeing if that works. Even if it does, though, turning off UAC, rebooting, installing everything, turning UAC back on, then rebooting again - it's frankly easier to install manually.
Double-clicking on each file (lots, for instance) and installing them one by one works, but there is a prompt for administrator access.

Hopefully if enough people bring this up a solution will eventually be presented.
Lab Assistant
Original Poster
#4 Old 20th May 2007 at 4:29 AM
Default Vista.Clean Installer
Did turning off your UAC work with Clean Installer and Vista?

Thanks!
Stupid people are stupid
#5 Old 21st May 2007 at 10:00 AM
If you disable UAC, the Clean Installer will not complain about access to the windows registry but crash a moment later. And don’t forget! User Account Control (UAC) is meant to protect you from malware, hackers, and yourself. Disabling UAC gives accounts with administrative privileges admin privileges all the time instead of only when needed and lots of other security features.
If you disable UAC don’t complain if your Windows Vista computer gets malware, hacked, or broken by yourself.
Lab Assistant
Original Poster
#6 Old 30th May 2007 at 12:08 AM
You're saying the Clean Installer will crash? Obviously I wouldn't want to turn off UAC all the time, but for a temporary fix if I had a ton of downloads to install... assuming it would work, it would be worth it to turn off and on again afterward, wouldn't it? I hope?
Instructor
#7 Old 18th Jun 2007 at 9:15 AM
Default :-s
I get error messages too...I don't think I like clean installer...
Lab Assistant
#8 Old 18th Jun 2007 at 5:57 PM
i hate vista! everything i had used to work until i got it

I don't like to repeat gossip....SO LISTEN UP!!!


<a href="http://www.freewebs.com/mobsterwifenatasha/">Visit My Website</a>
Test Subject
#9 Old 18th Jun 2007 at 10:42 PM
That is because Vista is still new. In about a year or two, there will be neat things that just plain don't work on XP. Frankly I like Vista better. Bluescreens less.

It is just the 9 GB of downloaded files I have to extract, etc. Makes me want to beat my head against the wall. So I do understand the frustration of New and Different. Clean Installer wont work,
File Maid wont work,
Q-Express download has a Trojan Virus in it.

Can't win.
Née whiterider
retired moderator
#10 Old 18th Jun 2007 at 11:48 PM
I can assure you - the Q-Xpress has no trojans in it. Having been the beta tester for the current release, and having redownloaded it multiple times to check who's end a downloading problem was on: the only malware I've had on this computer for a long long time was entirely my fault, and not Q-Xpress related.
In fact - I've just downloaded it, virus-scanned it, and run it without issue. To save time later

What happened when you tried with the Q-Xpress?

What I lack in decorum, I make up for with an absence of tact.
Test Subject
#11 Old 19th Jun 2007 at 2:06 AM Last edited by bibblenorn : 19th Jun 2007 at 2:58 AM.
Well, I started the download, and AVAST! comes up with a siren saying the Win32 Virus is in it. Scared the stuffing out of me the first time. I had the volume jacked up pretty high.

The Q-Express forums have some other people complaining about the same thing.

I could try it again, I guess and ignore the siren....


EDIT: I disabled AVAST!, and downloaded the program. I then ran a scan. No Viruses. I then installed it. Scanned again. Still no viruses.

Wonder what that was all about. *shrug* seems to work fine.
Coffee, anyone?
retired moderator
#12 Old 19th Jun 2007 at 4:32 PM
I think the 'virus warning' is a lot of fuss and feathers. Some AV programs alert on the silliest things..programs that you KNOW are clean. Go figure.

You may want to post this on the Q-Xpress forum to allay the fears of the people who are getting the virus alert.

I'm worried that my latest Salvation Army donation will result in homeless people looking like sluts from the 90s.
Test Subject
#13 Old 20th Jun 2007 at 7:19 PM
I don't have a Q-Xpress forum account. If someone with an account could post a link to this thread, or the fact that it seems safe, that would be good.
Coffee, anyone?
retired moderator
#14 Old 24th Jun 2007 at 9:36 PM
Just to add..Mcafee SiteAdvisor has tested Q-Xpress and deems it a clean download.

I'm worried that my latest Salvation Army donation will result in homeless people looking like sluts from the 90s.
Test Subject
#15 Old 16th Jul 2007 at 3:47 PM
Well,
I tried several things
One thing is that in Vista, disabling UAC won't help. It's the format of Vista that is the problem. CEP looks like the only legitmate program that works for Vista. What he said about Q-Xpress having a virus, he means that for Vista it doesn't work and a file is missing.

So if anyone could post something about Q-Xpress not working and maybe have a hotfix or a patch for it, that would be nice.
Test Subject
#16 Old 16th Jul 2007 at 11:33 PM
I can't use it for Vista either. It locks up every time after 25%-33%.
Lab Assistant
Original Poster
#17 Old 17th Jul 2007 at 10:07 PM
Is there any way someone could beg and plead (and maybe even pay? I know I would be willing to pay) for the creator of CEP to update it for Vista?
Test Subject
#18 Old 14th Aug 2007 at 12:24 AM
I have been having the same problem with Sims 2 Clean Installer. My copy did the same as Nothelinski's. Ironically my Q-Express is fine. I found by combining both softwares together I was able to do the right click install.

1)Click on Q-Express and open it
2)Select Local Install and then Browse(I always save my stuff to the desktop easier for me)
3)find the files and right click on them and choose install all and Sims 2 Clean Installer takes over installing the files.

It sounds a lil a$$ backwards but I got it to work so I'm happy. lol
Lab Assistant
#19 Old 24th Aug 2007 at 9:31 AM
I'm having problem with Clean Installer and Vista too. Mine is even worst. Nothing happens when I click on it and then a window pops up and says something about reinstalling everytime. Now when I try to open Sims2package the old Maxis content manager takes over....I don't remember how I set the Cleran Installer as default for this type of file??? Geeeee...
Field Researcher
#20 Old 24th Aug 2007 at 10:35 AM
Quote:
Originally Posted by nothelinski
for the creator of CEP to update it for Vista?

The CEP do NOT need to be update for Vista, it works fine. What is your problem?

About CI, I'd like to remember that Clean Installer need the .Net 1 to works, and on Vista there is .Net 2, so you must install ALSO the .Net1 on your machine: you can give booth.
I have no problem with Vista (Vista Ultimate) and CI, CEP, DDO, BGS, and others: anyway I still prefer XP pro

If you hate the warnings that show-up every time and tell you that the operations required administrator privileges, you can active the "real administrator" that is not the usually account for administrator

If you like my creations, you may consider to make a little donation to support my site and my modding activity.
MaryLou's Sims 2 World - MaryLou Sims 2 Forum (Italiano)
Test Subject
#21 Old 1st Sep 2007 at 3:03 PM Last edited by sweetcharming : 2nd Sep 2007 at 12:17 PM.
I'm having another problem with the Clean Installer and Vista: Everytime I download something and I want to extract it with the Clean Installer it just opens the Clean Installer window without the files, but it shows the "Install" and "Save as..." buttons. But even if I use this buttons and try to use them like always, it doesn't work and the things don't appear in game. Please, please help me!!!

Edit: I also tried it with older Clean Installers, but it didn't work, too. But if I want to extract something now, it only opens a window that says:
Application has generated an exception that could not be handled
Process id=0xcc0 (3264), Thread id=0x920 (2336)

Can someone help me, please?
Field Researcher
#22 Old 7th Sep 2007 at 9:32 AM Last edited by Witchboy : 7th Sep 2007 at 9:59 AM. Reason: Spelling
Im getting an error with the Clean Installer every few files i try to install. I just used CI to add alot of new items to my game, but a few wouldnt open & CI would give me the following error pictured below.



Files i couldnt get to open in CI are the Luxury TV for GLS, Blue Bell Dress for Celebration Stuff & Where in the World Map for Bon Voyage & various other sims2pack files.

Anyone else having this problem & know a work around? Im using Vista Ultimate Edition. Ive tried Sims File Maid but it dosent recognize the path to my downloads folder (im guessing because im using vista) & the offical installer that came with the game says its installed the items but i dont see them in my downloads folder or in game.
Field Researcher
DELETED POST
7th Sep 2007 at 3:41 PM
This message has been deleted by nancyw41. Reason: Not the same problem...sorry
Lab Assistant
#23 Old 15th Sep 2007 at 6:49 AM
Vista is the Devil. I wish you all good luck and sorry I can´t help... Im sticking with XP.
Test Subject
#24 Old 6th Nov 2007 at 11:28 PM

i have vista and thats what shows up when i try and run Q-Xpress
then it will open, but when i try and download it will shut off
HELP PLEASE :'[
Test Subject
#25 Old 11th Nov 2007 at 1:26 AM
Default I got the same problem too
Hi, I'm using Vista too. And I have the same problem as you do.

I tried to save the files as .sims2package blahblah or something, and then install each one of them seperately. Like, right click, install, right click, install, and so on.
I don't have any problems that time, but when I tried to see the result by BodyShop, I can't find the things I installed. Phooey.
Page 1 of 3
Back to top