Replies: 4 (Who?), Viewed: 1245 times.
Instructor
Original Poster
#1 Old 31st Aug 2007 at 1:55 AM
Default Quaternion Values Not Being Stored.
Okay, so I'm trying to mesh a pair of shorts for my teens and I keep getting this error when I try to export both the shirt and the top as I'd like them to be seamless.

What I'd like to know is if this can be caused by using Extended Manual Edit and Wes's normals data merge plugin? Because it usually always happens after I use one for both of those plug-ins.

Thanks.

desperation makes you look like a tool

Exclusive downloads available only at Phasmatic Sims!
Advertisement
Alchemist
#2 Old 31st Aug 2007 at 2:13 AM Last edited by wes_h : 31st Aug 2007 at 2:20 AM.
The quaternion values are stored in the joints comments, and are needed to place the skeleton back in the original position.

Somewhere, you are changing the bones themselves. Did you start with an imported teen clothing mesh item? If even one got messed up, the exporter would complain.

Now, you should be able to rescue this work by importing some teen clothing item into a new file. Select and delete the mesh group, but not the joints. Then import your old mesh overtop of this. Older versions asked about importing the skeleton. You do not want that.

When done, your old mesh should be laid on top of a fresh skeleton, with the right quaternions. Save this and continue on with your project.


If the Normals plugin has a side effect, I can fix that. If it is the extended manual editor, I can do nothing (as I didn't write that one). One other question though... are you using MilkShape 1.8.1 (not 1.8.11b)? 1.8.1 progressively shortened the comments by one character. That would eventually make the quaternions unusable. If so, update to 1.8.1b.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Instructor
Original Poster
#3 Old 31st Aug 2007 at 2:15 AM Last edited by migamoo : 31st Aug 2007 at 2:21 AM.
Call me dense, but how would I go about deleting the mesh group and not the joints? Just in the group menu?

I'll also try updating.

desperation makes you look like a tool

Exclusive downloads available only at Phasmatic Sims!
Alchemist
#4 Old 31st Aug 2007 at 2:22 AM
Yes.

Go to the edit menu and "select None".
Then click on the groups tab, pick one group, click on select, and then press the delete key. *poof*. Do that for all groups and al you have left is the skeleton (which you may or may not be viewing, depending on the checkbox setting).

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Instructor
Original Poster
#5 Old 31st Aug 2007 at 3:36 AM
While I wasn't using 1.8.1, upgrading did help. Thanks!

desperation makes you look like a tool

Exclusive downloads available only at Phasmatic Sims!
Back to top