Replies: 13 (Who?), Viewed: 3727 times.
Test Subject
Original Poster
#1 Old 22nd Nov 2008 at 11:01 PM Last edited by garjian : 23rd Nov 2008 at 12:07 AM.
Default ohno! :(
ok so ive been editting meshes for a few days now... but ive finally run into my first problem...

for some reason, the finished product is a huge twisty mess!

it looks fine in milkshape, even if i rexport it.
ive tried repeating the process and the same thing happens, i even tried following the tutorial again, and its still happening...

no idea whats up with it :P
Advertisement
Test Subject
#2 Old 22nd Nov 2008 at 11:30 PM
Quote:
Originally Posted by garjian
ok so ive been editting meshes for a few days now... but ive finally run into my first problem...

for some reason, the finished product is a huge twisty mess!

it looks find in milkshape, even if i rexport it.
ive tried repeating the process and the same thing happens, i even tried following the tutorial again, and its still happening...

no idea whats up with it :P


I've got the same problem

It's like just this:

The "monster" & the outfit which I wanted to combine with a basic body mesh.


And yep, in Milkshape it does look perfect (well, not the world's best mesh - but I would be happy to have it...)
Test Subject
Original Poster
#3 Old 23rd Nov 2008 at 12:04 AM
yeah thats the thing!

how do i fixes it? :P
Alchemist
#4 Old 23rd Nov 2008 at 1:09 AM
You both have moved the joints in your mesh while you were learning.

There is a fairly easy fix for this: reimport the original mesh, select the groups and delete them (leaving just a fresh skeleton) and then import your broken mesh overtop of the skeleton... the importer will not import the second skeleton, allowing you to have all your hard work attached to a fresh, unbroken skeleton.

Usually, when this happens, you had the skeleton visible while you were editing the mesh, and one or more joint were selected along with vertices or faces and then you used the move function.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Test Subject
Original Poster
#5 Old 23rd Nov 2008 at 3:10 AM Last edited by garjian : 23rd Nov 2008 at 3:34 AM.
i didnt have the skeleton visible but i did move using the group select...
let me quickly try this solution and ill see if it worked...

yeah... it did solve that problem... but now the mesh seems to have holes in it... and strangely some things at the back are overlapping the things at the front... but again seeing none of this in milkshape...
Test Subject
#6 Old 23rd Nov 2008 at 9:00 AM Last edited by b-bettina : 23rd Nov 2008 at 9:18 AM.
Ok, thanks I will try to solve it with that too. Hope it will help Thank you so much Wes for helping us out! :D

I've got one more question left: to not let it happen anymore, is it the only thing that I have to untick?

(oh, well, I'm kinda sure that it was unticked while I was workin' - when I opened MS it was the first thing for me to do as it was told in the tutorial. How could it be that I moved the joints anyway?)



EDIT: Ok, I've tried solving it, but when I'm trying to import my mesh I get this error message:
Screenshots
Test Subject
DELETED POST
23rd Nov 2008 at 11:15 AM
This message has been deleted by simsample. Reason: Not allowed
Test Subject
Original Poster
#7 Old 24th Nov 2008 at 6:27 PM
lol can milkshape do anything right? seems every tool has a flaw... i belive its the scaling tool thats causing holes in my mesh... shouldnt something be done to fix glitches like this?

also what program can i use to stop this happening... i did try blender but, it was slightly confusing... im gonna try it out again and hopefully ill get it this time. but what else can i do?
world renowned whogivesafuckologist
retired moderator
#8 Old 24th Nov 2008 at 6:40 PM
b-bettina - It shouldn't allow you to move the joints if they're not visible and you never select them. Not sure how you managed it, but unticking that is generally all you need to do to prevent that. The error you're getting is related to having too many joints - you probably have two many skeletons from clicking the wrong answer when importing a second mesh over the top of the first one to combine parts.

garjian - Scaling should not be causing any sort of holes. Things overlapping and the appearance of holes sounds more like an issue with underweight vertices - ones that don't add up to 100%. If you clicked the right answer when importing the mesh(es) originally, that shouldn't be an issue. There's an option for fixing underweighted bones under the Vertex menu.

my simblr (sometimes nsfw)

“Dude, suckin’ at something is the first step to being sorta good at something.”
Panquecas, panquecas e mais panquecas.
Test Subject
Original Poster
#9 Old 24th Nov 2008 at 8:53 PM
hmm well... it didnt ask me anything... also that fixer didnt work for me...
but great news is I FINALLY GOT IT WORKING Wooooo!!!
world renowned whogivesafuckologist
retired moderator
#10 Old 24th Nov 2008 at 10:12 PM
garjian - When you import a mesh, it asks, "Some Skin Weights do not equal 100%. Do you want these corrected?" If you do not say Yes to that, you will end up with underweight vertices.

my simblr (sometimes nsfw)

“Dude, suckin’ at something is the first step to being sorta good at something.”
Panquecas, panquecas e mais panquecas.
Test Subject
Original Poster
#11 Old 24th Nov 2008 at 10:35 PM
hmmm... never seen it ask that before...?
world renowned whogivesafuckologist
retired moderator
#12 Old 24th Nov 2008 at 10:40 PM
Well, you should've, as it will ask that pretty much anytime you import a Maxis mesh the first time... If you reimport after editing, it usually doesn't, but first time, basically every time, and you -definitely- would've seen it doing the tutorials.

my simblr (sometimes nsfw)

“Dude, suckin’ at something is the first step to being sorta good at something.”
Panquecas, panquecas e mais panquecas.
Test Subject
Original Poster
#13 Old 25th Nov 2008 at 1:18 AM
*whistle* maybe im not using maxis meshes :P
anyway i have a new mesh related problem... which im making another thread about :O
Test Subject
#14 Old 25th Nov 2008 at 3:30 PM Last edited by b-bettina : 25th Nov 2008 at 4:20 PM.
Quote:
Originally Posted by HystericalParoxysm
b-bettina - It shouldn't allow you to move the joints if they're not visible and you never select them. Not sure how you managed it, but unticking that is generally all you need to do to prevent that. The error you're getting is related to having too many joints - you probably have two many skeletons from clicking the wrong answer when importing a second mesh over the top of the first one to combine parts.


Thank you! I thought nobody would ever answer my question - I'm going into Milkshape right now - I think I know where I was mistaken I remember I was a bit confused when I came into that part of the tutorial...

Thanks again!


Edit: OMG! OMG! OMG! It works! I've just made my "real" first mesh! Thank you sooo much, HP! I'm going to test it in-game too right now!
Thanks again!
Back to top