Hi there! You are currently browsing as a guest. Why not create an account? Then you get less ads, can thank creators, post feedback, keep a list of your favourites, and more!
Replies: 23 (Who?), Viewed: 3629 times.
Test Subject
Original Poster
#1 Old 4th Feb 2009 at 5:51 AM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Espress-o-matic bar missing from Uni EP
I recently installed Sims 2 Double Deluxe PC version on my MacBook Pro. I also loaded EPs: University; Open For Business; Pets; and Seasons. Of course, S2DD comes with Nightlife and Celebration SP. I launched each EP after each installation. I updated with appropriate patches.

There is no Impresso Espress-o-Matic bar. It is not in the Buy Mode anywhere. It is not in the University Collections folder. It is not on any Community Lot. There is a space where the bar should be.

I uninstalled and reinstalled. I specifically checked for it when I loaded University this time. Still is not available. Before I uninstalled, out of curiosity I checked with SimPE to see if it was in my Resources and it was. I haven't checked again since I reinstalled.

How can I get this item back into my game? I am very new to using SimPE. So, I am not that well versed with what to do. Yes, SimPE was used to recolor some pictures and a lamp as part of a tutorial. I did have a problem with a mistake I made because I hadn't installed Nvidia DDS. But that was rememedied. I had hoped that the reinstall would have taken care of any problem had I inadvertently done something I shouldn't.

Any guidance will be appreciated.

I only found one other instance of this, but it pertained to Mansions and Gardens EP and that problem was remedied. I did post this on another forum site. The advice there was to ask Numenor to help get it back in the game.
Advertisement
#2 Old 4th Feb 2009 at 5:59 AM
Yeah, Numenor is good at that kind of thing. I`ve had a similar issue [with a "cheat object", in my case], and it was suggested that I try to clone the object I`m trying to access. Have you tried to clone the Espress-o-Matic?

This Space Intentionally Left Blank
Test Subject
Original Poster
#3 Old 4th Feb 2009 at 6:30 AM Last edited by psinatra : 4th Feb 2009 at 8:01 AM. Reason: Update info in post
I haven't done anything further since reinstalling. I have to reinstall my zCEP files too before I can use SimPE again. I considered cloning the object but was afraid that whatever prevented it from being available in the game might simply be cloned as well. As I stated, I'm not that well versed with SimPE. I will try that and let you know how it goes.

LATER: I don't know the proper procedure for cloning. I did remember my past recolor mistake where I managed to copy without changes to that lamp I was working on. So, I tried to simply recolor. The only difference this time is Nvidia DDS was installed. Still no espresso. I guess it's self-serve for my Sims until I fix this. My other thought is to return the disk, if the store accepts it.
#4 Old 4th Feb 2009 at 7:15 PM
I started with Double Deluxe myself. I don`t know what else to suggest at this time. One question, though: Did you *ever* have that particular object show up, that you know of? Idea: If so, perhaps you could [using Numenor`s AnyGameStarter, perhaps, or re-installing, if need be] re-create the environment in which you found it, and add it to a collection, then see if you can access it through that collection in your full game. That would be a lot of work, though, and it might well not work, even if you can add it to a collection. I wish thee luck, though.

This Space Intentionally Left Blank
Instructor
#5 Old 5th Feb 2009 at 4:03 AM
Did you ever have any recolors of that object? If you had an improperly done recolor, deleting it could have deleted the original object. Although it should have shown up again with a reinstall!

If the object shows up in SimPE, can you check and make sure it has all its mesh and texture files?

Cloning isn't too hard. I've done it before. Use the tutorial for creating a new object.
Me? Sarcastic? Never.
staff: administrator
#6 Old 5th Feb 2009 at 4:48 AM
Have you tried installing just Uni again? And if there is a space where it should be in the catalog, have you tried selecting it?


This really isn't a Mac issue since you installed on your Windows partition.
Test Subject
Original Poster
#7 Old 5th Feb 2009 at 5:36 PM
PLEASE MOVE THIS POST!
Sorry, if this is posted in the wrong area. I wasn't even really aware that it was posted specifically under Mac Issues. If someone would like to move this post to a better location, I'd be happy.

Yes, I did a clean reinstall of the entire game.

To Rhiamom: I did try to recolor it to get it back into the game. No files were deleted that I was aware of. I did attempt to clone it, but wasn't certain about some of the check boxes, etc. I did go through Numenor's cloning choices list but had a question about pulling the animations. And, I had no one to ask.

I just want to play the game! My Mac version is down; my new investment for the PC version is working with this one exception. EA has been no help. Their responses are irrelevant to my question.

My daughter has her PC here at my home. She has the base game loaded. I'm going to try to load University into her PC and see what happens.
Test Subject
Original Poster
#8 Old 5th Feb 2009 at 5:40 PM
to G.O.D.:
It never appeared in the game. Just not there. I checked the University campuses where I have played the game before, but on my Mac. There bar isn't there. Just an empty space where it should be. I will check my packaged lots (on my Mac) to see if I included it in a lot. But then, it might not show up because it isn't already in the game. Am I right in thinking that? But it is in the game because it show up in SimPE. My head is spinning. Phew!
#9 Old 5th Feb 2009 at 7:05 PM
Hmm, weird. I have University on my machine; do you know SimPE well enough to find the GROUP number of the missing bar? I`d like to look at my University object.package and see what I can find.

This Space Intentionally Left Blank
Me? Sarcastic? Never.
staff: administrator
#10 Old 5th Feb 2009 at 11:19 PM
General O.D. You will find the Group and GUID in the documentation that came with CEP. But the Espresso-Matic is 0x7FE94D23.

psinatra - Do you have any custom content that could be overwriting this and preventing it from showing? And since you said that there is a space for it, did you try selecting it?

Quote:
I checked the University campuses where I have played the game before, but on my Mac. There bar isn't there. Just an empty space where it should be.


So does this bar not show up on the Mac side or Windows side?
#11 Old 6th Feb 2009 at 2:37 AM Last edited by GeneralOperationsDirector : 6th Feb 2009 at 3:15 AM.
HugeLunatic, thank you for the Group ID; I`ll be looking into that as soon as SimPE finishes loading. I think that psinatra means that in lots where the bar exists in the Mac version of the game, there is an empty space in the Windoze version of the lot.

Edit: I`ve had a peek at the OBJD for the Espresso Machine Cart, and it appears to not have the "Overall Sort" set. It does, however, have both "Downtown Sort" and "Community Sort" set to 0x0085, whatever that means. "Valid EP Flags 1" appears to be set to University: 0x0001. I don`t see anything else that relates to catalog visibility, except for a couple other auxiliary placement "Sort" values that are all set to zero.

Does anyone know what this means regarding when it appears in the Buy Mode catalog?

This Space Intentionally Left Blank
Test Subject
Original Poster
#12 Old 6th Feb 2009 at 8:01 PM Last edited by psinatra : 6th Feb 2009 at 8:06 PM. Reason: Grammatical error and clarity
What is showing up under Object Workshop Window is:
Impresso Esress-O-Matic (cached) (0x7FE94D23)
That's the same as HugeLunatic.

Under Selected Object:
Name: Impresso Espress-O-Matic
Price: 1495 $
Category: Appliances/Miscellaneous
Required EPs: unknown[1]
Vertex Count: ---

The total number of files which SimPE says I have are 14. There are no files other than the texture files. No meshes, no behaviors, no globals. Just the Texture information.

I just got the Prima Game Guides and think there is even more missing from this EP, like the Ceiling Fire Extinguishers. I am going to search further into this.

To HugeLunatic, let me be more clear. The bar appeared in the game on my MacG5. When I packaged the lot which contained the bar using Sims 2 Package Installer and installed in the Windows partition on my MBP, does not appear in the Windows version of my game.

Yes, I clicked the area in case it was there, but invisible? (Hey, you never know!) But it didn't register that anything was there.

Geez, if Quicktime hadn't crashed my Sims 2 and if I'd known earlier that Aspyr planned to release Sims 3 on June 2, I might not have gone through the trouble and expense to purchase the Windows version in the first place. Well, maybe I would, just so I could do some recolors. I'm just a Sims junkie and can't get enough. I think you all understand.
Me? Sarcastic? Never.
staff: administrator
#13 Old 6th Feb 2009 at 8:37 PM
hmmm....thanks for clearing that up. I was getting lost.

Are you loading your game with no cc? - You could have a cc object with the same GUID preventing it from showing. This would be my best guess.

Uni doesn't come with Double Deluxe does it? And have you tried re-installing just Uni?
Test Subject
Original Poster
#14 Old 7th Feb 2009 at 5:09 AM
I did a clean reinstall. Fresh, no CC. Loaded them in EP sequence. Uni doesn't come with Double Deluxe. Nightlife does. So, right there the EPs are out of order. [I got conflicting remarks about this. Some people posted that you can go out of sequence when installing Sims 2. And then I've read the opposite, that you must install in sequence, like Sims (1)]. The only things I can think of that is possibly different is the fact that this is Double Deluxe; that I must go through the Sim 2 Store Edition in order to launch my game; that the sequence is out of order; provisions are already in place to play Free Time and Apartment Life when I get them; options that became available in later EPs were available in Double Deluxe.

I'm confused and tired. (Hey, I need an espresso!) And all I want to do is to continue to play the game I was involved in before the Quicktime Crash.
#15 Old 7th Feb 2009 at 6:19 PM
What happens if you move the WinUni objects.package out of your game and replace it with a copy of your MacUni objects.package? Be sure that you get the *right* objects.package in the *right* place, as there are two of them in some expansions. If this doesn`t help, delete the Mac version and restore the moved Win version.

This Space Intentionally Left Blank
Test Subject
Original Poster
#16 Old 8th Feb 2009 at 4:31 PM
What happened when I swapped out packages was—nothing. Still no bar. I don't know what to think now. I was hoping that was really going to fix it. Maybe one of the bars in the Celebrations SP overrides the espresso bar?

I swapped the WinUni objects.package back. All is well except that the control bar is missing the icon of the house (there's a picture box and when hovered over turns from white to pink striped; it is click-able and does allow me to enter lots) and the alignment of the control bar is slightly askew.
Me? Sarcastic? Never.
staff: administrator
#17 Old 8th Feb 2009 at 5:34 PM
General O.D. I notice you have Uni and you mentioned that you also have double deluxe. Does this bar show up for you? If so then it's not an issue with the game.

Showing up in SimPE means nothing btw. Every EP and SP has an objects package and it includes all the meshes and crap from all previous EP's. Redundancy and bloat at its finest.

Why do you have to go through the sims store? Can't you just use your exe from double deluxe? Have you tried?
Test Subject
Original Poster
#18 Old 8th Feb 2009 at 10:40 PM
The bar does not show up. I figured that the Impresso Espress-O-Matic appeared in SimPE because it's a cached item? And not that I actually have it in my game. But, because I'm not that familiar to Windows nor to SimPE, I can only guess.

I cannot load from Double Deluxe, nor any of the other EPs. I am forced to go through the Sims 2 Store Edition in order to launch the game. What happens when I double click on the shortcut to say, Seasons (the last EP I installed.) My window takes that pause like it's going to launch, then nothing happens. Nothing happens until I opened the Sims 2 Store Edition shortcut which I found on my desktop. Then, it shows me which EPs/SPs are installed and asks if I want to PLAY or go to the EA/Sims 2 Store? You must click PLAY to enter the game.

I like my Mac much better!



I'm in the process of uninstalling all the EPs & SPs and starting over once again.
Test Subject
Original Poster
#19 Old 9th Feb 2009 at 12:30 AM
Alrighty…I reinstalled Double Deluxe after removing everything again. (Yes, I checked to make sure all the files were gone after uninstalling.) I even uninstalled the Sims 2 Store Edition.

The base game (DD) launched just fine. Then I reinstalled University. I cannot launch the game. It seems my problem is with University. Unless there is some secret thing that stupid Windows is supposed to do or I'm supposed to do to with Windows, I am now at am impasse.
Me? Sarcastic? Never.
staff: administrator
#20 Old 9th Feb 2009 at 1:41 AM
Try going to C:\ProgramFiles\EAGames\ExpansionPacks\DoubleDeluxe\EP2 and double clicking the exe file there.

I think the folder is EP2, my motherboard just died this am so I cannot go double check the windows machine. But in the Double deluxe folder I think it had folders for base, EP2 and SP4. So try the one in EP2 and SP4. The shortcut on your desktop actually goes to one of those ( I don't know which is technically the later ep), and it might just be the shortcut not working.
Test Subject
Original Poster
#21 Old 9th Feb 2009 at 3:42 AM
I don't know how or why, but the seventh time's the charm. I could not launch University by double clicking the shortcut, nor by clicking the icon in the TSBin or selecting Run or Open. So, I opened Double Deluxe and launched the program. It instructed me to insert the Double Deluxe disk. I did and saw that the Sims 2 Launcher said that University was installed. I clicked PLAY, the game launched, went through its tasks and I was in. I was able to select University from the Menu and selected Sim State. I entered that and then entered the Campus Lounge. There was the Impresso Espress-O-Matic. If ever anyone else has this problem or similar, I left bread crumbs to find the way. Wow. I can't believe all this trouble just to play a game that I use to relieve my stress. I spent 6 hours this evening alone trying to get it up and running.

Well, I have the rest of the EPs to install now. I'll let you all know how that goes—if I have to use Double Deluxe to launch the game. Until then, THANK YOU, THANK YOU, THANK YOU to all those who took the time to help.
#22 Old 10th Feb 2009 at 7:05 PM
HugeLunatic: "General O.D. I notice you have Uni and you mentioned that you also have double deluxe. Does this bar show up for you? If so then it's not an issue with the game."

I don`t know; where in the catalog am I supposed to find it?

psinatra: Of course you have to launch Double Deluxe when University is the only expansion installed: NightLife itself is newer than University, so University will not count as your "newest expansion". As Numenor pointed out to me in his AnyGameStarter thread, Double Deluxe includes the executables and all of the "bloat" for the base game, NightLife, *and* Celebration Stuff.

This Space Intentionally Left Blank
Me? Sarcastic? Never.
staff: administrator
#23 Old 10th Feb 2009 at 11:01 PM
#24 Old 26th Feb 2009 at 9:33 PM
General notice for anyone else having this problem, but isn`t helped by this thread:

There is another thread with identical symptoms but apparently different causes:

Technical Issues - Espress-O-Matic bar disappeared from game after installing The Sims 2 Store Edition

This Space Intentionally Left Blank
Back to top