Hi there! You are currently browsing as a guest. Why not create an account? Then you get less ads, can thank creators, post feedback, keep a list of your favourites, and more!
Replies: 120 (Who?), Viewed: 177793 times.
Page 1 of 5
Lab Assistant
Original Poster
#1 Old 28th Jun 2009 at 6:51 AM Last edited by TigerM : 21st Aug 2009 at 10:26 AM.
Default Neighborhood Workshop (Formerly save game editor - now with simple painting replacement)
Latest update 1.4 on 8/21

Sims 3 Neighborhood Workshop is the first incarnation of my save game editor with an attempt at a friendly interface. Right now all that it can do in a friendly manner is modify still life portraits your sims have painted. The full editing and viewing capabilities are still there as well, but there are numerous ways that using the advanced editor mode can screw up your games if you don't have backups.

Your choice of downloads:
Windows installer
Just the exe and presets

(No more mac specific download - the packaging I attempted didn't work quite right. However it will still work fine on a Mac under mono, just download the zip file.)

Still Life Workshop
For those of you with artistically bent sims, the still life workshop allows you to view the various still life paintings your sim has attempted. If you really like something they did, you can export the picture (On the file menu) and use it wherever you want. On the other hand if you think they are a bit muddly looking and you think your sim is better than that, you now have the power to turn them into a regular Da Vinci. Under the file menu, select the import option to load a new picture in to replace one you don't like. Even if your sim hasn't painted it yet, you can still replace what they plan to paint and have memorized.

You can also rename the paintings to your hearts content by clicking on the title and entering a new name. Of course, you can do that just as easily from within TS3.

Once you are happy with your sims new artistic talents, just save the neighborhood again. It is strongly encouraged you save to a different name, as I can not warrant that this program will not break something else.

Advanced editor
And of course, as a nod to the save game editor heritage, the familiar old scary advanced interface is back. You can do pretty much anything here that involves modifying the values of script objects. Including screw up your neighborhood severely, to the point that it won't load. But if you know what you are doing, this is also a powerful tool.

Since it shows all script objects, the advanced editor can also be useful to core mod developers, so you can see exactly what the state of various objects are in a neighborhood, and see if/how any of your scripts objects are being saved.
.NET framework 2.0 is required, however it runs under mono mostly perfectly happily (Tested on Linux, should be the same on mac). The only issue on Mono (On Linux at least) is that cut/paste does not work properly for object instances.

Changes in 1.4
  • Compression is a little faster now, at the cost of a little size

Bug Fixes
  • Save data larger than 16mb will now be written properly

Changes in 1.3
New plugin
  • Still life workshop - view and alter paintings made by your sim

Bug Fixes
  • Removed oddly wrapped text from tree view displays
  • Fixed read only file handles being held until the program exits

  • Added plugin selection screen to support multiple plugins
  • Augmented the file menu with a neighborhood selection similar to what TS3 has
  • Significantly reduced load time
  • Renamed to "Neighborhood Workshop" to reflect the refocus of utility

Changes in 1.2
  • References to objects can now be modified by setting to an existing object, null, or a new object.
  • Array, list, dictionary and hash table contents can be modified, added and deleted.
  • Copy and paste now work for copying values, and cut and paste work for moving (Or duplicating) references to objects.
Test Subject
#2 Old 28th Jun 2009 at 6:57 AM
itz cooooool, thank you tiger @ tyger .
#3 Old 28th Jun 2009 at 8:29 AM
Ooh, I am going to have to take a good look at this tomorrow. YAY!!
Lab Assistant
#4 Old 28th Jun 2009 at 2:55 PM Last edited by xalwaysvindicatedx : 28th Jun 2009 at 5:22 PM.
Very cool, I'm definitely going to try this out

Not sure if this is a bug or something of my doing, but I was writing a tutorial on modifying gender preferences with this tool, and it all worked fine until I opened up the game to check and saved the town. Now whenever I try to open that save file again, it gives me the "Unable to read beyond the end of the stream" error. Any ideas? I'm running Vista x64 with .NET 3.5 installed. The game loads the save fine, I just can't seem to open it again (read only or edit mode).

I tried saving it ingame again and got "Unable to parse generic parameter definitions" when trying to open it.

EDIT (Again):
I figured out that, after running the game and saving, if you copy the [Savename].sims3.backup and make it replace [Savename].sims3, it will keep your changes and allow you to edit it again. Welcome to the voodoo that is The Sims 3
Lab Assistant
Original Poster
#5 Old 28th Jun 2009 at 5:37 PM
So let me understand this chain of events...

1. Edit file, save as A
2. Load A in TS3, save as B
3. B gives end of stream error
4. Load B in TS3, save as C
5. C gives generic parameter error

Is that about it?

The second error should be easy to fix - I'd forgotten to roll some new research/understanding of the data into that part of the code, so as long as that's all it is it should be fine. In fact, I just uploaded a fix now.

For the second problem, are you running with any core mods installed? If you still have the save and don't mind sharing, I wouldn't mind taking a look at it. If you have somewhere you can put it, or PM me and I can give you an address to email it to. If you're familiar with one of the package editing tools like s3pi or postal, all I need is type 06b981ed group 00000000 instance 0000000000000001, and it should compress pretty well with zip or whatever.
Lab Assistant
#6 Old 28th Jun 2009 at 5:45 PM Last edited by xalwaysvindicatedx : 28th Jun 2009 at 5:56 PM. Reason: Grammer :)
That's the correct chain of events
It's weird, once I replaced the Sims3 file with the Sims3.Backup file, it hasn't given me a problem yet (I've saved and reloaded successfully without replacing it again). I don't still have the save though, as I replaced that with the Sims3.Backup file. I just saved and reloaded again and it's still working - I nominate The Sims 3 as the most spazzy game of the year

I'll download the new version once I finish this test (I'm pretty much playing around with different settings and if it explodes, my EA folder is backed up).

I disabled all of my mods (cut and pasted Resource.cfg and Mods folder to my desktop) for another reason last night and I just never got around to putting it back - it worked out well in this case :P
Lab Assistant
Original Poster
#7 Old 28th Jun 2009 at 5:56 PM
The mods might still have data in your save games if you haven't saved since disabling them. And they might be producing save state that looks different than what the game would produce normally. But that wouldn't explain the problem on the second save file.

Edit: New new version that fixed my new save bug in place. I was too quick throwing in the fix for the generic parameters that I forgot I'd just put in another change that I hadn't had a chance to test.

Also if you're going to write up how to change gender, there is actually an easier way then I said in the other thread. If you select "current household" in the list on the left, it takes you right to your sims and to the correct object to edit gender without having to find the difficult to spot mDescription field.
Lab Assistant
#8 Old 28th Jun 2009 at 6:00 PM
I completely deleted the My Documents/Electronic Arts folder (after copying it to a safe place, that is :P) to make sure none of that would happen, and I just let the game regenerate a new one for my testing purposes. Once you post the new version, let me know and I'll happily tear apart my save to see what breaks it and what doesnt

I knew about the Current Household selection, so that's in my writeup already
Lab Assistant
Original Poster
#9 Old 28th Jun 2009 at 6:05 PM
New version is up.

The filters are actually customizable in presets.xml if you're comfortable with XML. If you think another filter preset would be useful, feel free to suggest it and I can put it in the package. Even if you're not comfortable with xml, you can always suggest it and I can put it in.
Lab Assistant
#10 Old 28th Jun 2009 at 6:07 PM
Okay, I'll take a look at that and if I have any ideas I'll let you know
Lab Assistant
Original Poster
#11 Old 28th Jun 2009 at 6:09 PM Last edited by TigerM : 28th Jun 2009 at 6:29 PM.

For clarification, mods shouldn't make a difference. There is only really one thing mods could do which would trip up the editor, and I don't see much of a reason for the mods to do it. But if they do, it can easily be remedied by using tools->advanced->import type definitions and select the package with the mod scripts. On the other hand though, if a mod DID do that, it would either go completely unnoticed because of code that compensates for that sort of thing, or it would cause one of those end of stream load errors. (You can spot the former case by looking at the unknown instances filter - that should normally never find anything.)
Lab Assistant
#12 Old 28th Jun 2009 at 6:21 PM
I don't think the download from your site got updated. It wont let me save my changes, so I checked the version - it says its
Lab Assistant
Original Poster
#13 Old 28th Jun 2009 at 6:30 PM
Hmm, I just checked the zip file and it was 1.1.2... I'll rebuild the package just in case.
Lab Assistant
#14 Old 28th Jun 2009 at 6:31 PM
I downloaded the MSI, that might be why.

Edit: Yep, the zip version is the new one
Lab Assistant
Original Poster
#15 Old 28th Jun 2009 at 6:36 PM
I put both up at the same time, but I'm a little new to making installers so I might have screwed something up. I'm used to just writing the code and letting someone else deal with packaging it up. New one should be up now, but the zip should be good either way.

Edit: No clue what happened, I just tried downloading the original 1.1.2 package and I got the right version. Really baffled where it could have gotten mixed up.
Lab Assistant
#16 Old 28th Jun 2009 at 6:39 PM
No problem
If you want to keep the installer an option, maybe try Inno Setup. I haven't used it, but I heard it was reasonably easy to use (has a step-by-step wizard), plus it's free.

Edit: Here's the link - http://www.jrsoftware.org/isinfo.php

Edit 2: Should I keep track of what edits work as expected or otherwise?
Lab Assistant
Original Poster
#17 Old 28th Jun 2009 at 6:48 PM
It would be good to know yeah. At some point I'll include a guide, and probably a friendlier interface for the more useful/popular changes.

If I really feel brave I'm considering putting in plug-in support (Torn between .NET assemblies or lua scripts there) for additional modifications people might want to code up.

Right now I'm being amused by playing a ghost family. I killed them all with the editor. Though I think they aren't behaving as ghosts normally would - the "GhostReactionBroadcast" field is empty. So they are more like a regular family that happens to look like ghosts and have spooky sounds follow them. And occasionally get a wish to visit the graveyard. (Happened to one of them within a few minutes of first loading, heh.)
Lab Assistant
#18 Old 28th Jun 2009 at 7:01 PM
Okay, I'll put in any other discoveries I make as well. I don't know what would go in the guide besides that and maybe a "DO NOT EVER" section

As far as the interface goes, I mean, it's not for everyone, but it's easy enough to get used to. The most I could really think of doing with that is creating some kind of separate interface (a popup window or something?) that does the basic, most commonly used, edits. But I also know, from a programmer's perspective, what a PITA that can be.

Haha, that's too funny - that's actually the first thing I did with the new version was play around with the ghost settings. Hmm...I need to kill a sim for real (I'll hack myself the ghost opportunity, thank god for debug mode) and see what all of those fields default to.
Lab Assistant
Original Poster
#19 Old 28th Jun 2009 at 7:11 PM
My idea for the final interface is something pretty basic unless you ask for advanced mode, then it will show you the current interface, maybe with a few little extras like a visible command history with selective undo. I'm envisioning you open a file and it shows you the family portrait and gives a menu of some sort with common activities maybe with a wizard style interface for selecting what you want to do. But that's probably more ambitious than I'll get around to doing. Except the family portrait part, that should be easy to do.
Lab Assistant
#20 Old 28th Jun 2009 at 7:22 PM
Haha that's a big step towards simplicity, but like you said, it'll probably end up being somewhere in the middle.
Lab Assistant
Original Poster
#21 Old 28th Jun 2009 at 7:30 PM
So my ghost family just had triplets(!) and the babies give the normal ghost reaction. Two of them had their father's death method (Electrocution) and one their mothers (Burned - she's a daredevil so I figured it fits)

Aaaand the save game has the end of stream error, so that should get fixed up right quick!
Test Subject
28th Jun 2009 at 7:39 PM
This message has been deleted by thetechnosim.
Lab Assistant
#22 Old 28th Jun 2009 at 7:43 PM
Haha at least they're passing it on correctly.

As far as the end of stream, do you mean saving within the game or saving it with the Editor?
Lab Assistant
Original Poster
#23 Old 28th Jun 2009 at 7:56 PM
Loading it in the editor is giving me the end of stream error. I've got the data that's confusing it isolated, just trying to figure out what the data actually means now.
Lab Assistant
#24 Old 28th Jun 2009 at 8:04 PM
Open up the corresponding [Save].Sims3.Backup - it should load it fine, and everything will still be saved (at least, that's what happened to me). You should be able to replace the original save with that and everything will work again.
Lab Assistant
Original Poster
#25 Old 28th Jun 2009 at 8:15 PM
Well I want to figure out why this doesn't work and fix it. Unless it does't load in the game, I haven't tried. I think I know what's going on, I'll fix it up when I get back.
Page 1 of 5
Back to top