Replies: 4 (Who?), Viewed: 3311 times.
Test Subject
Original Poster
#1 Old 29th Nov 2009 at 5:33 PM
Default Freezing/bugs when accessing inventory
I have an odd bug, and hopefully someone can help me figure out what to make of it.

My game freezes on menu selections that would normally access inventory. I've noticed it in a couple of places:
1. If I try to feed an omni plant, the "feed" menu option does nothing, and then the game freezes or runs extremely slowly for a couple of minutes.
2. There's an adventure in France where you place something from your inventory on a pedestal. Same problem: the "place" menu option does nothing and the game goes haywire.

So obviously it's hanging when trying to access my sim's inventory. I can sort through the inventory fine as long as it's not through one of those menu options.

I have no mods, and I am pretty sure all of my CC is EA-made. Googling found me a couple of other people with the same problem, but no solutions. In general my game has run very slowly since installing WA, but that may or may not be related.

Any guesses as to what's happening here?
Advertisement
Née whiterider
retired moderator
#2 Old 29th Nov 2009 at 5:43 PM
You need to remove all your CC, just to be sure. Does this issue reoccur with a new town?

What I lack in decorum, I make up for with an absence of tact.
Test Subject
Original Poster
#3 Old 29th Nov 2009 at 5:55 PM
Okay, I just tried it with the mods folder pulled and the same thing happens, so it's definitely not my EA store stuff.

I've had it happen with two neighborhoods and two installs. (I nuked what I had before after getting the blue lots problem.)
shiny!
retired moderator
#4 Old 29th Nov 2009 at 6:54 PM
Default MTS2 Staff Reply
In order to better solve your problem, please go through the following as listed below:
  • Sims 3 - Loading Crashes
    If your game is crashing on load, with or without an error message, or the game starts up then just disappears, then you have a loading crash.

    Please see the following FAQ and go through the steps listed in order to try fixing your game: Game_Help:Sims_3_Loading_Crasheswiki.
You need to do more than just pull your mods folder. That guide talks about how to test without cc.
Test Subject
Original Poster
#5 Old 30th Nov 2009 at 12:49 AM
I already tried the cache files, unfortunately, because I assumed it was inventory cache.

It's family inventory that's borked, I realized. Those "feed" and "place" options must call what's in family inventory as well as sim inventory. When family inventory is empty, those menu options do nothing but the game doesn't freeze, so that's helpful.

My next step would be to reinstall and not restore any of my old save games, but that's not really worth it. Thanks for the responses folks.
Back to top