Hi there! You are currently browsing as a guest. Why not create an account? Then you get less ads, can thank creators, post feedback, keep a list of your favourites, and more!
Replies: 20 (Who?), Viewed: 13018 times.
Original Poster
#1 Old 6th Jan 2010 at 10:20 PM
Default Simple TS3 CAS Texture Tutorial for MAC USERS and IDIOTS.
Okay, I know it seems kind of dumb for a person without a creator icon to make a creating tutorial, but while I may not be as experienced as some, I have uploaded content, just not to this site. C: Just getting that out of the way, in case anyone thinks this is a bit fishy.

This is a specifically for Mac users who wish to make clothing retextures, but if you are a savvy Windows user, you can still gain from this. However, if you are not a savvy windows user, I suggest you read another tutorial.

Basically, this is a more in-depth Macified version of daluved1's texture tutorial.

What This Tutorial Will Do:
-Teach you how to handle texture files on a Mac
-Give you an in-depth walk-through on how to make the different basic textures (Base, Specular, Mask) on a Mac in GIMP
-Teach you How to use Delphy's CTU on a Mac
-Teach you how to put it all together to make a tattoo (On a Mac)

What This Tutorial Will Not Do:
-Teach you how to do ANYTHING on a Windows
-Teach you how to use TSRW
-Teach you how to use Photoshop
-Teach you the basic tools of GIMP
-Teach you how to use MilkShape
-Teach you how to mesh
-Teach you how to use custom meshes and bumpmaps in CTU -Teach you custom clothing overlays and makeup
-Teach you specifics on more complicated textures for clothing and accessories
-Teach you anything about objects

I've attached the pdf and docx files, as I haven't put the tutorial in BBC format yet. If requested, I will put together a BBC version, but I thought people might prefer to download, as it's 19 pages long. (although most of that is the pics)

Info on programs you will need is included in file. C: If anyone finds any problems or errors, or has any questions, please let me know!
Attached files:
File Type: zip  Simple texture tutorial for MAC USERS and IDIOTS_docx.docx.zip (3.02 MB, 169 downloads) - View custom content
Description: docx version
File Type: zip  Simple texture tutorial for MAC USERS and IDIOTS_pdf.pdf.zip (2.97 MB, 464 downloads) - View custom content
Description: pdf version
2 users say thanks for this. (Who?)
Field Researcher
#2 Old 14th Jul 2010 at 5:01 PM
it keeps asking me to find my sims 3 root folder even though i dragged it into the thing in text edit. i can get passed this and it doesnt show me my applications folder so i can't navigate to it myself. and when i click cancel the whole thing exits. am i doing something wrong? i read over every step 3 times and i did it correctly.. at least i think.. i tried starting all over again twice
Test Subject
#3 Old 14th Jul 2010 at 5:25 PM
I'm getting the exact same issue and I haven't found a solution either. I've been trying desperately to make it work. Perhaps it's an issue with the pathOverrides.xml? Whatever it is, I'd appreciate some help
Field Researcher
#4 Old 16th Jul 2010 at 4:22 PM
=( =( i'm going to try redownloading all the files. maybe something got messed up... i shall report back for you thoppenfeld
#5 Old 16th Jul 2010 at 5:48 PM Last edited by Base1980 : 16th Jul 2010 at 5:59 PM.
Need to manualy edit that file i guess.
You find it in your CTU installation folder.
Open it with a xml editor and update it with a link to your sims 3 folder?

Here is a way to solve this:

Hey i'm using OS X, but have a Virtual Machine so that i can run Windows and inevitably, run the CTU. It runs fine until i actually want to do something, where the program asks for the root Sims 3 folder, only that's impossible because OSX's "Applications" folder isn't available through the Virtual Machine.
Does anyone else have any experience with this problem and help me out? I really dont want to copy the entire sims folder back and forth between the drop box for the virtual machine every time i want to extract a file.
Is there any way i can shorten the drop box strain by only "showing" the CTU one part of the Sims 3 package contents (i.e. the part it's looking for)? because i wouldnt mind that.

Ahh. Problem Resolved. Fixed through the Virtual Machine's shared folder options and allowed it to look in to the Applications section. Anyone using VMWare with a similar issue can PM me for the detailed answer.
Sorry for posting without exploiting all my options >.>

Looking forward to the Software, Thankyou.
Original Poster
#6 Old 17th Jul 2010 at 1:11 AM
I think I may have done that part wrong on my tutorial, if you guys followed it correctly. Can you post what your pathoverrides.xml says? I'll take a look at it, and compare it to mine.
#7 Old 17th Jul 2010 at 2:14 AM
I did had a look but the link isn't in there.
You best follow the advise giving in Delphy's CTU thread.
Add the applications folder as trusted folder to the VM, that way you can browse to your sims 3 folder.
You might need VMware for it:

Lol, im not on a mac so all wat i wrote down here i googled.
Original Poster
#8 Old 17th Jul 2010 at 5:49 AM
There should be a paragraph in the beginning that says to edit your pathoverrides.xml, or maybe it's after that. ;x I can't believe I could have forgotten it.
Test Subject
#9 Old 17th Jul 2010 at 8:00 AM
I'm not sure about iheartcowcapoos, but I did edit the pathoverrides.xml, just like the tutorial said to. I guess it just didn't work for some reason.
Here's my edited version:

thank you guys for helping
Original Poster
#10 Old 17th Jul 2010 at 8:46 AM
I just looked at it, that's not your root folder. That's a shortcut to the game, you can tell because it says "localized"

Here's an example of a path to your sims 3 root folder

/Applications/The Sims 3/The Sims 3.app/Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3

In fact, that'll probably work for you if you try it Unless you didn't install TS3 in applications.
Test Subject
#11 Old 17th Jul 2010 at 10:07 AM
Hmmmmm, I thought I had the right folder, but I guess there was some confusion there.

Well, I fixed it and tried it again and it's working! Thank you times a million!!!!! :D
Original Poster
#12 Old 17th Jul 2010 at 11:29 AM
You're welcome! Can't wait to see what you'll create, and let me know if you have any more issues
Field Researcher
#13 Old 20th Jul 2010 at 2:38 AM Last edited by iheartcowcapoos : 21st Jul 2010 at 3:19 AM.
wait i dont understand. i am not running this on a virtual machine. i have one but i dont want to have to start up windows everytime i want to use CTU. so if i replace what i have (which i think i was having the same problem as thoppenfeld) with "/Applications/The Sims 3/The Sims 3.app/Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3" it should work? what if i have ambitions? i'll still use /TheSims3 right instead of /TheSims3Ambitions?

edit: i just tried it with the "/Applications/The Sims 3/The Sims 3.app/Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3" and i still got same message asking for root folder. then i tried /The Sims 3 Ambitions
then i also tried "/Applications/The Sims 3/The Sims 3.app/Contents/Resources/transgaming/c_drive/Program Files/Electronic Arts/The Sims 3/Game/Bin/TS3.exe
it still asks me for root folder
Original Poster
#14 Old 21st Jul 2010 at 5:46 PM
Where do you have TS3 installed? If it is in your Applications folder, then that path should work for you. If not, try looking for a folder with a similar path.
Field Researcher
#15 Old 22nd Jul 2010 at 4:49 AM
it's in my applications folder. i dont know where any other path would be..?
Original Poster
#16 Old 22nd Jul 2010 at 6:10 AM
Hmm, well have you checked that path, to see if it actually is somewhere on you computer? I. e. did you go to that location? Right click on the sims 3 .app and do "show package contents" to open it without opening the game.
Field Researcher
#17 Old 22nd Jul 2010 at 3:42 PM
yes i did. i also tried doing it with ambitions too and it didnt work. should i try redownloading everything?? (by everything i mean the CTU and all it's files)
Original Poster
#18 Old 23rd Jul 2010 at 7:00 AM
I guess you could, and start fresh with the pathoverrides. Try dragging the root folder into the path overrides instead of copy+pasting the path I posted.
Field Researcher
#19 Old 23rd Jul 2010 at 11:09 PM Last edited by iheartcowcapoos : 24th Jul 2010 at 1:08 AM.
ah ha! it worked!! i redownloaded everything and tried again and now it's working hooray!! thanks for the help =D
ok so now how would i get custom content in this thing to edit and make an adult outfit work for a child? is it possible to work off of a custom content item? just for my own personal use, i'm not going to share it (obviously because it wouldnt be my own)
Original Poster
#20 Old 25th Jul 2010 at 7:48 AM Last edited by emhpb : 25th Jul 2010 at 4:54 PM.
Hmm, that requires meshing if you want to do an age conversion for a mesh. What you can do however is this:

Find a game mesh for a child that is similar to the adult mesh. (i e, the same shape, but for child)

Export the child base textures for that item, and then use them to make the adult base textures line up on the child textures. You should also do this with the mask if it has multiple recolor channels, or make it so it doesn't have multiple channels.

Import the new textures onto the child mesh.

That's really more complex than this tutorial covers however. You should really try a tattoo first, it's much easier

Edit: Oh yes, I forgot to answer your original question haha.

To open CC packages in CTU, go to file->open.

For sims3packs, you must first convert to package using Delphy's multi package converter.
Test Subject
#21 Old 21st Oct 2012 at 4:35 PM
Problem here i cant find the stupid sims 3 folder in applications all i c is my darn desktop
Back to top