Replies: 13 (Who?), Viewed: 12813 times.
Test Subject
Original Poster
#1 Old 28th Jan 2010 at 8:17 PM Last edited by DuchessAngel37 : 28th Jan 2010 at 8:20 PM. Reason: typos
Possible Bug? - Cannot Buy/Build on lot while a move is in progress.
Last night I moved one of my youngest daughters -Madalynne- and her hubby out of the house, leaving her twin sister and her family and their mother -Melissa- behind, and switched Madalynne to the active household.

Just as the new couple entered their new lot, I got the notification saying Melissa passed on. I mention this only because I've moved 10 children out of the house with no issure before, and this is the only time I'm having a problem, and it's also the only time I've had any notifications during the move.

Anyway, I waited a few sim minutes, and tried to build, and it gave me the 'cannot enter buy/build while a move is in progress'. So I said okay, and kept waiting...

Two sim days later, and the move is still in progress. Hubby's gone to work and come back. Madalynne's gone around town, but cannot visit households. They also cannot interact with each other.

The obvious answer would have been to quit without saving and try again, but I always automatically go to 'save and quit'.....and as my finger came down on the mouse button, I was like oh man.

Soooo... how do I fix this? Answer can be technical if necessary, I know my way around computers.

Malibu
Advertisement
Banned
#2 Old 28th Jan 2010 at 8:25 PM
Go to edit town and see if they can be evicted. I dont know if it severs relationships when you do so, but eviction and then manually moving them back in sounds like a good option.
Test Subject
Original Poster
#3 Old 28th Jan 2010 at 10:58 PM
I can't do anything. 'Cannot Edit Town while a move is in progress' either.

Malibu
Field Researcher
#4 Old 29th Jan 2010 at 10:42 AM
Did the game let you save even though there was alledgedly a move in progress? When I move my sims, they always have to finish moving before the game lets me save.

A possible solution: isn't the game supposed to keep a backup when it saves? You will lose some gametime, but your family would work again.
Test Subject
Original Poster
#5 Old 29th Jan 2010 at 7:02 PM
Yes, it did let me save.

And great minds think alike, Anna, I did some poking around, found the backup. I had no idea that it even did that, but I started looking at the timestamps on the save files, and I realized that the one in the backup folder was from the night before. Woohoo!

Everything is in fine working order. I had to start Madalynne's romance all over again, but it's all good. I waited until Melissa passed before I even started the move... Moved to the same empty lot, and managed to build the house!

Malibu
Test Subject
#6 Old 9th Feb 2010 at 4:21 AM
After reading all the threads I could find here, not wanting to have to restore from a backup because of some changes and not having the cell phone options available as some seemed to, I messed with various cheats for a while and finally got this bug to clear. I didn't see this solution posted elsewhere, but apologies if I missed it.

I used a combination of testingcheatsEnabled true and the Master Computer mod. Of course make sure you save a backup copy of your town in the loading screen and backup your game overall.

1. Make active a Sim that did NOT move in during the stuck move.

2. Shift-click the Sim that DID move in and select Object...Delete it. Check that the bug has cleared (selecting the cell phone and seeing if Travel and Move options are still grayed out, for example). If you moved in multiple Sims and the bug has not cleared when you delete one, exit without saving, return and try again with another one. For me it was only one of the two moving in that was bugged.

3. Now click the active Sim, go to Master Computer...Household...Add Sim...and select 'Type of Sim'. From there select the type 'Dead'. Find the Sim you just deleted, add it, and your household should be unstuck with the new Sim in place.

I tried resetting Sims, lots, even the whole town, and moving people around households and re-adding them, all sorts of steps, and this was the only path which worked. So here it is as an alternative to the backup option for those who wish to avoid that.
Test Subject
#7 Old 26th Feb 2010 at 6:18 AM
Thank you, thank you, thank you!
Test Subject
#8 Old 25th Apr 2010 at 10:07 PM
I have the same problem, but do not have/can not find the master computer Mod, any idea where to get it or what I should do.

I can delete the sim causing the problem, but can not get them back again.

Any help appreciated.
Inventor
#9 Old 26th Apr 2010 at 2:29 PM
Test Subject
#10 Old 27th Apr 2010 at 8:45 AM
Thanks, I got the Mod to work, but when I brought my sim back from the dead via the master computer, he would not interact with anyone except to be mean and woo hoo, is that normal.
Scholar
#11 Old 27th Apr 2010 at 5:39 PM
Have you tried to use AwesomeMod to reset the sim?
Test Subject
#12 Old 1st May 2010 at 6:03 PM
How do I load from the backup file?
Test Subject
#13 Old 13th May 2010 at 7:07 PM
I ended up just getting annoyed with it and deleted him, so its like he died.
Field Researcher
#14 Old 13th May 2010 at 11:44 PM
This happen to me the other day I ended up having to kill of the family at least I wasn't attached to them.Its best if you wanna move a family just go to edit town and forget the move option on the lot.
Back to top