Replies: 5 (Who?), Viewed: 2960 times.
Test Subject
Original Poster
#1 Old 12th Feb 2010 at 12:39 AM

This user has the following games installed:

Sims 3, Late Night
Default Feeding omni plant doesnt work and lags the game
Hello,
I've been enjoying TS2 for some time (didn't get to try omni plants before the WA tho) with no problems. But once I installed WA and patched it to 2.3.3 (haven't tried it without the patch) and also got theos Johna_Sliders_... I get weird lags after I try to feed omni plant.
I click omni plant, click on option Feed and nothing happens - but in a few secs games starts to have weird input lags and gets unplayable. I have noticed the behavior only once before (after the WA installation) when I was in library with my sim reading some book, but even tho I have been in library a lot since then it haven't been repeated.
But the omni plant problem is there every time I try to feed it.

It's probably worth mentioning I don't use any other mod except those sliders.

I now have current version of the game and also High-end loft stuff. Problem persists.

What I tried to do about it was:
- I removed file SlidersHack since I read somewhere it may cause errors.
- I also tried Sims3Dashboard, it found nothing
- I tried Procmon with that filter, which I had to fix a little so it also checks TS3SP01.exe process, but I failed to see anything extreme in the results.

I really don't know what is this all about. I'd love to see how that feeding actually works.

Ty for any help.
Advertisement
Mad Poster
#2 Old 12th Feb 2010 at 2:59 AM
Are you absolutely sure you have removed all Custom Content? You may want to check out the FAQ's - Game Help:TS3 Custom Content. Making sure all custom content is out of your game, will eliminate the possibility of broken or corrupted content. If you don't experience the problem with all content removed, then it is likely due to one or more of your custom content(s).
transmogrified
retired moderator
#3 Old 12th Feb 2010 at 3:11 AM
Just to rule out normal game behavior: how full is the inventory of the Sim you are directing to feed the plant?
Test Subject
Original Poster
#4 Old 12th Feb 2010 at 3:46 AM
Im pretty sure I removed it all and my inventory contains like 50 different items.
When I click on the Feed it makes the sound, but nothing else happens. Guess I'll have to reinstall the game completely.
transmogrified
retired moderator
#5 Old 12th Feb 2010 at 4:00 AM
If the inventory contains multiples of those 50 items, and most/all of the items are feedable, the game is simply creating the list. Before going to the bother of a reinstall, try pausing the game, then press feed, then wait at least 3 minutes for the list to populate (without clicking on anything else).

The other alternative would be to clear out the Sim's inventory, leaving only a very few items (fewer than 10 items, with fewer than 10 of each item), then press feed. If the game still lags, then yes, you have a game problem.
Test Subject
Original Poster
#6 Old 12th Feb 2010 at 11:52 AM
mangaroo thanks, you are right, it helped. I' having hard time understanding why it takes so long though, seems like bug to me. Every time I open the Feed menu it takes like 2 mins to load, isn't there some mod for it from someone who can actually code non-exponential-time algorithm for reading collections? :D
Back to top