Replies: 16 (Who?), Viewed: 6025 times.
Lab Assistant
Original Poster
#1 Old 19th Jul 2010 at 5:02 PM
Default How to apply glasses lens material to a completely new accessory mesh?

I'm trying to create a new accessory using the lenses from a glasses mesh. I first created a simple shape, a sphere or a box, assigned bones, regrouped it with the lens group in milkshape (with the glasses frame untouched), copied original comments and renamed. Imported it into my package using TSRW. I was excited to see that it actually showed up on the model, but I should have known it would'nt work out that smoothly because once I loaded the game, I saw that the lens had disappeared. Completely unrecognized by the game.

Try #2: This time, I only moved the vertices on the original lenses without adding a new mesh. This worked fine and it showed up in-game, but I want to create a whole new mesh instead of moving the vertices around.

Try #3: Next, I duplicated that same lens group, moved the copy away from the original a bit, regrouped, copied comments, imported into package. I load up the game and immediately, before I even applied the accessory, I see that my sim has dark ash gray skin. This goes away when I remove the package. Not sure what happened there.

My question: How can I apply the glasses lens material to a completely new accessory mesh?

And while I'm here, I was wondering if it's possible to add morphs to an accessory. I tested this out myself by resizing a bracelet and a pair of pearl earrings, than applying them to a fat morph and imported them using the MorphMaker. In both cases, the sim's face just became distorted as I increased the fat slider and the accessory was unchanged. I guess morphs are only able to target the body shape (?) ... but I gave it a try anyway.

Any help is greatly appreciated. Thanks.
#2 Old 19th Jul 2010 at 5:17 PM
You can use the glasses material as long its a head accesoire because the material settings are related to the glasses joint.
So you need to give your custom accesoire glass bone assignements in order for it to show up.

TSRW however has the option to edit the material settings, located at the mesh tab.
Lookup the glasses material settings and maybe you can choose the same settings on a bodyaccesoire(if your making one)

Both CTU and TSRW support morphs BGEO files.
I have made accesoires(that slide along with the difrent morph shapes when using the sliders) with both programs.
Lab Assistant
Original Poster
#3 Old 19th Jul 2010 at 9:51 PM
Thank you for replying Base.

I forgot to mention that it was in CTU that I first tried to assign the lens material to a new mesh by grouping and copying the comments in Milkshape. Although the comments were automatically copied over once I regrouped. In TSRW, all I did was assigns bones to the new mesh, regroup it with the original lens and renamed it.

Anyhow, with both programs, I get the same results. I make sure that I assign the new mesh to "b_glasses_", which is the what the lens is assigned to and I've also tried assigning it to "b_headnew_". When I open my package in either CTU or TSRW, it shows exactly the way it was meshed but in-game, only the frame is visible. I'm not sure what I'm doing wrong.
#4 Old 19th Jul 2010 at 10:50 PM
I have tested these settings like so many times i cant remember.
Seems even the vertices numbering needs to match.
Its been a while and thinking back i only could get the transparancy when i cloned the beard, think i also failed on the glasses.

Cloning the fullbeard will give you the transparancy but you cant set it to a accesoire as it will lose all settings(recoloring)
Ill have some sims 2 glasses i want to convert, ill give it a try.
Lab Assistant
Original Poster
#5 Old 19th Jul 2010 at 11:44 PM
Well, I tried something new. With TSRW, I exported the glasses mesh and in Milkshape I deleted one vertex from each lens leaving a square opening in the middle of both. Opened up the game, and they showed up just fine. I can edit and apparently delete the existing vertices, but as soon as I add my own shape, I get no results. Hmmm... I'll just keep trying.

You mentioned that you were able to create accessories morphs that moves with the sliders. Did you mean that your accessory placement moves with the shape of the sim's body? Unrelated to the glasses accessory, I was thinking about creating a belt that contracts and expands to fit sims of various sizes. I followed the same steps used in CmarNYC's tutorial on adding pregnant morphs, but as I mentioned above, the accessory doesn't move with the slider, only the head gets distorted. I'm thinking that accessory morphs involve re-positioning in relation to the body rather than re-sizing.

I really appreciate your input.
#6 Old 20th Jul 2010 at 1:44 AM Last edited by Base1980 : 20th Jul 2010 at 3:24 AM.
its a alot of work with CTU, you better use TSRW for it.
When you clone a accesoire with it and export the meshes to edit them it will automaticly generate the morphs.
You replace the base mesh with your belt, duplicate it 4 times and make morphs out of the duplicates.
then import everything back into TSRW.
Done it with CTU(adults parts for both male and female on adult site)
And here with TSRW:
Big accesoires have a nasty thing when more as one are used, they lose texture quality as you can read...

Made a quick sims 2 glasses conversion, made a few mistakes(unassigned or wrong bones) but the transparancy works.
Used TSRW 2.0(latest)
#7 Old 22nd Jul 2010 at 4:42 AM
there are a few things wrong when trying to create the glasses tho.
Cloned the aviator glasses but i lose the cool reflection and only the glasses bones are supported, cant use any other bones.
Thought i let you know
Lab Assistant
Original Poster
#8 Old 22nd Jul 2010 at 7:28 AM
Okay, I finally got around to messing with this lens accessory again and I keep getting the same results no matter what I do. The difference this time is that I got a better look at the accessory on a lot and out of CAS, unlike before when I'd view it in CAS and then close it out.

I made a sphere, for testing purposes, assigned it to a bone, and renamed the group. It turns out the mesh assigned to the lens material does show up in-game . . . about 5 feet to the left of the sim and level to the ground. I've tried assigning it to different bones, particularly the ones that glasses are assigned to. No luck.

I'm not really sure where to go from here, but maybe I can just try my best to reshape the original lens since it seems impossible to create a whole new shape that didn't come from the game.

Oh, and I read your response to another user regarding importing accessory morphs into TSRW. I got the same message stating that too many groups were imported. I'll try out your method and work on that some more later.
#9 Old 22nd Jul 2010 at 12:31 PM
strange, wich accesoire did you clone?
I cloned the female avaiator and have all the bones set to 100% glasses and the 4th bone to the right ear(without any weight)
But i lose the cool reflection you still seem to have.
Lab Assistant
Original Poster
#10 Old 22nd Jul 2010 at 2:15 PM
I have tried the aviators, oversized, half-rim, nerdy, I tried assigning bones 100% to "b__HeadNew__", "b__Glasses__", with and without the 4th bone assignment, I've tried planes, spheres, boxes ... It's seems like it would be pretty easy to just replace the mesh, assign it, rename the group, and re-import it, but it never shows up correctly.

I've only gotten my custom lens mesh to show up in-game and with correct placement once and that was because I had cloned different glasses and replaced it with the same .wso I used for another pair. It turns out that in the new pair of glasses that I cloned, the group order was backwards (group_0 for lens, group_1 for the frame) and I had replaced it with a mesh where the "group_1" was the lens and "group_0" was the frame. So the lens was assigned to the solid frame material and had no transparency ... but somehow the glasses frames mesh (which were cloned from a different pair) showed up. A completely different glasses mesh assigned to a new cloned pair will show up, but a completely new shape just floats on the ground.
#11 Old 22nd Jul 2010 at 3:00 PM
The glasses are from sims 2, new shapes and show up correctly.
I did notice that with most glasses the group0 is the frame and group1 are the lenses, exept with the aviator
Ill try the sphere test and see wat it does
#12 Old 22nd Jul 2010 at 3:51 PM Last edited by Base1980 : 22nd Jul 2010 at 4:06 PM.
Lol, i must have done something wrong that made my glasses work......
I did the sphere test by cloning the female aviator glasses and assigned half of it to the frame, the other halve to the lenses.
The frame shows up correctly above the head while the lenses are on the floor in the background.
Now the guy on the right also wears a female aviator glasses clone and that one shows up fine(except that it misses the reflection)

I do know that some material settings are related to the skeleton and the bones so i prolly have switched the skeleton(by accident) wich positioned the lenses on the correct spot but killed the reflection settings.
In TSRW you have the option to adjust the joints, in your case you need to rotate the glasses joint to bring it back in its original position.
Go to the mesh tab, pick your mesh/bones/transformation and experiment with the rotation.
Its prolly caused by the WSO importer/exporter and looking at the screenshot its 90 degrees on 2 axis.

hmm, TSRW chrashed when i try to rotate the joints
#13 Old 22nd Jul 2010 at 6:10 PM
Originally Posted by Base1980
In TSRW you have the option to adjust the joints, in your case you need to rotate the glasses joint to bring it back in its original position.
Go to the mesh tab, pick your mesh/bones/transformation and experiment with the rotation.
Its prolly caused by the WSO importer/exporter and looking at the screenshot its 90 degrees on 2 axis.

thats not going to work.......Altho you have the option, it doesn't work.

I am still puzzled how i got the lenses from the glasses right.
Lab Assistant
Original Poster
#14 Old 22nd Jul 2010 at 7:22 PM
Well, at least I know I'm not the only person to encounter this problem, haha. At this point, I'd be happy to find a way to make my mesh translucent/semi-transparent by any other means, which might be best for what I'm going for anyway because I want the option to add an overlay, stencil, or texture to the mesh and I don't believe I would be able to do so with the glasses lens material. I'm going to dig around in some other threads for a bit and see what I can accomplish.
#15 Old 22nd Jul 2010 at 8:15 PM
All those things you can do with the glasses accesoire tho.
Its all in the materials tab within the mesh tab, you can add, delete or update the texture files in there.
To make the lenses recolorble i replaced the link to the alpha texture with one to a custom mask texture.
Both meshes(frame and lenses) are linked to the same uvmap and use the same texture file so a overlay or stencil should be possible too.
I also experimenting with this so i cant explain yet on how it all works but if i know more ill post.
Lab Assistant
Original Poster
#16 Old 27th Jul 2010 at 8:02 PM
Hi. I'm able to make lenses recolorable in the texture tab, but is there any difference in enabling tinted lenses in the Mesh tab vs the Texture tab? I've noticed that when I replace the lenses with the orb looking ball, the ball isn't recolorable. It keeps that shiny silvery color. But when I clone any of the game glasses without making any changes to the mesh, I am able to tint the lenses pretty well in-game.
#17 Old 27th Jul 2010 at 11:43 PM
That shiny reflection has its own unique material settings, as far as i know its only used on the aviator and not linked to the recolor files.
Back to top