Replies: 13 (Who?), Viewed: 11029 times.
Test Subject
Original Poster
#1 Old 5th Apr 2011 at 6:48 PM
Default Common Uninstall Problem - Solutions Not Working!
I'm very frustrated. I downloaded the Sims2Pack Clean Installer so that I could start sharing some of the things I've created for the game & according to the Creator Guidelines, "Before uploading your lot, you MUST scan it with Clean Installer."

So I downloaded/installed the program and found that none of my PackagedLots were showing up. I decided to uninstall it, but it left files all over my computer. I deleted everything associated with the program from:

-Start (All Programs)
-Computer/OS/ProgramFiles (x86)

I've ran a System Cleaner to try to rid my computer of any other files that may have been left behind.

I also searched through all the Folders/Files for "sims2pack clean installer".

Now I'm trying to reinstall the program, but the error message says I still have an older version on my computer. When it asks if I want to uninstall it, I choose yes, and a uninstall.exe file appears in my Temp Folder. I choose that, but it comes up as there is no program available to run the file.

I'm using Windows 7.
I AM the Administrator for my PC.
The version of Sims2Pack Clean Installer that I'm trying to install/uninstall is the most recent.

If anyone can help it would be appreciated. I have never had this much trouble and I do not want to have to do a System Restore to get the files off my computer once and for all.
Site Helper
#2 Old 5th Apr 2011 at 7:12 PM Last edited by Mootilda : 5th Apr 2011 at 8:00 PM.
I'm sorry that you are feeling frustrated.

The Clean Installer only installs things into the installation directory and the registry. If it installed anything in any other location, please give me the full path so that I can fix it. Of course, I am not talking about the need to add shortcuts to your start menu and desktop, which every program does so that you can find the program in order to run it.

Most problems associated with uninstalling are because of the "Install all" capability. As long as an explorer window is open, the S2PCI executable is locked and cannot be removed.

Did the Clean Installer tell you that it needed to reboot your computer to complete the uninstall process? Did you reboot before attempting to remove any additional registry entries?

Did you install into the Program Files folder? I wonder whether Windows 7 is refusing to remove things because of UAC (user access control). Have you tried turning off UAC while you do the cleanup?

You could try searching your registry for each of "Sims2Pack", "Clean Installer", "S2PCI", and "S2PCISE" individually, although you'll want to be a bit careful about removing entries for "Sims2Pack" which aren't actually related to the clean installer. Also, the spaces are important: you should be checking for "Sims2Pack Clean Installer". Are you searching all of Keys, Values, and Data? Are you searching for partial strings, rather than full strings only?

Originally Posted by enviousxbeauty
none of my PackagedLots were showing up.
Did you read the manual at ? This is a program which is used successfully by lots and lots of people; if you require help learning how to use the program, I'm sure that there's someone here who can help.

And, yes, I do understand that you may have decided that you never want to use it. However, if you do decide to try again, we'll be happy to help you to figure things out. Perhaps you would be more comfortable with the no-install version? Unfortunately, it requires you to add the file associations yourself.
Test Subject
Original Poster
#3 Old 5th Apr 2011 at 8:21 PM
Well, I restarted my computer before, but the uninstall process hadn't asked me to.

After your reply, I Disabled User Access Control (w/restart), performed a quick scan/clean, then ran a system search for Sims2Pack Clean Installer, Sims2PackInstaller, S2PCISE, and S2PCI. Four files were found in C:\Windows\Prefetch.


After I deleted them, I preformed another clean (all windows closed) and restarted my computer. I once again tried to install the program, but the error message hasn't changed.


I usually don't have problems using programs associated with Lots, Packages, or Downloads, but I will have a look to make sure I'm doing things right!

If I am able to finally get the program uninstalled, I think I will try the manual download. I feel a little better doing things by hand.


Just to let you know, I do appreciate all your help. Thanks for being patient and doing what you can!
Site Helper
#4 Old 5th Apr 2011 at 8:32 PM
If the Clean Installer uninstall process didn't ask you to reboot, then the problem is not the locking of the S2PCISE executable.

I'm afraid that I can't think of anything else to try, other than a system restore. I'm not that familiar with Windows 7. Hopefully, someone with more knowledge of that platform will have some other ideas.

You should be able to try the no-install version even if the previous uninstall failed. At the very least, it can't make things worse, since it doesn't modify the registry. Do you know how to add a file association for Sims2Pack files?

Perhaps I should take another look at the install process and see whether there's some way to force an install even if the previous uninstall failed. I could also look into adding an "option" screen to the install process, so that people could decide whether they want a desktop shortcut, a start menu shortcut, or the "install all" ability.
Test Subject
Original Poster
#5 Old 5th Apr 2011 at 8:50 PM
I downloaded the files manually and am now able to access the program! Thank you for your help.

I think automatically overwriting a previous install would be a good idea, especially if a lot of people have trouble with the uninstall. Things like that are pretty trial-and-error though, I suppose. I'm sure you'll eventually find the way that works best for the majority.

Take care, and thanks again!
Test Subject
Original Poster
#6 Old 5th Apr 2011 at 9:54 PM Last edited by enviousxbeauty : 5th Apr 2011 at 10:53 PM.
Good News! I did end up finding a way to remove all files from the first download. I used a program called "Revo Uninstaller Pro". I just selected the main file and it found everything and let me delete it all so I could go ahead and download the automatic file if I wanted. I just wanted to share in case anyone else was having this problem!
Site Helper
#7 Old 6th Apr 2011 at 12:04 AM
I wish that I knew exactly what file or registry entry was causing the problem... I don't suppose that Revo gave you a report?
Test Subject
Original Poster
#8 Old 6th Apr 2011 at 1:23 AM
I'm afraid it didn't. What it does is bring up all the files that are associated with the program and lets you select what you want to delete. Once it's deleted it doesn't show what files were there or if any were corrupt.
Test Subject
#9 Old 25th Apr 2013 at 10:42 PM
Very helpful, please do not delete this thread. I am having problem with my packaged lot too, and am trying to figure out what's wrong, I might have to uninstall the Clean Installer to verify something.
Site Helper
#10 Old 26th Apr 2013 at 12:11 AM
What problem are you having? It's very easy to see where your lots are being installed, since the Clean Installer tells you before installing.
Test Subject
#11 Old 10th Sep 2013 at 10:48 PM
i need help i need to uninstall and install the new versions of the sims 2 pack installer but im trying to unistall it but i use this this on my laptop that removes viruses its called Spybot - Search & Destroy i used it and i think it removed it and im trying to find it but i cant find it any where plz help!
Site Helper
#12 Old 11th Sep 2013 at 2:18 AM
What happens when you try to install a new version? Do you get an error message?
Test Subject
#13 Old 4th Jul 2014 at 8:27 PM
Originally Posted by enviousxbeauty
I downloaded the files manually and am now able to access the program! !
Please Explain how you did that! I have tried everything, and I messed up the last chance I had by doing the Registry wrong. :/ It would mean a lot if someone could help me
Site Helper
#14 Old 5th Jul 2014 at 3:11 PM
Download the no-install version and unzip it to your hard drive. Then, run the EXE from that location.
Back to top