Replies: 14 (Who?), Viewed: 11710 times.
Test Subject
Original Poster
#1 Old 21st Aug 2011 at 5:02 AM
Default Possible lead on the Hot Springs Lag Problem...
Ladies and Gentlemen...

I've been basically ignoring the lag that shows up in China between 10 PM and 6 AM, hoping that, somehow, my machine would eventually power through it. Of course, like may of you, it hasn't. I've tried the re-routed maps for China and, naturally, the Overwatch Mod, in addition to cleaning out a lot of other mods that I like, but didnt really NEED per-se.

None of this assisted.

Now, I've read in a few threads that this is caused by Sims getting stuck at the Hot Springs. I've looked around the stairs, as has been suggested, but no luck in finding a stuck Sim. However, when my wife was playing a night or so ago, something interesting happened. The door at the top of the lot (near the Dive Well for the Adventure portion) would not allow her passage... almost like it was locked by some Park Ranger at sunset.

In fact, it didnt allow her to leave until... shockingly... about 6 the next day.

This fits in with all the other threads thinking that it's caused by a routing problem - specifically, a door they cant go through. I thought the easy solution would be to go into the lot, remove the door itself, and replace it with a archway. But, of course, that's too easy. When attempting to do this, I have to somehow unlock the lot for editing.

I've tried every cheat code that looked even halfway promising, and havent been able to do so. Therefor, I turn to you, ladies and gentlemen... what set of codes have I somehow missed that will allow me to make this miniscule change that could well be the thing that cures the lag?

I eagerly await a reply.
#2 Old 21st Aug 2011 at 1:48 PM
enablelotlocking true (I know, you'd think it would be false but it isn't) will unlock the lot for editing. Haven't done it in a while but I think you also need to click on the "lock' icon for the lot once you activate the cheat. Perhaps someone else can confirm this.
#3 Old 21st Aug 2011 at 4:00 PM
Try the WA Routing fixes by Ellacharmed . I have been using them in game and have had no routing problems and hence very little lag in the towns that she has done routing repairs for so far including Shang Simpla, Al Simarah, Champs Le Sims, Sunset Valley and Bridgeport . They essentially fix the broken routing so that Sims no longer get stuck and it works pretty well.
Department of Post-Mortem Communications
#4 Old 21st Aug 2011 at 5:42 PM
You won't need to unlock the lot necessarily, just shift-click on the ground with testingcheatsenabled and choose Buy or Build On This Lot.

But your observation is quite interesting. So, you're basically saying that the Hot Springs lot closes like a LN venue between 10 pm and 6 am. This would explain a few things, namely that the half-hour freeze started with LN and also why it is for most people only China. IIRC correctly the Hidden Springs lot is possibly the only tomb lot where one would have to go *through* a building in order to go somewhere else, all other tombs in the vacation worlds are at the end of a route.
But why 10pm until 6 pm? there are no LN venues that close at 10 pm and re-open at 6 in the morning. The only thing that I can think of that is in accordance with this time frame are the work hours for paparazzi.They drop their role, I think, at 10 and take it up again at 6.

Edit: Also I think that the Hidden Springs lot is the only tomb that is tagged as a park. But do parks have closing times?
Test Subject
Original Poster
#5 Old 23rd Aug 2011 at 3:24 AM
I'll give these other attempted route fixes a try. I cant recall which set I used the first time, but anything is worth trying at this point.

As to why it would be between 10 and 6, I have no real idea either. It just may be that there is a sim trying to get home at that point. May have nothing to do with the LN vvenue times... or perhpas theres an odd bit of code hanging around that they were considering adding in for Parks, but eventually didnt, and for some reason, it didn't go completely away for the Hot Springs. I'll see what happens with the door fix first ( my trial solution) and then see what happenes with this other set of fixes if that doesnt take care of it.

Thanks for the input all.
Test Subject
Original Poster
#6 Old 23rd Aug 2011 at 4:38 AM

1) Those routing fixes are the same ones I already have installed for the WA locations. So that, alone, will not solve the issue.
2) I thought about it a bit, Babele, and the 10 to 7 timeframe makes a lot of sense for reasons other than LN. Think about this - when you are in China (or any other world for that matter), at what time do all the NPC sims go home at night? DId you say... TEN?! Why yes, yes you did. My best guess is that the NPCs are trying to route home through a door that locks itself for some reason. *shrug* Not sure why.

3) And now for some actual experimental results. Using the LockingLotsEnabled cheat (thanks for explaining the correct usage, BTW), I removed the door and put in two archways of the same style as the other side of that same building. This was done in a save game using a single sim who was "fresh off the bus", shall we say, and exclusively for testing. On my system, I typically hit lag even on that first night, though it gets progressively worse. I figured this would be a good baseline test.

So, with that done, I did the first few adventures. I spent the night exploring the Dragon Caves.... and...


You read that right. Not ONE. I tried not to get excited (flukes happen...) so I waited for a second night, and this time spent it picking up Jade by walking/cycling all over the map. Aside from small stutters while the game caught up it's graphics (which is normal), the same results. NOT ONE SIGNIFICANT STUTTER.

As I speak, my wife has loaded up her own save, which is chronically plagued with the problem. Assuming all goes well, I suggest that you all try this solution yourself and see if you get the same results. At that point, if it is truly the solution, the next step would be to figure out how to make this change inherant to a mod such that you dont have to make the change each time you start a new game. I'm not a modder for this game, so I dont have idea how that would be done, but I'm sure it's possible.

So - for the moment, I am very optimistic about this. Further news when a few nights have passed in her game.
Test Subject
Original Poster
#7 Old 23rd Aug 2011 at 4:53 AM
And Busted.

Soon as it hit 10:01, we hit the lag wall. *shakes head* It's better than it was before, which is good, so now I begin to wonder if that particular door is used elsewhere in the game map (And I'm sure it is). If it does, than maybe it is self-locking all over the map, and it's several door routing problems? I'd look into that, but I may be away from home for some time soon... it may be a direction for everyone to look though.

Also interesting to note is that, previous to this attempted fix, the lag would be sproadic. Sometimes it would be every 15 sim minutes, sometimes 5, sometimes 30. Now, it's like clockwork every 30 minutes, so, as I said, a big improvement.

Sorry if I got your hopes up guys. It was looking real good there for a while. Unless you have any last minute suggestions that I could try in conjunction with what I have, I think this one just died on me.
Department of Post-Mortem Communications
#8 Old 24th Aug 2011 at 9:18 AM
I think, it has always been kind of obvious that these freezes are caused by some stuck explorer or Chinese local on the map, trying to go home, or rather leave their current location.
Also, if you get it every 30 minutes this only means that it is just one Sim that is stuck. If you get it twice within a half-hour frame it means that there are two Sims stuck.
Every stuck Sim will produce a freeze in 30-minute intervals.
So, the going home part is not really part of the question. The question, as I see it, is why do Sims get stuck in the area around the Hot Springs lot and why mostly only during the night?
I think one of the ways to find out whether your replacing the doors really made a difference is to use AwesomeMod, type "radar all" into the console while in China and observe Sim movements over the course of several days.
Also, in my experience, these freezes are more prone to happen in later stages of the game, maybe only after my own Sims have been in that area for the first time.
Test Subject
#9 Old 24th Aug 2011 at 6:48 PM
My freezes happen even if I don't visit the lots and begin on the second night of the trip, forst visit time. I have tried resetting the lots with the master controller and resetting the stuck Sims also. It fixes for a bit, then I noticed the reset Sim transports back to the stuck spot and the lag continues. I have also had the lag when no one was on the hot springs lot, and searching all lots there is no stuck Sims. Finally found a Sim stuck in the dragon cave, behind the first door. When I sent my Sim to open the door, the other Sim just stayed there....for the rest of my Sim's time in China. I thought about resetting that Sim, but decided to see how long they would stay. I left China and said Sim was still standing there, whining about a blocked path.
Mad Poster
#10 Old 25th Aug 2011 at 2:52 AM
I started having lag in Shang Simla at night like what's been described, the game clock freezing approximately every half hour. I didn't know about the stuck sims problem, so for lack of some other solution, I thought it might be a mod conflict. I took out the no-memories mod, thinking it might be conflicting with MasterController, went back into the Shang Simla game and the lagging stopped, at least for that vacation.
Just thought I'd mention this even if it isn't applicable.
Lab Assistant
#11 Old 4th Sep 2011 at 10:09 AM
I was having the same issue in Shang Simla and edited the Hot Springs lot, which partially resolved the issue. Children for some reason will still get stuck in that lot. They will stay at the base of the stairs by the pool and you can see the "no-route" balloon. I have to manually reset them.

However, when I return to the base world (which is a user-made world: Longview) the game will crash. I have tried the usual, like having having the base game and all EP's set on DEP, but still it will crash.

I tried editing Egypt in order to add a LN club as well, and the same happens when I return to the base world.

In order words, I cannot edit World Adventures worlds without causing the game to crash.

Any ideas on what could be causing this crash?
Test Subject
#12 Old 16th Sep 2011 at 3:51 PM
I think I cracked it... And I only had this problem since last night... And because I googled and found this thread, finding out that the issue has something to do with the hot springs, I only thought it would be fair to share this.

I found the problem not at the hot springs, but "next door" at the dragon springs. There where 3 explorers walking around and I noticed they where all showing that "no route" bouble at a certain point. So I Shift+Ctrl clicked them and deleted the suckers. Now it seems to work fine...
Test Subject
#13 Old 18th Sep 2011 at 12:02 AM
I also had this problem with both of those lots. I reset the explorer sims involved and so far so good. Also I have now installed the routing fixes by Ellacharmed
Test Subject
#14 Old 8th Oct 2011 at 11:01 AM
This is a temporary fix. Type "resetsim *" on your console. "*" instead of specifying a name will reset all, thereby un-"stuck"ing any sim in your sub-neighborhood. You'll experience the freezes when some sim (playable or not) gets stuck again.
#15 Old 23rd Nov 2011 at 6:12 PM
Originally Posted by iamdgr8
This is a temporary fix. Type "resetsim *" on your console. "*" instead of specifying a name will reset all, thereby un-"stuck"ing any sim in your sub-neighborhood. You'll experience the freezes when some sim (playable or not) gets stuck again.

Thank you thank you thank you, I have had this problem since the Pets trial and it worked. I still have a long delay for the mouse to work but the stuck sims has been resolved. I tried Master Controller and that worked for a bit and then didnt. I have tried resetting individual Sims and that worked for a bit and then got stuck again, but this resolved the issue.

Some people have a Guardian Angel, you know a little guy sitting on your shoulder that tells you right from wrong, but mine is an Idiot.
Back to top