Replies: 1 (Who?), Viewed: 8400 times.
In the Arena
retired moderator
Original Poster
#1 Old 27th Oct 2011 at 5:15 PM Last edited by ellacharm3d : 3rd Dec 2011 at 3:18 PM. Reason: corrected IMG links

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life, Island Paradise, Into the Future
Default Do your Sims3Packs disappear, and/or is Sims 3 forever CRASHING when loading?
  1. Do you often get this error?
  2. Does doing what the dialog box say - ie restarting the game NOT help at all in ALL instances?
  3. Is your Save not useable ever again, and you throw it out to start over?
  4. No other suggestions in the WWW were able to help?
  5. Was this error preceded by a crash? The "Sims 3 has stopped working..." one.
  6. Subsequently, after clicking the button, and loading the game the next time, did your Sims3Pack CC go missing? Upon loading you get the "Missing Object Warning!" and you get blank icons where your Sims3Pack content once were?

If you answered YES to all the above, try this!

I have this Game_Help:TS3_Load_Issues#A_Serious_Error_has_occurred_errorwiki FAQ to help with it, but there's actually one step I usually do that was not documented, and it has worked most of the time. Enough so that I don't think it is a fluke anymore. But I need confirmation from all of you.

If it is a universal solution that works for everyone in all instances, I can then include it. The reason I'm hesitating is because it involves using a 3rd-party utility - Unlocker - and some folks would rather not use any external tools. If you want to help corroborate the findings below, then download and install the tool. Restart the PC. You should then get a context menu when you right-click on a file or folder.

After 2 days of purposefully putting in outdated & incompatible mods and broken CC in my game, I've been able to get the following sequence about a few times out of an insane amount of times repeatedly reloading Saves to prove/disprove the theory. I'm still not happy with the odds, so I'm not sure if it is a fluke or not.

For the "A Serious Error has occurred" issue
  1. Get the crash and the error "Sims 3 has stopped working. Windows is ..."
  2. Clicking Close/Cancel, and checked "CurrentGame.sims3" folder and contents are not cleared as they should be after game executable is no longer running.
  3. Next load of the game, getting the "A serious error has occurred ..." error. But don't click the "Check Mark" button.
  4. Instead, Alt+Tab to the "Electronic Arts" folder under "Documents", right-click "The Sims 3" folder and click on "Unlocker" from the context menu.
  5. You'll get a list of all files that are in use, just click the "Unlock All" button.
  6. When it's done, Alt+Tab back to the game, and now you can click the "Check Mark" button.
  7. Select the Save that was giving the error earlier.

In some cases, the above issue is accompanied by the below issue, so proceed on with the steps. Other times they happened separately, so I've treated them as separate issues for now.

For the disappearing Sims3Pack content issue
  1. Get the "Missing Object Warning!" dialog upon loading the game.
  2. Instead of a catalog like this (I've blurred the icons so as to not endorse any particular CC or offend any Creator showing any broken stuff unintentionally)
  3. you get this, (ignore the fact it is not the Beds catalog, I snapped the wrong time, but it all looks similarly blank like that)
  4. Do not do anything else except these steps.
  5. QUIT the game! Don't save, don't try to change out the missing items to default items.
  6. Do the steps suggested in Game Help:GCCTSU3 Redo/DCCachewiki

Do these steps the next time you get the "A Serious error" message or your Sims3Pack content disappeared, and report back with status. Whether it works or don't work, and what happens...
Advertisement
In the Arena
retired moderator
Original Poster
Back to top