Replies: 17 (Who?), Viewed: 7543 times.
Test Subject
Original Poster
#1 Old 12th Jun 2012 at 3:24 AM
Terrain Tears Before I Even Begin :/ for why???
so i scrapped and started again for the 8millionth time.

all i've done so far is lower the land mass and flatten it so the world's not hovering above sea level the way it defaults when you open a flat map.

then i labeled the map n, e, s, w so i know where the sun's rising/setting etc.

i zoomed out to start bringing up the mountains/hills and there's all these spotted white lines streaming down the length of my damn map. as far as i know these are "tears" normally caused by roads/lots. i haven't done a thing to the map yet and it's full of them. WTF? lol

help anyone? am i right in identifying these as "tears" or have i managed to dig up an other problem? any thoughts would be most welcome!

edit: it would help if i uploaded a picture of what i'm blithering about wouldn't it?
Lab Assistant
#2 Old 12th Jun 2012 at 5:25 AM
That is normal and not harmful. It might be that the grass is being rendered with different zoom levels where the line appears; not entirely sure. But you can build without worrying about anything exploding. Anything more than usual, anyway.
Test Subject
Original Poster
#3 Old 16th Jun 2012 at 2:20 PM
thank you kindly for your response! i never even thought i could be overreacting fancy that. heh. i'm glad it's nothing to loose my hat over then. they don't ever seem to go away though which is sad. i actually trashed my last world because of it. thought it was "lot/road tears".
dodgy builder
#4 Old 18th Jun 2012 at 11:06 AM
Can't you just recolor them?
The Camera Eye
retired moderator
#5 Old 1st Jul 2012 at 3:59 PM
Originally Posted by SharaRose
That is normal and not harmful.

I don't think this is normal- I've had this problem, but not until I've got some way in to building a world. In my case I linked it to being connected to the textures I was using, or perhaps the texture map used by layer. I've never seen it on a blank world, though- all of the instances I've seen people report have been in almost completed worlds.

Sococo, what are your computer specs? I wonder if it's a memory issue. I definitely don't see this in a new world, although I did experience it in Jericho when I was playing with terrain textures:

To fix it, I had to clear the texture map of the last terrain paint layer I used, so it is quite possible a memory error.

@Volvenom- you cannot recolour them, if sococo's experience is the same as mine then it's a gap in the terrain at the chunk boundaries, so showing the background through.
Test Subject
Original Poster
#6 Old 1st Jul 2012 at 5:39 PM
yeah i`ve barely done anything to the world. i certainly have not done any terrain/texture work besides lowering it and flattening. my specs are as follows:

Processor : Intel Core 2 Duo E6750 2.6 Gz
CPU Cooler : Zalman Blue LED Cooler
Power Supply : CoolerMaster 650W
Physical Memory : OCZ Reaper Edition HPC 4GB (4 x 1G DDR2)
Video Card : ASUS Radeon 3850HD GDDR3 PCI-E
Hard Disk : Western Digital 160GB
DVD-Rom Drive : Sony DVD RW DW
Operating System : Windows 7 Ultimate Professional 32bit

i really hope it`s not memory as i just bought this computer although off of kijiji it`s been pretty solid.
The Camera Eye
retired moderator
#7 Old 2nd Jul 2012 at 2:23 AM
Try a test: drag your Documents\ Electronic Arts\ The Sims 3 and Documents\ Electronic Arts\ The Sims 3 Create A World tool folders to the desktop. Run CAW to generate a fresh set of files, then copy that world into your CAW files. Does the problem show up now? If you create a fresh world, does the problem occur?
Test Subject
Original Poster
#8 Old 3rd Jul 2012 at 12:29 AM Last edited by Sococo. : 3rd Jul 2012 at 1:33 AM.
Default gave that a whirl
hmm so far so good. i dumped the original "The Sims 3" and "The Sims 3 Create a World" files on my desktop and rebooted CAW. i got scared for my Sims 3 folder for a sec didn't realize starting up CAW would re-create these files. but i guess that would be why you told me to back 'em up on the desktop LOL.

anyway thanks simsample once again for your patience and input. i will keep my fingers crossed for now!

edit: ok so everything was fine. then as soon as i clicked the terrain paint tab i got the lines. this time they were all over the map in chunk boundary grid. i made an ugly animation plus attached the separate images below. i'm not alarmed yet as they go away when i move the non-routable paint slider down to zero. hope it stays this way *sigh*
The Camera Eye
retired moderator
#9 Old 3rd Jul 2012 at 1:27 PM
Eek, I've never seen red seams before! When I had this in my game, it was definitely a gap between the chunks so that I could see the background through (and this colour changed according to which colour ramps, if any, I was using).

That routing opacity slider is dodgy though, I notice that when I've been using CAW for a while it will suddenly slide all the way up, so I can't see what I'm painting. I suspect CAW's buggy memory management for that, too- so maybe this is connected to that.
Top Secret Researcher
#10 Old 3rd Jul 2012 at 7:04 PM
I know that the main issue is probably solved, but if you plan to make the most recent pictures a world, I'd take a look at the unroutable terrain, make sure there are no small open spaces where CPUs could spawn and get stuck.

Why did I move here? I guess it was the weather.

Test Subject
Original Poster
#11 Old 4th Jul 2012 at 4:42 AM
welp. decided to upgrade to 1.34 and re-download CAW. my next experiment is going to be to not flatten down the world to just above the water level. leave it "floating" as it were until i'm ready to work on the edges at which point i'll just work my way around the map by area. or hell maybe i'll try a distant terrain to hide some of it or something. i'll update later with how that goes.

the world seemed fine as long as i had the non-route paint slider down but i dunno it just seemed to screwy so i start again for the millionth time lol. thanks guys!!
Lab Assistant
#12 Old 4th Jul 2012 at 6:12 AM
From what I gathered (don't quote me on this) but I think the seams or 'tears' you're referring to are the chunks that the world has to render. I think it may be caused alot more often by a not so good graphics card and high CPU usage. I have the same problem but it's caused no problems and I've been using CAW for about a year and a half now. But like I said don't quote me on it as I've never seen the routing underneath the whole thing...although I never looked...

Smile. Your Days Are Not Numbered Yet.
Test Subject
#13 Old 4th Jul 2012 at 4:05 PM
I've seen it a million times. Lovevslust is correct, I'm currently using a medium map and it seems to be dividing the map up into quadrants - if I turn down the LOD Transition Distance, it's pretty easy to see where the grid and the "separations" meet up. If it's bugging you in CAW, I've always been able to fix it by smoothing or flattening the area - only once has it been indicative of a problem - and the issue was it that it was at the base of a mountain and I'd made the terrain unroutable. It still looked fine in game though (no visible tearing) even though I couldn't get there.

Unless you can see it in EIG, I wouldn't worry about - I'd just smooth/flatten it if you plan to put a road there. I don't know the actual cause but I suspect it's slight gradation differences in the two parts of the map. I say this because I can only use 4 colors in CAW (Grass, Shale, Dark Sand, and Dry Sand) so I wouldn't suspect terrain paints/textures as the issue, since my entire world is default green and I've seen this in the map I am working on. Also - if you are right at those boundaries, and you place a road, and then drag the road around some until you've got a curve or two, you will see the "tears" become more pronounced. I believe that this is because roads tend to smooth the areas on either side of them to some degree - when you move it around, you are effecting the ground level, even if it's a minor way.

That's my two inexperienced cents.
The Camera Eye
retired moderator
#14 Old 5th Jul 2012 at 10:37 PM
@lovevslust and adentonclark- In my case it was something that suddenly occured. I had made a (very large) world, and was experimenting with changing some of the terrain paints. At this point I had been working on the world for over a year, and it had 150+ completed lots on it. I changed a terrain paint and then imported a terrain paint mask, and then the chunk seams were visible. It was very apparent- before, I had not been able to see the seams at all, and after I edited the terrain paint layer, they were very visible.

I managed to fix it by deleting that layer of paint completely and then recreating it, but I had it happen several more times with that world and I would have to backtrack to get rid of it. It's not a performance or graphics card issue because during the time that I was working on that world I built a new computer, and I saw it on that new machine too (which had a much better graphics card). Others have reported this phenomenon too- this is one I can think of offhand:

So for my problem I narrowed it down to be triggered by my terrain paint layers- but it could feasibly be caused by a memory problem, since CAW can only use around 3.5GB RAM max and seems to have a memory leak of some kind. The fact that my world was very large (file size) could be relevant- and the fact that sococo only has 4GB RAM could be, too.
Test Subject
Original Poster
#15 Old 6th Jul 2012 at 4:10 AM
i've narrowed it down to being triggered as soon as i start playing with terrain sculpting/painting. like if i open a new world and change the base grass and turn up non-routable terrain paint i see nothing. HOWEVER as soon as i build up a little mountainage, and then turn up non-routable paint again, THEN i see the seams in red. if i turn the paint back off, they disappear. for now i'm not too too worried however i did see it in game with the last world i scrapped (they were a greyish colour though like the typical "lot/road tears" we've seen) and it was most likely because i had started putting down roads and the terrain levels were very heavily sculpted with lots up in hilly areas etc. this sort of throws off the whole idea of my world now but i'll keep trying lol.

thanks everybody for your input!! too bad i just bought this comp and thought 4 gigs would be loads for now ha! wish they could have made CAW less of a finnecky, ram hogging butthead lol
The Camera Eye
retired moderator
#16 Old 6th Jul 2012 at 10:33 PM
I hope it doesn't show up again for you, Sococo! I wish I could find a sure fix for it, will keep an eye out for any information.
Lab Assistant
#17 Old 13th Jul 2012 at 7:05 AM
@Simsample: Really?! The case that it may 'leak' and is caused by memory is most likely why my tears are seen almost always in every world I make before and after I start editing them(I always start with flat maps). I'm running on a laptop to make my worlds now and it does not have a very good memory when it comes to CAW. Neither did the PC I had been using previously. So yes, mainly it could very well be a memory problem. Thanks Simsample for bringing that to my attention...

Smile. Your Days Are Not Numbered Yet.
Lab Assistant
#18 Old 11th Mar 2019 at 3:22 PM
Hello guys, i know this topic is very old, but i've got the same problem. I've got a medium map and all boundaries are broken ): first, i deleted the create a world folder, so a new one appeared and i copied my world into it. then i exported the height map into a totally new world (just the height map, nothing else). and even though it was a new folder and a new world without any paint, the boundaries stayed broken. I don't know what to do anymore. Maybe someone has some advises for me? ):

and another problem ):
I want to replace the 4 default terrain paints with custom ones or from other EPs. I found this tutorial, scrolling a bit down: Creating Your Own Terrain Paints
I tried following the steps. I opened the original grass paint (let's call it A) in gimp with the dds plugin. then I opened the other terrain paint (B) i want to use as default, in gimp too. so they are both loaded "next to each other" (i am so sorry for my english, i hope you can understand *facepalm* ). then i copied B into A, it seemed to work in gimp. then i deleted B. Now i got trouble.
In step 3 i have to "Go to File > Save As and select .dds from the Format dropdown menu" - BUT there is no dropdown menu. i just can "save as" and that's it. No menu at all.
So, every step after that i couldn't do either. so no saving, I directly exported as dds, put it into the caw folder where it belonged and started caw. it recognised my default replacement, because the green went to the darker colour i wanted to... but the texture looked horrible. I don't know the english word, but it looked like millions of green ants xD no nice texture, but like these "ants" you got on TV when the programs ended in the evening (yes, old times^^) but just green.
Has anyone an idea or a solution?

i hope you all have a nice monday <3
Back to top