Replies: 2 (Who?), Viewed: 4146 times.
Test Subject
Original Poster
#1 Old 27th Mar 2013 at 9:15 PM
Default Need Help Please
Hi. I'm trying to build a world in CAW but am unable to use the Edit In Game function. When I click on Edit In Game the game Launcher opens and nothing else happens.

My game is up to date (1.50 patch) and I have all the expansion packs including University Life. I have the latest CAW program. My games were all downloaded from Origin which is also up to date.

Also, all of my executable files [TS3W.exe, TS3.exe, and the expansion pack executable files (example - TS3EP09.exe)] open Origin first and then the Launcher. None of them go straight to the game itself. I am unable to bypass the launcher.

I've been searching for a solution for two days and nothing I have found works. Thanks for your help.
Advertisement
Forum Resident
#2 Old 28th Mar 2013 at 12:52 AM
I've seen many people having the same issue, and the previous workarounds have not worked for them. I don't have the problem, so I haven't been able to troubleshoot it. Maybe we can try some things, and see if we can't figure it out.

The first thing I would try is downloading zaide_chris' batch file, get it here
http://www.modthesims.info/showthread.php?t=453161
Plop it on your desktop. It will look like this:


How to use:
  • With Caw closed, find your .world file located in Documents/Electronic Arts/Create a world/UserToolData/Worlds
  • Click and drag and drop it over the EIG batch file
This will pop up:



Wait a few seconds, and the game should open up, although, people have been reporting the launcher still opens.


Next I'd make sure all my EP's are patched & up to date. One time I was having problems with caw, and even though the base game was up yo date, some of my EP's were not. I use this to check.
The Sims 3 Patch Downloader


If all is good there, I'd go on to pulling my entire Sims 3 folder out of my Documents/Electronic Arts folder. The game will generate a fresh one. Save your old one temporarily to your desktop because the new one will not have all your installed content, saves, and presets in it. If this isn't the problem, we can put it back.

Try these things, and report back. Maybe we can find some other people who can suggest other things to try. Before you start any of this, I would make a backup of your world for safety sake. Just in case.
Screenshots
Attached Images
 
Test Subject
Original Poster
#3 Old 28th Mar 2013 at 7:13 AM
Thanks so much for your reply. I really appreciate your help. Here's what I've done:
  1. Tried using the batch file. It opened Origin, then the launcher.
  2. Ran the Patch Downloader. Thanks so much for that link. Six of my EPs/Stuff Packs needed updating so I did that. EIG still only opened the launcher as did the batch file.
  3. Tried the Clean Folder method again (I had tried this previously). Tried both the regular way to EIG and also the batch file again. It still did not work.

I'm at a loss here. My base game was purchased in December as a bundle with Seasons. I'm wondering whether the new base game bundles have some sort of new DRM on them. I know I can't install the games (I've uninstalled and reinstalled twice) without installing Origin. It's not an option for me like it is for most people. Origin is installed first without asking me whether I want it or not. If I uninstall Origin and try to run the game I get an error that says: "Origin is required to play this game".

Thanks again for your help.
Back to top