Replies: 31 (Who?), Viewed: 1133 times.
Page 2 of 2
Test Subject
Original Poster
#26 Old 27th May 2020 at 2:27 AM
Quote:
Originally Posted by Lady M.
I just installed Sim City 4 and have the exact same problem. Additionally, any downloaded terrain I load into Simcity loses its roads. I'm on a Mac, using Sims 2 Super Collection rand SimCity via Steam. I uploaded a terrain, if anybody is willing to take a look.


I am not getting the your Sim City 4 terrain to load roads either, I truly think its because we are on Macs as Mac computers are not the best when it comes to PC games.
Screenshots
Top Secret Researcher
#27 Old 27th May 2020 at 8:01 AM
Quote:
Originally Posted by Colors100
I am not getting the your Sim City 4 terrain to load roads either, I truly think its because we are on Macs as Mac computers are not the best when it comes to PC games.


I play on my iMac and I have downloaded a few terrains from MTS and they all worked fine from what I can remember and the roads were there.

What ever the problem is it is not that terrains made with SimCity 4 won't display the roads on Macs. So there is some other issue at work from what I can tell.

Sorry that I am not able to be more helpful.

for info on changing the Mac Open File Limit check out my post here http://www.insimenator.org/index.ph...html#msg1628939
Curiosity killed the cat,
but satisfaction brought it back.
Lab Assistant
#28 Old 27th May 2020 at 10:16 AM
Quote:
Originally Posted by lordtyger9
I play on my iMac and I have downloaded a few terrains from MTS and they all worked fine from what I can remember and the roads were there.

What ever the problem is it is not that terrains made with SimCity 4 won't display the roads on Macs. So there is some other issue at work from what I can tell.

Sorry that I am not able to be more helpful.


Thanks for having a look at the problem you guys, I really appreciate it! I think the problem is with terrains created on a mac (with a recent SC4 version, maybe inc ennection with the 64-bit update that apparently caused a couple of incompatibility issues). I can download terrains into TS2 with no problems. When I open the same terrains in SC4 (not all of them can be imported though) they work fine in SC4 but don't have roads when I save and put them back into TS2. I think this is the point where I'll have to get a Windows Partition so I can look at the files. Probably it's some tiny thing that gets changed while saving and prevents the road layout to be read by the game. This will probably take me a while though....

Don't believe in the 60's, the golden age of pop
You glorify the past when the future dries up
Heard a singer on the radio late last night, He says he's gonna kick the darkness 'til it bleeds daylight
I...I believe in love
Theorist
#29 Old 27th May 2020 at 9:03 PM
Quote:
Originally Posted by Lady M.
Thanks for having a look at the problem you guys, I really appreciate it! I think the problem is with terrains created on a mac (with a recent SC4 version, maybe inc ennection with the 64-bit update that apparently caused a couple of incompatibility issues).


How annoying! Hope you can find a workaround.

My new downloads are on my Pillowfort
Field Researcher
#30 Old 29th May 2020 at 11:28 PM Last edited by muridae : 3rd Jun 2020 at 1:02 AM.
I should be able to play compare and contrast to check whether the disappearing roads are a problem caused by the 64-bit update of SimCity 4 for Mac, though it may take me a while as I'm currently trying to rebuild my system on a replacement SSD after a hard drive died on me. But I've just checked the bootable clone of the system I used for file recovery, and it was taken before I updated from version 1.1.1 to 1.2.1, so I can try exporting SC4 files from both versions.

(This is largely because I deliberately took the clone backup before updating either SimCity or Sims 2 Super Collection to the new version. )

I'll let you know what happens.

ETA: So far I've done the following tests:
  • Copied Driftwood.sc4 from Sims 2 Super Collection 1.2.4 and imported into SimCity 4 1.2.1. Added a piece of road, saved. Copied *.sc4 file back to Sims 2 and created hood from it. No roads.
  • Copied Driftwood.sc4 from Sims 2 Super Collection 1.2.4 and imported into SimCity 4 1.2.1. Changed name of city and made no other changes, saved. Copied *.sc4 file back to Sims 2 and created hood from it. No roads.
  • Copied Driftwood.sc4 from Sims 2 Super Collection 1.2.4 and imported into SimCity 4 1.2.1. Exited after import without saving. Copied *.sc4 file back to Sims 2 and created hood from it. Roads are okay.

So it looks like any save at all makes the roads disappear, not just road-related edits. I've definitely still got both Sims 2 Super Collection 1.2.3 and SimCity 1.1.1 on my bootable clone, so I will try all possible combinations between the two to try to identify which of the two apps is the culprit. I'm hoping I can also try my old Windows versions of both, to do a three way comparison, but as my Bootcamp partition is on the dying disk that will definitely take a while.

ETA2: I've now tried importing the SimCity 4 1.2.1 created files into Sims 2 Super Collection 1.2.3, and they behave the same there (no roads). So it looks like the bug is in the 64-bit version of SimCity 4, and not Sims 2 Super Collection. I'll test creating files in SimCity 4 1.1.1 and importing them into both versions of Sims 2 Super Collection next, but first I have to retrieve that version from my backups.
Test Subject
Original Poster
#31 Old 7th Jun 2020 at 7:58 PM
Quote:
Originally Posted by muridae
I should be able to play compare and contrast to check whether the disappearing roads are a problem caused by the 64-bit update of SimCity 4 for Mac, though it may take me a while as I'm currently trying to rebuild my system on a replacement SSD after a hard drive died on me. But I've just checked the bootable clone of the system I used for file recovery, and it was taken before I updated from version 1.1.1 to 1.2.1, so I can try exporting SC4 files from both versions.

(This is largely because I deliberately took the clone backup before updating either SimCity or Sims 2 Super Collection to the new version. )

I'll let you know what happens.

ETA: So far I've done the following tests:
  • Copied Driftwood.sc4 from Sims 2 Super Collection 1.2.4 and imported into SimCity 4 1.2.1. Added a piece of road, saved. Copied *.sc4 file back to Sims 2 and created hood from it. No roads.
  • Copied Driftwood.sc4 from Sims 2 Super Collection 1.2.4 and imported into SimCity 4 1.2.1. Changed name of city and made no other changes, saved. Copied *.sc4 file back to Sims 2 and created hood from it. No roads.
  • Copied Driftwood.sc4 from Sims 2 Super Collection 1.2.4 and imported into SimCity 4 1.2.1. Exited after import without saving. Copied *.sc4 file back to Sims 2 and created hood from it. Roads are okay.

So it looks like any save at all makes the roads disappear, not just road-related edits. I've definitely still got both Sims 2 Super Collection 1.2.3 and SimCity 1.1.1 on my bootable clone, so I will try all possible combinations between the two to try to identify which of the two apps is the culprit. I'm hoping I can also try my old Windows versions of both, to do a three way comparison, but as my Bootcamp partition is on the dying disk that will definitely take a while.

ETA2: I've now tried importing the SimCity 4 1.2.1 created files into Sims 2 Super Collection 1.2.3, and they behave the same there (no roads). So it looks like the bug is in the 64-bit version of SimCity 4, and not Sims 2 Super Collection. I'll test creating files in SimCity 4 1.1.1 and importing them into both versions of Sims 2 Super Collection next, but first I have to retrieve that version from my backups.


Thank you so much for working on this! :D
Field Researcher
#32 Old 10th Jun 2020 at 8:56 AM Last edited by muridae : 10th Jun 2020 at 5:45 PM.
@Colors100 - I've now managed to restore my SimCity4 version 1.1.1 from backup, and can confirm that it's definitely SimCity4 version 1.2.1 that's the problem.

New Tests:
* Copied Driftwood.sc4 from Sims 2 Super Collection 1.2.3 and imported into SimCity4 1.1.1. Added a piece of road, saved. Copied .sc4 file back to Sims 2 and created hood from it. All roads intact.
* Copied the same .sc4 file from SimCity4 1.1.1 to Sims 2 Super Collection 1.2.4 and created hood from it. All roads intact.

And it gets better:
* Loaded the SimCity4 region where I'd done my tests at SimCity4 1.2.1. Version 1.1.1 couldn't see the previously created cities - there were just blank squares where they used to be.
* Put one of the SimCity4 1.2.1 created SC4 files into Downloads of SimCity4 1.1.1 and attempted to import it into SimCity4 1.1.1 as a new city. The game couldn't even see that there was a file in Downloads to import.
* Put one of the SimCity4 1.1.1 created SC4 files into Downloads of SimCity4 1.2.1 and imported it. No problems. (I'd expected this, as both versions can see the pre-created regions just fine.)

Time to report it to Aspyr as a serious bug, I think. Now if only my login details still worked... they seem to have broken those as well at some point. :-(

My second machine is an elderly iMac that can only run High Sierra at maximum, so it will always be able to run the 32-bit versions of the games. I think I'm going to leave SimCity4 1.1.1 running on it and just ignore the constant nags to update, at least until the prompt is for version 1.2.2 or whatever...

If anyone else wants to revert back to 1.1.1... the games are tied to your Mac App Store account, so can't be shared. But if you have a Time Machine or other complete backup that goes back earlier than 19 February 2020 when the game was updated, you can restore it from backup. It's a single containerised app file, so all you need to restore is Applications/SimCity4 Deluxe Edition. I had to redo all my options settings again once I got in the game, and (as stated above) it won't see anything you've created in SimCity4 1.2.1, but I'm not seeing any other issues with having backed out to the older version.

There is a "report a bug" option on this Aspyr support page:

https://support.aspyr.com/hc/en-us/requests/new

I will be reporting it, and I urge anyone else affected to do the same thing. The more of us who mention it, the more likely Aspyr are to think it worth fixing...
Page 2 of 2
Back to top