Replies: 3 (Who?), Viewed: 551 times.
Lab Assistant
Original Poster
#1 Old 30th Jul 2020 at 10:44 PM
Default Objects placed into slots turn invisible?
Trying to make the fast lane trophy cabinet something that can actually hold items rather than just sitting there, but the slots don't seem to be working and I'm not entirely sure why. I cloned a coffee table to use its slots so maybe that's why?

*flops about like a fish*
Trainee Moderator
staff: trainee moderator
#2 Old 30th Jul 2020 at 10:52 PM Last edited by zoe22 : 30th Jul 2020 at 11:06 PM.
I had a problem with slots and tbh still don't really understand them! But what I did was, turn on the joints and slots buttons at the top of the 3D viewport thing, so they should all show up at the same time, I think the slots are yellow and the corresponding joints are green? 
Then you might need to select the joints that match each slot, and click on the matching slot, and I believe they should sort of snap to the position where you placed the slot. And then hopefully the slots will function in game  

edit: okay I'm actually trying to recreate this now and it's not working :p
So I'm sorry about that lol! Basically for me it wasn't working and then I was trying to figure it out and realised the joints were not in the same position as the slots, and I swear they just sort of snapped together...
If I work it out I'll let you know 
Or maybe someone actually knows loll

But I think you could just move the slot to the same place as the matching joint
Lab Assistant
Original Poster
#3 Old 30th Jul 2020 at 11:33 PM Last edited by Hydrasis : 31st Jul 2020 at 1:25 AM.
What's weird is that tsrw said that it automatically moved all of them for me, so not its just showing the joints at the bottom for where I'm assuming a sim would stand and the slots where I placed them, with no overlap where the slots are. o.o; going back to an older version of the project file to see where I screwed it up

edit: Ok so i had deleted a few of the joints, assuming that none of the joints were attached to the slots on the table. Seems all the ones labeled S may have been the ones all the slots had been assigned to and I hadn't noticed since the joints for the slots didnt go missing until after I had reopened tsrw. Not sure what to do about it, since I don't want sims reaching through it to get or view items and I dont want sims giving routing errors because the items they want to view they can't (assuming thats how this works for the coffee table anyway).

*flops about like a fish*
Lab Assistant
Original Poster
#4 Old 31st Jul 2020 at 4:56 PM Last edited by Hydrasis : 31st Jul 2020 at 5:33 PM. Reason: forgot stuff to mention
Alright so, got the slots sorted out but now I encounter a new problem in that the glass of the object means sims can't really interact with the items once placed and you can't take the items out of it (unless you move it to family infentory and back). Any way to fix that aside from making it without the glass?

There's also the footprint that's acting up, I tried to change it in tsrw (since it has a selection for 3x1) but it doesn't seem to be working as it shows the original coffee table's footprint when in game. I'm looked up trying to fix it but it's all just selecting one of the dropdown options when in the footprints tab/prompt thing.

edit: nvm, footprint works now but the object blocking what it holds is still a thing

*flops about like a fish*
Back to top