Replies: 16 (Who?), Viewed: 987 times.
Instructor
Original Poster
#1 Old 3rd Aug 2020 at 3:42 PM Last edited by CrystalFlame360 : 22nd Aug 2020 at 1:54 AM. Reason: Described an additional issue. I didn't want to make two topics in one day.

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Object Error Stack Trace Will Not Save and Subhood Thumbnails Missing
I don't know if this is in the correct category, but considering what the topic is I thought it made sense. I'll also apologise for making yet another help topic.

My object error stack traces will not save.

I tried looking it up on Google, but I was just getting results telling me what an object error was. I browsed the help forums here, but still couldn't find anything related to this issue specifically. I was only finding where the stack trace was located, which doesn't help in this case.

In my previous install, whenever I got an object error, the stack trace was always stored in C:/Users/<username>/Documents/EA Games/The Sims 2/Logs. In addition, it would tell you what the error was.

In this install, whenever I get an object error it will simply say:
"An error has occurred in object <name> #<number>,
The stack trace could not be saved."

I play with debug mode enabled, just so I can easily set things up. I don't mess with the risky features.

Because I play with debug mode on, I get object errors whenever the game has a little wobble. I simply reset if I can, and move on. I find seeing what the error was quite interesting, but I can't now and it's frustrating.

Subhood thumbnails are also missing, storytelling doesn't work, and I can't take videos or screenshots.





I play on Windows 10 if that helps. My previous install was also Windows 10 and had no issues.

I don't know what's wrong here, so any help would be appreciated.
Screenshots
Instructor
DELETED POST
Original Poster
4th Aug 2020 at 1:01 AM
Default Images
This message has been deleted by CrystalFlame360. Reason: Edited the first post to include information. Sorry.
Advertisement
Lab Assistant
#2 Old 18th Aug 2020 at 5:29 PM
No answer to this, but just wanted to say I've had this start happening to me today too, along with jump-bugging with that sim.
1001001
retired moderator
#3 Old 18th Aug 2020 at 7:20 PM
For both of you it could be a problem with read/write access to the game. Exclude your userdata files from your antivirus on-access scans and if all else fails, generate a fresh userdata folder and copy your saves/ CC/ settings over to the new one.

I will choose a path that's clear- I will choose free will
-RUSH- -RADIO- -ARCHIVES-
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
Lab Assistant
#4 Old 18th Aug 2020 at 7:46 PM Last edited by sillysoraya : 18th Aug 2020 at 9:22 PM.
Do you mean the userdata folder under the latest expansion pack/tsdata/res? or a different folder/file? And would simply removing it from the folder generate a new one when you next start the game?

Edit: Removing my 'The Sims 2' folder from 'My Documents' and letting the game create new ones, then going into the default neighbourhoods allows screenshots to be taken like normal (one of the things that stopped working recently, same as OP). However, when then quitting the game, and going straight back in without changing anything or putting any of my old files in, it no longer works again. Am wondering if it's something to do with a file that only appears when going into the game a second time? And a file that the game uses from the program files.... tricky! Not a clue which one it may be but I'm still investigating

2nd edit: it seems to be a problem with the graphicsrules file, at least for me, which makes sense as I got a new graphics card fairly recently so was editing those files. I used the graphicsrule maker from here and it seems to be working with regards to taking screenshots and them saving again. Fingers crossed it stays working when I add my old game files back in e.g. neighbourhoods, downloads, cameras etc.
1001001
retired moderator
#5 Old 19th Aug 2020 at 12:28 PM
Yes I meant the userdata, as in the place where your user files are (in the Documents folder) as opposed to gamedata (the installation files for the game). Take a look here:
Game Help:Game Problem-Remove All User Fileswiki

You mention the game works at first, when creating a new Sims 2 folder, but upon re-load it doesn't. Again, this points to there being a file lock or access problem with your userdata. Something is preventing the game from reading and accessing the files correctly. First thing to do is to make sure your antivirus program is not trying to scan the files as the game boots. The Graphics Rules file will only affect the game appearance, and shouldn't affect whether the game can write screenshots to disc at all.

I will choose a path that's clear- I will choose free will
-RUSH- -RADIO- -ARCHIVES-
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
Lab Assistant
#6 Old 19th Aug 2020 at 12:34 PM
It's all working again now after doing what I mentioned in my post above, so fingers crossed it says that way. Have tested in a couple of my neighbourhoods and families and things are working as before which is a relief! It was definitely nothing to do with antivirus as I tested with that on or off many times during the testing and playing around with it all last night.
1001001
retired moderator
#7 Old 19th Aug 2020 at 1:16 PM
Cool! Well done for fixing it, I hope it continues to work! Have fun.

I will choose a path that's clear- I will choose free will
-RUSH- -RADIO- -ARCHIVES-
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
Instructor
Original Poster
#8 Old 19th Aug 2020 at 3:24 PM
I didn't know this thread got replied to until recently. I was patiently waiting for a reply, while just putting up with it.

I still have this issue, as I couldn't put heads or tails on what it was (that is a real saying, right?). I don't think it's anything to do with the antivirus, though it wouldn't hurt to check later when I'm on the PC (I'm on my tablet at the moment).

About the userdata, doing that tutorial should sort the screenshot, thumbnail, and the object errors not saving, right? Or just one of these things. Do I also need to sort certain permissions out? I'm confused

When a game is predictable, it's boring.
That goes for any medium that isn't life.
That's why The Sims 2 is my favourite sims game.
It has elements of unpredictability and everything feels more involved.
The Sims 4 is another story altogether...
1001001
retired moderator
#9 Old 19th Aug 2020 at 5:48 PM
Don't touch permissions; in your Documents folder they are inherited, if you have something changing your file permissions you have bigger problems that Sims 2! If you generate a new Sims 2 folder, test the game to see if it works (a clean startup), and if it does then it tells you the problem was with your old files so you can work to sort that out. If it doesn't work then it's either your game install files that are the problem, or something else going on with your computer.

I will choose a path that's clear- I will choose free will
-RUSH- -RADIO- -ARCHIVES-
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
Instructor
Original Poster
#10 Old 20th Aug 2020 at 1:58 PM
I was going to reply to this thread last night (as far as UK time goes anyway), but I forgot.

So, before I finished playing for the night, I went into my antivirus, I use Avast if that helps, and placed all my The Sims 2 based stuff in the exceptions tab. I don't know if that has fixed the object errors, but it hasn't fixed the Sub-Hood thumbnails; they still show a green grid. I don't know if it only fixes newly created 'hoods, or what...

I didn't get to try taking pictures, or triggering an object error, as I was pressed for time, but if that hasn't worked that is when I try running the game with a new Userdata folder, right?

I realised that I had forgotten to mention a few things:
I looked into the neighbourhood folders that have the green grid thumbnails to see that the thumbnails aren't even present. My 'hoods from the previous install have not been affected; they still have their thumbnails. I tried placing the required thumbnails in my Pleasantview (one of the 'hoods with the error) and Strangetown (another one), and that hadn't done anything.

When a game is predictable, it's boring.
That goes for any medium that isn't life.
That's why The Sims 2 is my favourite sims game.
It has elements of unpredictability and everything feels more involved.
The Sims 4 is another story altogether...
Lab Assistant
#11 Old 20th Aug 2020 at 4:12 PM
Just to say me updating the graphicsrule file and resetting my user data files as mentioned above fixed both the screenshots and objects stack error Then I slowly added back in my neighbourhoods, downloads etc. good luck with yours!
Instructor
Original Poster
#12 Old 21st Aug 2020 at 2:03 AM
What did you alter in the GraphicsRules file?

When a game is predictable, it's boring.
That goes for any medium that isn't life.
That's why The Sims 2 is my favourite sims game.
It has elements of unpredictability and everything feels more involved.
The Sims 4 is another story altogether...
Lab Assistant
#13 Old 21st Aug 2020 at 8:25 AM
I used the graphicsrule maker from here https://www.simsnetwork.com/tools/graphics-rules-maker
Instructor
Original Poster
#14 Old 21st Aug 2020 at 5:15 PM
Okay, but what did you change within the GraphicsRules itself? Resolution? Because I did have to do some stuff in that file to sort out the resolution and some other graphical hiccups. Is there a setting that I missed that sorts the screenshot and object errors?

When a game is predictable, it's boring.
That goes for any medium that isn't life.
That's why The Sims 2 is my favourite sims game.
It has elements of unpredictability and everything feels more involved.
The Sims 4 is another story altogether...
Lab Assistant
#15 Old 21st Aug 2020 at 5:39 PM
I clicked auto, then sorted out resolution to fit my screen resolution, and made sure it was recognising my graphics card (it was). I didn't change any of the other settings after doing auto though!
Refreshing the userdata folder in my documents might have fixed it, or the graphicsrule maker, i'm not sure - one of them did anyway! Good luck with yours.
Instructor
Original Poster
#16 Old 22nd Aug 2020 at 1:53 AM
Well, I'm happy to say that sillysoraya's suggestion worked. I don't know how exactly, as I'd imagine it to only effect how the game looks, but I'm glad to say it has worked.

For the sake of others who may come across this in the future, I will walk you through what exactly I did.

1) Firstly, I installed the GraphicsRules Maker that sillysoraya linked on post #13.

2) I then loaded it up and ticked "Enable driver's memory manager." I proceeded to click "Save file."

3) After that, I got the following pop-up: "The following devices are still missing in the video card database. Do you want to add them?" with the name of my graphics card. I checked "Yes."

I closed the GraphicsRules Maker and loaded my game. I ran some tests and I'm happy to announce that:
▪Object Errors save in the "Logs" folder again
▪Screenshots save again
▪And lastly, any NEW subhoods I create have pictures again, as well as story telling. Subhoods added before I did the GraphicsRules fix still have a bumpy grid thumbnail, unfortunately.

I'm really thankful to those who have replied to this topic and tried to help. Due to how long it was taking for someone to reply, I was beginning to give up on getting help. But anyway, thank you and happy simming!

When a game is predictable, it's boring.
That goes for any medium that isn't life.
That's why The Sims 2 is my favourite sims game.
It has elements of unpredictability and everything feels more involved.
The Sims 4 is another story altogether...
Lab Assistant
#17 Old 22nd Aug 2020 at 8:26 AM
Yes! I'm so glad it worked for you too. The reason I considered it for myself was because this started happening around when I got a new graphics card and tried editing files myself to work with the new card, and presumed I'd messed something up along the way
Glad we've both got it fixed!
Back to top