Replies: 5 (Who?), Viewed: 321 times.
Test Subject
Original Poster
#1 Old 5th Aug 2020 at 3:52 AM Last edited by lego_block : 5th Aug 2020 at 4:21 AM.

This user has the following games installed:

Sims 3, Ambitions, Pets, Supernatural, Seasons, University Life, Into the Future
Default Packages don't work, help please
Hey, I'm new here
So I downloaded the sims 3 a year ago with lots of cc, and uninstalled it because you know, the feeling of playing the sims for periods of time and then you don't play it anymore.
Ok so I downloaded it again, and I have the problem where my packages just don't work, even the "nointro" and "nobuildsparkles" ones.
And yes, I tried a lot of stuff, checking if i was putting it in the right place, if the files were misspelled or something, tried to uninstall and install the game again, and they just don't seem to work. I don't really know if it has anything to do with my version, it says "1.0.615.00107", but even with that version things used to work really well before.
I don't really know what I'm doing wrong but if someone can help me I would be really thankful
Advertisement
Mad Poster
#2 Old 5th Aug 2020 at 5:05 AM
Where exactly are you putting your package files? If they are going into a Framework inserted into the TS3 user game folder in Documents, then that will never work on Patch 1.06. That structure requires Patch 1.12 or higher, which is when EA changed things. Plus, for other reasons, running a totally unpatched game would be less than desirable. Not sure where you have "downloaded" from since neither Origin nor Steam provide an unpatched game like that. If what you really meant is that you installed it from a retail disc, then the SuperPatcher should be run to bring the game up to Patch 1.67.
https://help.ea.com/en-us/help/the-...3-super-patcher

Installing any Expansion or Stuff Pack from Ambitions forward will also raise your game's patch level to 1.12 and beyond. That's not as good as being up to date as far as 1.67, but at least it would make the Framework within the Documents game folder work properly.

There was a way to mod the game prior to 1.12 but it was a bit more difficult, the package files went into a location within the Program Files not the Documents area, some other changes needed to be made, and that structure isn't really currently supported anymore (plus many modern mods designed for higher patch levels will tend to not work correctly).
Test Subject
Original Poster
#3 Old 5th Aug 2020 at 5:00 PM Last edited by lego_block : 5th Aug 2020 at 5:29 PM.
Oh ok ok. So it makes sense that it worked before because i had installed some expansions and those could have in some way updated the base game for atleast the mods to work.
I will use the superpatcher then, thank you so much, i was so lost :")

i also downloaded it from a Youtuve chanel, because i had it in a disk but it got lost years ago.
Test Subject
Original Poster
#4 Old 5th Aug 2020 at 7:13 PM
Now i have the problem where the launcher just takes me to a window that say "enter your registration code here"
I have all the problems in the world I swear I just wanted to play the sims xd
Mad Poster
#5 Old 5th Aug 2020 at 7:27 PM Last edited by igazor : 5th Aug 2020 at 8:13 PM.
I understand that you may have had a legit store disc at one point, but if that had been registered (or if it can be now) to your store account then you would have been entitled to the Origin download version at no extra cost. Pirated games can often not be patched up or modded properly.

You can have a chat with EA customer support if you like, to try to retrieve the game code you might have had registered in the past. But if they aren't very sympathetic, your only other choice would probably be to buy the game and the packs you want to play.
Test Subject
Original Poster
#6 Old 5th Aug 2020 at 7:56 PM
Yeah, I'll see if I can at least make it work with the expansions I had previously or something. If not, I just give up because I was dealing with this problem since like 2 days ago, sorry :")
Back to top