Replies: 6 (Who?), Viewed: 343 times.
Test Subject
Original Poster
#1 Old 11th Aug 2020 at 9:24 AM Last edited by SimyourLife : 11th Aug 2020 at 10:13 PM. Reason: Card numeric typo

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life, Island Paradise, Into the Future
Screen tearing driving me cray cray (NVIDIA GTX 1050)
Everything is up to date, FPS capped at 60 which is my Display Adapter’s recommended setting, Vsync is on & forcibly now, through Nvidia Profile Inspector... I have tried pretty much everything except reinstalling my card, y’all... I’ve researched this subject to death.
Sorry to be vague- grateful to supply more info, but just not sure what you’d need. Please help me beat the streak!
Advertisement
Mad Poster
#2 Old 11th Aug 2020 at 11:39 AM
Do you get any better or different results if you set the Max Frame Rate Setting in Inspector (or the Nvidia Control Panel) to a value just under 60 like 59 or 58.something? Any relief from the screen tears if you run the game in windowed mode?
Mad Poster
#3 Old 11th Aug 2020 at 5:45 PM
Following along what igazor said, go to your display advanced setting. Make sure your GPU and monitor refresh rate are both set the same 60/60 or 59/59

Sanity is overrated.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Test Subject
Original Poster
#4 Old 11th Aug 2020 at 9:58 PM Last edited by SimyourLife : 11th Aug 2020 at 10:13 PM.
@igazor: Hi! I am fangirling a bit right now. Anyway, no such luck on setting FPS lower. In fact, when I set Max Frame Rate in the Nvidia Control Panel, it strangely, made the tearing worse. I am solely using Nvidia Profile Inspector to cap my FPS for this reason. Windowed Mode is the only relief I get- I cannot see any tearing. Thank you for taking the time to assist me!

@nitromon: The max resolution for this card is 60Hz, but I don’t know how to check my GPU output on my computer, if that is what you are advising unless maybe through Nvidia Inspector...? I have confirmed that my monitor is set to 60Hz (the next option is 48Hz.) Thanks for taking the time to lend your knowledge!
Mad Poster
#5 Old 11th Aug 2020 at 11:21 PM
Quote:
Originally Posted by SimyourLife
The max resolution for this card is 60Hz, but I don’t know how to check my GPU output on my computer, if that is what you are advising unless maybe through Nvidia Inspector...? I have confirmed that my monitor is set to 60Hz (the next option is 48Hz.) Thanks for taking the time to lend your knowledge!


- right click on your desktop and go to "screen resolution"
- click "advance settings"

This will open up the GPU/monitor dialog

- Under "monitor" tab, you can see what the "screen refresh rate" is set.
- Under "Intel Graphics and Media Control Panel" tab, you can see what the refresh rate is set for the GPU and the corresponding monitor.

Make sure they match. Mine likes to put the GPU on 59 while monitor on 60. (if you are playing window mode) Make sure in your TS3 setting, you also chose the right refresh. (if you are playing full screen)

(It's important you check this b/c most systems use Optimus to switch between Nvidia and Intel HD, basically it runs the Nvidia through the Intel HD b/c the Intel HD is your desktop.)

Sanity is overrated.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Test Subject
Original Poster
#6 Old 12th Aug 2020 at 2:04 AM
Quote:
Originally Posted by nitromon
- right click on your desktop and go to "screen resolution"
- click "advance settings"

This will open up the GPU/monitor dialog

- Under "monitor" tab, you can see what the "screen refresh rate" is set.
- Under "Intel Graphics and Media Control Panel" tab, you can see what the refresh rate is set for the GPU and the corresponding monitor.

Make sure they match. Mine likes to put the GPU on 59 while monitor on 60. (if you are playing window mode) Make sure in your TS3 setting, you also chose the right refresh. (if you are playing full screen)

(It's important you check this b/c most systems use Optimus to switch between Nvidia and Intel HD, basically it runs the Nvidia through the Intel HD b/c the Intel HD is your desktop.)


Indeed they match. What the heck... I even tried Windowed Borderless Gaming as a workaround, but to my knowledge, there is no Edge Scrolling available & I refuse to play w/o it, so torn screen it is for now.
Thanks for responding.
Mad Poster
#7 Old 12th Aug 2020 at 4:08 AM
Actually Windowed Borderless was what I was going to suggest next but you got to it already. It's not really that bad (for most of us) to deal with no edge scrolling, in fact I find it distracting ever since I got into the habit of right-clicking to move/refocus the game camera.

In addition to the handoff between Intel and Nvidia not working as seamlessly as it should for those who actually have dual graphics, some of the more recent Win 10 updates began causing the game to act up graphically in unexpected ways beginning around this past December or so. It got better just recently with some further Win 10 and graphics driver updates -- are you all caught up on both of those? I'm running the game on a system with an AMD Radeon card myself and now find that in full screen mode I get something that can best be described as "rippling," as if there were dozens or more tiny screen tears that clear themselves up after a second whenever the game camera moves about and only while zoomed far in. But that was annoying enough for me to stay on windowed mode until it can get resolved one way or another.
Back to top