Replies: 15 (Who?), Viewed: 184 times.
Forum Resident
Original Poster
#1 Old 20th May 2022 at 1:51 PM
Default Cannot enable Design Mode of some old objects -- what resources should I fix in SimPE?
Can somebody provide me a checklist of resources I should control or fix in mesh files in order to work Design Mode correctly? I wanted to recolor some very old objects, but in-game the objects are not desinable, even though I had to fix the GUIDs in MMATs of certain objects.

Attached, you can find screenshots of an example object that's "undesignable" in-game.
Screenshots
Advertisement
Forum Resident
Original Poster
#3 Old 20th May 2022 at 9:55 PM
@HugeLunatic thanks for your link! I've did my best to go through your checklist, but it still doesn't work for those files that are "undesignable", despite tsDesignModeEnabled being present with the correct subsets. Can you take a look at these files to give feedback on what I've overlooked? http://simfileshare.net/folder/162686/
Mad Poster
#4 Old 20th May 2022 at 10:35 PM Last edited by simmer22 : 22nd May 2022 at 8:21 AM.
"wfs2bdtable002_050311" - the file is switching between "table" and "surfaces" as the subset name. Pick one and stick with it, make sure all the subset name references get fixed.

--

Only strange thing I can find in the "4esfquadrocoffeetable" file is that the MMAT says "defaultMaterial: False" instead of "True", but I don't know if that's enough to cause it to be non-recolorable.

EDIT: The MMAT does have some strange info - it has instance 0x8E1A4A40. Usually the first MMAT has instance 5000 and if there's a second it has 5001. If there are extra recolors included in the file, they get higher MMAT numbers counting up from there. Only thing I can think of.

The OBJDs also say "Please commit! (Unreadable)"
Forum Resident
Original Poster
#5 Old 20th May 2022 at 11:06 PM
@simmer22 thanks for the tip! But what could be off in vs_vita_paint and 4esfquadrocoffeetable ? I haven't noticed it yet.
Mad Poster
#6 Old 21st May 2022 at 12:30 AM
Already answered for the "4esfquadrocoffeetable" above.

The "vs_vita" files are missing the Datalist reference for the 4th line (copyright line) in the GMND, although I don't think that would influence the recolorability. Could potentially cause problems like crashing or errors.

These also have the MMAT saying "defaultMaterial: False" instead of "True", but again, not sure if that would be enough to cause it to not pick up colors.

Several of the OBJDs say "please commit" (I've seen that for a few files before, not sure why it appears). Again, I don't think this would cause the file to not pick up colors. You might want to just click "commit" where you see these, and then save the file.

Other than that I can't see anything in the files. Try changing the "DefaultMaterial" line and see if that helps, but other than that I don't know what could be wrong.

--

If you've edited the files, have you made sure to remove every instance of the original files, and also deleted cache files? If you have old copies of the files in your downloads they could still be read by the game.
Forum Resident
Original Poster
#7 Old 21st May 2022 at 12:42 AM
Quote:
Originally Posted by simmer22
The "vs_vita" files are missing the Datalist reference for the 4th line (copyright line) in the GMND, although I don't think that would influence the recolorability. Could potentially cause problems like crashing or errors.


Do you mean that adding the copyright line would cause errors, or if that reference is missing?

Yes, I've made sure there are no duplicates present. I managed to fix some other objects by either fixing the MMAT or renaming the subsets in the DesignMode references, but the Vitasims ones remain a mystery for me (multiple meshes of them aren't designable). @HugeLunatic , any thoughts?
Mad Poster
#8 Old 21st May 2022 at 1:19 AM
The Blocklist in the GMND (when you stand in the 0x0 entry) - if you look in the Blocklist it has 4 entries below the 0x0. The "Datalist Extension Reference" in the "cObjectGraphNode" should list all four, but currently has only 3 of them listed. It should be enough to add the 4th to the reference (Click "add", then change that one to "0x00000004" in "index" and "0x01" in "Enabled").

(The "Copyright" line isn't an important one for the function of the file, but if the blocklist references aren't properly set up, files can have other issues, so at least you can rule out potential crashes, etc.)

Try changing the "defaultMaterial" in the MMATs to "True" (1 in value) for the ones that currently say "false". Not sure if it helps, but it's the only thing I can think of.
Me? Sarcastic? Never.
staff: administrator
#9 Old 21st May 2022 at 12:04 PM
The copyright line will not affect anything, it's simply text and I remove them all the time. The instance numbers for an individual package shouldn't matter, not in this case. The defaultMaterial line in the MMATs will definitely cause issues. The wfs object also has mismatched subset names.
Forum Resident
Original Poster
#10 Old 21st May 2022 at 1:46 PM Last edited by Softlism : 21st May 2022 at 1:56 PM.
@HugeLunatic it seems like setting defaultMaterial to True helps, but I yet have to verify it if I've created recolors. What other issues could happen if that line is set to False? For the Recolors, does this line also have to be set to True, or only in the Mesh files?
Mad Poster
#11 Old 21st May 2022 at 2:10 PM Last edited by simmer22 : 21st May 2022 at 2:24 PM.
I think only the MMATs in the mesh should be set to "true" since this one is supposed to be the default version showing.

You pretty much know if the file is working if the design tool works and there's a recolor thumbnail showing for each of the MMATs (even if it's just one set of thumbnails, which means you only have the mesh).

Depending on which changes you've made, it's possible you also have to do changes to the recolor files.

Wasn't entirely sure about the Copyright line - didn't think it would affect anything, but the 3 files are missing the Datalist entry. Files seem to tend to have the setup correctly setup for the Copyright line if they have it. If you want to be on the safe side you can either add the reference or remove the Copyright line entirely (never know what could end up crashing your game, and missing Datalist entries are known to cause crashes - although usually it's for the more useful Blocklist entries. If they're just there for text, I don't know if they affect anything even with the missing Datalist).
Forum Resident
Original Poster
#12 Old 21st May 2022 at 5:56 PM
@simmer22 I managed to fix the recolorability of the Vitasims objects by setting defaultMaterial to True for the meshes (and some GUID fixes in the MMAT).

But there's one object from a different creator I haven't managed to make it recolorable: http://www.simfileshare.net/download/3197640/
What have I missed out in this case?
Mad Poster
#13 Old 21st May 2022 at 6:07 PM Last edited by simmer22 : 21st May 2022 at 8:02 PM.
For the "cabinet" subset, the MMAT is called "##0x1C050000!ogwindsortvcabinet1_reflective" but the SHPE is pointing to the "##0x1C050000!ogwindsortvcabinet1_cabinet" TXMT.

EDIT: Tested it out, and it's indeed this that's the problem. The file is drawing the TV texture instead of the cabinet texture. Changing the end of the MMAT name to "cabinet" works, and draws the proper textures when recoloring, which should also make it recolorable ingame.

(Doing a test recolor is something you can do if you're unsure whether an object is still having issues with the MMAT. It lets you see if it's pulling the correct resources properly).
Forum Resident
Original Poster
#14 Old 21st May 2022 at 6:48 PM Last edited by Softlism : 21st May 2022 at 6:59 PM.
@simmer22 In the MMAT, I've renamed the cabinet subset to Cabinet (because the name Cabinet was shown in GMDC), but still no recolorability.

EDIT: I haven't seen your edit when I posted this reply. I will check it out and keep you updated.
Mad Poster
#15 Old 21st May 2022 at 8:01 PM
The MMAT "name" value needs to be "##0x1C050000!ogwindsortvcabinet1_cabinet" (not the "subsetname"). Just swap "reflective" for "cabinet".
Forum Resident
Original Poster
#16 Old 22nd May 2022 at 1:02 PM
@simmer22 Eventually, I managed to make that TV cabinet recolorable by editing the OBJD: the RAW data between "Television - Floor - Expensive" and "Television - Floor - Expensive - Right" were swapped, so I fixed that and used another TV mesh as reference for the correct RAW data. So this was a more complicated case.

These days, I've learnt more about SimPE edits, so thank you for taking the time to help me out! If I stumble upon another weird unrecolorable case, I will update this thread.
Back to top